summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-10-23 12:21:18 +0000
committerRoy Marples <uberlord@gentoo.org>2007-10-23 12:21:18 +0000
commit80850908247c36882b2aba8c94b63a28ead88a1a (patch)
tree9c07a5a1b894e79100a2443804b1488c8dcf48f3 /dev-ml
parentRemove old. (diff)
downloadgentoo-2-80850908247c36882b2aba8c94b63a28ead88a1a.tar.gz
gentoo-2-80850908247c36882b2aba8c94b63a28ead88a1a.tar.bz2
gentoo-2-80850908247c36882b2aba8c94b63a28ead88a1a.zip
Fix building on non GNU platforms and keyword ~x86-fbsd, #192065
(Portage version: 2.1.3.15)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/facile/ChangeLog6
-rw-r--r--dev-ml/facile/facile-1.1.ebuild12
-rw-r--r--dev-ml/facile/files/facile-1.1-make.patch48
3 files changed, 64 insertions, 2 deletions
diff --git a/dev-ml/facile/ChangeLog b/dev-ml/facile/ChangeLog
index 506fd2194a5a..3035048fc77a 100644
--- a/dev-ml/facile/ChangeLog
+++ b/dev-ml/facile/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/facile
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/facile/ChangeLog,v 1.5 2007/10/13 10:26:45 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/facile/ChangeLog,v 1.6 2007/10/23 12:21:18 uberlord Exp $
+
+ 23 Oct 2007; Roy Marples <uberlord@gentoo.org>
+ +files/facile-1.1-make.patch, facile-1.1.ebuild:
+ Fix building on non GNU platforms and keyword ~x86-fbsd, #192065
13 Oct 2007; Markus Rothe <corsair@gentoo.org> facile-1.1.ebuild:
Added ~ppc64; bug #192065
diff --git a/dev-ml/facile/facile-1.1.ebuild b/dev-ml/facile/facile-1.1.ebuild
index c55d424669ae..6f2b3c2bd770 100644
--- a/dev-ml/facile/facile-1.1.ebuild
+++ b/dev-ml/facile/facile-1.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/facile/facile-1.1.ebuild,v 1.5 2007/10/13 10:26:45 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/facile/facile-1.1.ebuild,v 1.6 2007/10/23 12:21:18 uberlord Exp $
+
+inherit eutils
DESCRIPTION="FaCiLe is a constraint programming library on integer and integer set finite domains written in OCaml."
HOMEPAGE="http://www.recherche.enac.fr/log/facile/"
@@ -16,6 +18,14 @@ IUSE=""
DEPEND=">=dev-lang/ocaml-3.09.3-r1"
RDEPEND="${DEPEND}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix building on FreeBSD
+ epatch "${FILESDIR}/${P}"-make.patch
+}
+
src_compile(){
# This is a custom configure script and it does not support standard options
./configure --faciledir ${D}$(ocamlc -where)/facile/
diff --git a/dev-ml/facile/files/facile-1.1-make.patch b/dev-ml/facile/files/facile-1.1-make.patch
new file mode 100644
index 000000000000..7b77639d2277
--- /dev/null
+++ b/dev-ml/facile/files/facile-1.1-make.patch
@@ -0,0 +1,48 @@
+diff -ur a/Makefile b/Makefile
+--- a/Makefile 2004-09-08 10:51:02 +0100
++++ b/Makefile 2007-10-23 13:11:28 +0100
+@@ -3,7 +3,7 @@
+ include config_Makefile
+
+ compile:
+- cd src; make
++ cd src; $(MAKE)
+
+ install:
+ if test -d $(FACILEDIR); then : ; else mkdir $(FACILEDIR); fi
+@@ -14,10 +14,10 @@
+ chmod a+r $(FACILEDIR)/facile.a
+
+ clean:
+- cd src; make clean
++ cd src; $(MAKE) clean
+
+ distclean uninstall:
+ rm -fr $(FACILEDIR)
+
+ check:
+- cd examples; make FACILEDIR=../src queens.opt; ./queens.opt 8
++ cd examples; $(MAKE) FACILEDIR=../src queens.opt; ./queens.opt 8
+diff -ur a/src/Makefile b/src/Makefile
+--- a/src/Makefile 2004-09-08 10:51:02 +0100
++++ b/src/Makefile 2007-10-23 13:10:34 +0100
+@@ -28,7 +28,7 @@
+ # Version of the library to be linked with the -p (profiler) option
+ facile.p.cmxa : $(CSTR)
+ rm -fr $(CSTRCMX)
+- make facile.cmxa OPTOPT=-p
++ $(MAKE) facile.cmxa OPTOPT=-p
+ rm -fr $(CSTRCMX)
+ mv facile.cmxa $@
+ mv facile.a facile.p.a
+@@ -41,8 +41,8 @@
+ # Does not work with many modules (e.g. containing class expressions
+ facile.exp.cmxa : $(CSTR)
+ rm -fr $(CSTRCMX)
+- make fcl_stak.cmx fcl_cstr.cmx fcl_inv.cmx fcl_reify.cmx fcl_arith.cmx fcl_goals.cmx fcl_fdArray.cmx fcl_gcc.cmx fcl_alldiff.cmx fcl_sorting.cmx fcl_interval.cmx facile.cmx
+- make facile.cmxa OPTOPT="-pp inline_functors"
++ $(MAKE) fcl_stak.cmx fcl_cstr.cmx fcl_inv.cmx fcl_reify.cmx fcl_arith.cmx fcl_goals.cmx fcl_fdArray.cmx fcl_gcc.cmx fcl_alldiff.cmx fcl_sorting.cmx fcl_interval.cmx facile.cmx
++ $(MAKE) facile.cmxa OPTOPT="-pp inline_functors"
+ rm -fr $(CSTRCMX)
+ mv facile.cmxa $@
+ mv facile.a facile.exp.a