summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-09-29 18:29:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-09-29 18:29:26 +0000
commit74841044171c4797a85723a4711f9e7faf0a7997 (patch)
tree46a344e01cdc80254c0d95a8530e271f6bdc877a /dev-ml
parentFix DEPEND variables. (diff)
downloadgentoo-2-74841044171c4797a85723a4711f9e7faf0a7997.tar.gz
gentoo-2-74841044171c4797a85723a4711f9e7faf0a7997.tar.bz2
gentoo-2-74841044171c4797a85723a4711f9e7faf0a7997.zip
version bump
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-sqlite3/ChangeLog8
-rw-r--r--dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.8.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-ml/ocaml-sqlite3/ChangeLog b/dev-ml/ocaml-sqlite3/ChangeLog
index 0f803ac3ffa1..c4209748facb 100644
--- a/dev-ml/ocaml-sqlite3/ChangeLog
+++ b/dev-ml/ocaml-sqlite3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocaml-sqlite3
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ChangeLog,v 1.19 2010/04/12 06:40:32 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ChangeLog,v 1.20 2010/09/29 18:29:26 aballier Exp $
+
+*ocaml-sqlite3-1.5.8 (29 Sep 2010)
+
+ 29 Sep 2010; Alexis Ballier <aballier@gentoo.org>
+ +ocaml-sqlite3-1.5.8.ebuild:
+ version bump
12 Apr 2010; Alexis Ballier <aballier@gentoo.org>
-ocaml-sqlite3-1.5.6.ebuild:
diff --git a/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.8.ebuild b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.8.ebuild
new file mode 100644
index 000000000000..2e6bdd292df9
--- /dev/null
+++ b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.8.ebuild,v 1.1 2010/09/29 18:29:26 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+IUSE="doc +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to SQLite databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#ocaml-sqlite3"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ >=dev-db/sqlite-3.3.3"
+
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.22.0-destdir.patch"
+ epatch "${FILESDIR}/${PN}-0.23.0-noocamlopt.patch"
+ epatch "${FILESDIR}/${PN}-1.5.1-werror.patch"
+}
+
+src_compile() {
+ emake -j1 bytecode || die "make bytecode failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "make opt failed"
+ fi
+ if use doc; then
+ emake -j1 docs || die "make doc failed"
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ export OCAMLPATH="${OCAMLFIND_DESTDIR}"
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc Changelog README.txt TODO
+ use doc && dohtml doc/*
+}