summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-04-08 21:34:32 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-04-08 21:34:32 +0000
commit6fccff928d57340ace446dc798051e74c4685659 (patch)
tree51a8f2ef95f8d80ce04f6754e9a4e58e90302c7c /dev-ml
parentapp-text/evince: Bump to 2.22.1.1, bugfix release, contains our dbus patch (diff)
downloadgentoo-2-6fccff928d57340ace446dc798051e74c4685659.tar.gz
gentoo-2-6fccff928d57340ace446dc798051e74c4685659.tar.bz2
gentoo-2-6fccff928d57340ace446dc798051e74c4685659.zip
version bump
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pcre-ocaml/ChangeLog8
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-5.14.0.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-ml/pcre-ocaml/ChangeLog b/dev-ml/pcre-ocaml/ChangeLog
index adf99bae92ba..b596eba2858f 100644
--- a/dev-ml/pcre-ocaml/ChangeLog
+++ b/dev-ml/pcre-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/pcre-ocaml
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.16 2008/02/05 18:06:58 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.17 2008/04/08 21:34:32 aballier Exp $
+
+*pcre-ocaml-5.14.0 (08 Apr 2008)
+
+ 08 Apr 2008; Alexis Ballier <aballier@gentoo.org>
+ +pcre-ocaml-5.14.0.ebuild:
+ version bump
*pcre-ocaml-5.13.0 (05 Feb 2008)
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-5.14.0.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-5.14.0.ebuild
new file mode 100644
index 000000000000..0545c779f298
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-5.14.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/pcre-ocaml-5.14.0.ebuild,v 1.1 2008/04/08 21:34:32 aballier Exp $
+
+inherit findlib eutils
+
+EAPI="1"
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://www.ocaml.info/ocaml_sources/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+
+DEPEND=">=dev-lang/ocaml-3.07
+ >=dev-libs/libpcre-4.5"
+SLOT="0"
+IUSE="examples +ocamlopt"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_compile() {
+ cd "${S}/lib"
+ emake byte-code-library || die "Failed to build byte code library"
+ if use ocamlopt; then
+ emake native-code-library || die "Failed to build native code library"
+ fi
+}
+
+src_install () {
+ export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_install
+
+ # install documentation
+ dodoc README VERSION Changes
+
+ if use examples; then
+ for dir in examples/*
+ do
+ docinto $dir
+ dodoc $dir/*
+ done
+ fi
+}