summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-09-25 20:15:43 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-09-25 20:15:43 +0000
commit318a4d6e368432bfb048ab7c09bf74fa881df95f (patch)
tree242bc8d3b12997375decd8d6d5fe5b2c6517c7ce /dev-ml
parentStable on sparc. (Manifest recommit) (diff)
downloadgentoo-2-318a4d6e368432bfb048ab7c09bf74fa881df95f.tar.gz
gentoo-2-318a4d6e368432bfb048ab7c09bf74fa881df95f.tar.bz2
gentoo-2-318a4d6e368432bfb048ab7c09bf74fa881df95f.zip
New package for generating bindings to C/C++ libs, fixes bug #65138.
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlidl/ChangeLog11
-rw-r--r--dev-ml/camlidl/Manifest2
-rw-r--r--dev-ml/camlidl/camlidl-1.05.ebuild40
-rw-r--r--dev-ml/camlidl/files/digest-camlidl-1.051
-rw-r--r--dev-ml/camlidl/metadata.xml5
5 files changed, 59 insertions, 0 deletions
diff --git a/dev-ml/camlidl/ChangeLog b/dev-ml/camlidl/ChangeLog
new file mode 100644
index 000000000000..3414077932ed
--- /dev/null
+++ b/dev-ml/camlidl/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/camlidl
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlidl/ChangeLog,v 1.1 2004/09/25 20:15:43 mattam Exp $
+
+*camlidl-1.05 (25 Sep 2004)
+
+ 25 Sep 2004; Matthieu Sozeau <mattam@gentoo.org> +metadata.xml,
+ +camlidl-1.05.ebuild:
+ New package for building stub code from C/C++ libraries, submitted by Bardur
+ Arantsson <gentoo@scientician.net>. Fixes bug #65138.
+
diff --git a/dev-ml/camlidl/Manifest b/dev-ml/camlidl/Manifest
new file mode 100644
index 000000000000..9910ef9e86cd
--- /dev/null
+++ b/dev-ml/camlidl/Manifest
@@ -0,0 +1,2 @@
+MD5 afa037151596cd4d059cde5b9a374cda camlidl-1.05.ebuild 710
+MD5 67257771cc4ea539389ae0252ddc1b30 files/digest-camlidl-1.05 64
diff --git a/dev-ml/camlidl/camlidl-1.05.ebuild b/dev-ml/camlidl/camlidl-1.05.ebuild
new file mode 100644
index 000000000000..e51f30a73c2c
--- /dev/null
+++ b/dev-ml/camlidl/camlidl-1.05.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlidl/camlidl-1.05.ebuild,v 1.1 2004/09/25 20:15:43 mattam Exp $
+
+DESCRIPTION="CamlIDL is a stub code generator for using C/C++ libraries from O'Caml"
+HOMEPAGE="http://caml.inria.fr/camlidl/"
+SRC_URI="http://caml.inria.fr/distrib/bazar-ocaml/${P}.tar.gz"
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+DEPEND=">=dev-lang/ocaml-3.07"
+
+src_compile() {
+ # Use the UNIX makefile
+ libdir=`ocamlc -where`
+ sed -i -e "s|OCAMLLIB=.*|OCAMLLIB=${libdir}|" config/Makefile.unix
+ sed -i -e "s|BINDIR=.*|BINDIR=/usr/bin|" config/Makefile.unix
+ ln -s Makefile.unix config/Makefile
+
+ # Make
+ emake -j1 || die
+}
+
+src_test() {
+ einfo "Running tests..."
+ cd tests
+ ( make CCPP=g++ && einfo "Tests finished successfully" ) || die "Tests failed"
+}
+
+src_install() {
+ libdir=`ocamlc -where`
+ dodir ${libdir}/caml
+ dodir /usr/bin
+ # Install
+ emake BINDIR=${D}/usr/bin OCAMLLIB=${D}${libdir} install || die
+
+ # Documentation
+ dodoc README Changes
+}
diff --git a/dev-ml/camlidl/files/digest-camlidl-1.05 b/dev-ml/camlidl/files/digest-camlidl-1.05
new file mode 100644
index 000000000000..753065e2c2db
--- /dev/null
+++ b/dev-ml/camlidl/files/digest-camlidl-1.05
@@ -0,0 +1 @@
+MD5 4cfb863bc3cbdc1af2502042c45cc675 camlidl-1.05.tar.gz 100640
diff --git a/dev-ml/camlidl/metadata.xml b/dev-ml/camlidl/metadata.xml
new file mode 100644
index 000000000000..849ed8ebf13d
--- /dev/null
+++ b/dev-ml/camlidl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+</pkgmetadata>