summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-07-22 13:14:51 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-07-22 13:14:51 +0000
commit63d2377b90b40c970538a2c9f1d0d27a7ef339fb (patch)
tree13b84ab219320f30230ca86be2c9fc1241b194b7 /dev-ml/postgresql-ocaml
parentversion bump (diff)
downloadgentoo-2-63d2377b90b40c970538a2c9f1d0d27a7ef339fb.tar.gz
gentoo-2-63d2377b90b40c970538a2c9f1d0d27a7ef339fb.tar.bz2
gentoo-2-63d2377b90b40c970538a2c9f1d0d27a7ef339fb.zip
version bump
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/postgresql-ocaml')
-rw-r--r--dev-ml/postgresql-ocaml/ChangeLog8
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.4.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-ml/postgresql-ocaml/ChangeLog b/dev-ml/postgresql-ocaml/ChangeLog
index efa5def4c6e9..0ceaa683ac6a 100644
--- a/dev-ml/postgresql-ocaml/ChangeLog
+++ b/dev-ml/postgresql-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/postgresql-ocaml
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.32 2013/07/22 13:10:57 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.33 2013/07/22 13:14:51 aballier Exp $
+
+*postgresql-ocaml-2.0.4 (22 Jul 2013)
+
+ 22 Jul 2013; Alexis Ballier <aballier@gentoo.org>
+ +postgresql-ocaml-2.0.4.ebuild:
+ version bump
22 Jul 2013; Alexis Ballier <aballier@gentoo.org>
-postgresql-ocaml-1.16.0.ebuild, -postgresql-ocaml-1.18.0.ebuild:
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.4.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.4.ebuild
new file mode 100644
index 000000000000..fd0f10211c75
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.4.ebuild,v 1.1 2013/07/22 13:14:51 aballier Exp $
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases."
+SRC_URI="http://bitbucket.org/mmottl/postgresql-ocaml/downloads/${P}.tar.gz"
+HOMEPAGE="http://bitbucket.org/mmottl/postgresql-ocaml"
+IUSE="examples"
+
+DEPEND="dev-db/postgresql-base
+ dev-db/postgresql-server"
+RDEPEND="${DEPEND}"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}