summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-01-19 13:11:04 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-01-19 13:11:04 +0000
commit5ba871e7d7d7112a00cacff898286e2bf1d6b439 (patch)
treee665fae81f4ef51816453f8f8e1e5f0384caed71 /dev-ml/postgresql-ocaml
parentcleanup (diff)
downloadgentoo-2-5ba871e7d7d7112a00cacff898286e2bf1d6b439.tar.gz
gentoo-2-5ba871e7d7d7112a00cacff898286e2bf1d6b439.tar.bz2
gentoo-2-5ba871e7d7d7112a00cacff898286e2bf1d6b439.zip
version bump
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/postgresql-ocaml')
-rw-r--r--dev-ml/postgresql-ocaml/ChangeLog10
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.5.ebuild32
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-ml/postgresql-ocaml/ChangeLog b/dev-ml/postgresql-ocaml/ChangeLog
index 12b29c9f4260..eb3789bfc694 100644
--- a/dev-ml/postgresql-ocaml/ChangeLog
+++ b/dev-ml/postgresql-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/postgresql-ocaml
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.34 2013/12/24 12:42:22 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.35 2014/01/19 13:11:04 aballier Exp $
+
+*postgresql-ocaml-2.0.5 (19 Jan 2014)
+
+ 19 Jan 2014; Alexis Ballier <aballier@gentoo.org>
+ +postgresql-ocaml-2.0.5.ebuild:
+ version bump
24 Dec 2013; Agostino Sarubbo <ago@gentoo.org> postgresql-ocaml-2.0.4.ebuild:
Stable for x86, wrt bug #492058
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.5.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.5.ebuild
new file mode 100644
index 000000000000..26b6b1f7675d
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.5.ebuild,v 1.1 2014/01/19 13:11:04 aballier Exp $
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases."
+SRC_URI="http://bitbucket.org/mmottl/postgresql-ocaml/downloads/${P}.tar.gz"
+HOMEPAGE="http://bitbucket.org/mmottl/postgresql-ocaml"
+IUSE="examples"
+
+DEPEND="dev-db/postgresql-base
+ dev-db/postgresql-server"
+RDEPEND="${DEPEND}"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}