summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-06-11 23:56:56 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-06-11 23:56:56 +0000
commit101417b793d55254378ca1838e2045643758f296 (patch)
treeb58420999272800261a5a27e2fc2bc7d38b91377 /dev-ml/ocamlnet
parentversion bump (diff)
downloadgentoo-2-101417b793d55254378ca1838e2045643758f296.tar.gz
gentoo-2-101417b793d55254378ca1838e2045643758f296.tar.bz2
gentoo-2-101417b793d55254378ca1838e2045643758f296.zip
remove old
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/ocamlnet')
-rw-r--r--dev-ml/ocamlnet/ChangeLog5
-rw-r--r--dev-ml/ocamlnet/ocamlnet-3.5.ebuild75
2 files changed, 4 insertions, 76 deletions
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index de0da16c8320..97965b0a842f 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/ocamlnet
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.74 2013/06/11 23:54:54 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.75 2013/06/11 23:56:55 aballier Exp $
+
+ 11 Jun 2013; Alexis Ballier <aballier@gentoo.org> -ocamlnet-3.5.ebuild:
+ remove old
*ocamlnet-3.6.5 (11 Jun 2013)
diff --git a/dev-ml/ocamlnet/ocamlnet-3.5.ebuild b/dev-ml/ocamlnet/ocamlnet-3.5.ebuild
deleted file mode 100644
index 12979c942f78..000000000000
--- a/dev-ml/ocamlnet/ocamlnet-3.5.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-3.5.ebuild,v 1.5 2013/03/30 14:55:23 ulm Exp $
-
-EAPI="2"
-
-inherit eutils findlib
-
-MY_P=${P/_beta/test}
-DESCRIPTION="Modules for OCaml application-level Internet protocols"
-HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
-SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
-
-LICENSE="ZLIB GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-IUSE="cryptokit gtk ssl tk httpd +ocamlopt +pcre zip"
-RESTRICT="installsources"
-
-# the auth-dh compile flag has been disabled as well, since it depends on
-# ocaml-cryptgps, which is not available.
-
-DEPEND=">=dev-ml/findlib-1.0
- pcre? ( >=dev-ml/pcre-ocaml-5 )
- >=dev-lang/ocaml-3.10.2[tk?,ocamlopt?]
- cryptokit? ( dev-ml/cryptokit )
- gtk? ( >=dev-ml/lablgtk-2 )
- ssl? ( >=dev-ml/ocaml-ssl-0.4 )
- zip? ( dev-ml/camlzip )
- "
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-ocamlnet_use_with() {
- if use $1; then
- echo "-with-$2"
- else
- echo "-without-$2"
- fi
-}
-
-ocamlnet_use_enable() {
- if use $1; then
- echo "-enable-$2"
- else
- echo "-disable-$2"
- fi
-}
-
-src_configure() {
- ./configure \
- -bindir /usr/bin \
- -datadir /usr/share/${PN} \
- $(ocamlnet_use_enable cryptokit crypto) \
- $(ocamlnet_use_enable gtk gtk2) \
- $(ocamlnet_use_enable pcre pcre) \
- $(ocamlnet_use_enable ssl ssl) \
- $(ocamlnet_use_enable tk tcl) \
- $(ocamlnet_use_enable zip zip) \
- $(ocamlnet_use_with httpd nethttpd) \
- || die "Error : econf failed!"
-}
-
-src_compile() {
- emake -j1 all || die "make failed"
- if use ocamlopt; then
- emake -j1 opt || die "make failed"
- fi
-}
-
-src_install() {
- export STRIP_MASK="*/bin/*"
- findlib_src_install
-}