summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-08-24 13:39:28 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-08-24 13:39:28 +0000
commit638f90bfb00e950159fe1fb6545558d3b7b52ff0 (patch)
treea9d93d1da02f0d53688542389862042326d1c0c6 /dev-ml/lablgtk
parentppc stable (bug 422217). (diff)
downloadgentoo-2-638f90bfb00e950159fe1fb6545558d3b7b52ff0.tar.gz
gentoo-2-638f90bfb00e950159fe1fb6545558d3b7b52ff0.tar.bz2
gentoo-2-638f90bfb00e950159fe1fb6545558d3b7b52ff0.zip
version bump
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/lablgtk')
-rw-r--r--dev-ml/lablgtk/ChangeLog7
-rw-r--r--dev-ml/lablgtk/lablgtk-2.16.0.ebuild84
2 files changed, 90 insertions, 1 deletions
diff --git a/dev-ml/lablgtk/ChangeLog b/dev-ml/lablgtk/ChangeLog
index 6278db445e12..dec26d88ca67 100644
--- a/dev-ml/lablgtk/ChangeLog
+++ b/dev-ml/lablgtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/lablgtk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgtk/ChangeLog,v 1.96 2012/08/03 22:43:29 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgtk/ChangeLog,v 1.97 2012/08/24 13:39:28 aballier Exp $
+
+*lablgtk-2.16.0 (24 Aug 2012)
+
+ 24 Aug 2012; Alexis Ballier <aballier@gentoo.org> +lablgtk-2.16.0.ebuild:
+ version bump
03 Aug 2012; Alexis Ballier <aballier@gentoo.org> lablgtk-2.14.2.ebuild:
as-is license only applies to examples, make it conditional in LICENSE
diff --git a/dev-ml/lablgtk/lablgtk-2.16.0.ebuild b/dev-ml/lablgtk/lablgtk-2.16.0.ebuild
new file mode 100644
index 000000000000..753fe807e3aa
--- /dev/null
+++ b/dev-ml/lablgtk/lablgtk-2.16.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgtk/lablgtk-2.16.0.ebuild,v 1.1 2012/08/24 13:39:28 aballier Exp $
+
+EAPI="2"
+
+inherit multilib findlib
+
+IUSE="debug examples glade gnome gnomecanvas sourceview +ocamlopt opengl spell svg"
+
+DESCRIPTION="Objective CAML interface for Gtk+2"
+HOMEPAGE="http://lablgtk.forge.ocamlcore.org/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/979/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception examples? ( as-is )"
+
+RDEPEND=">=x11-libs/gtk+-2.10:2
+ >=dev-lang/ocaml-3.10[ocamlopt?]
+ svg? ( >=gnome-base/librsvg-2.2:2 )
+ glade? ( >=gnome-base/libglade-2.0.1 )
+ gnomecanvas? ( >=gnome-base/libgnomecanvas-2.2 )
+ gnome? (
+ || ( >=gnome-base/gnome-panel-2.32[bonobo] <gnome-base/gnome-panel-2.32 )
+ >=gnome-base/gnome-panel-2.4.0
+ >=gnome-base/libgnomeui-2.4.0
+ )
+ opengl? ( >=dev-ml/lablgl-0.98
+ >=x11-libs/gtkglarea-1.9:2 )
+ spell? ( app-text/gtkspell:2 )
+ sourceview? ( x11-libs/gtksourceview:2.0 )
+ "
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd ~x86-linux"
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_with svg rsvg) \
+ $(use_with glade) \
+ $(use_with gnome gnomeui) \
+ $(use_with gnome panel) \
+ $(use_with opengl gl) \
+ $(use_with spell gtkspell) \
+ --without-gtksourceview \
+ $(use_with sourceview gtksourceview2) \
+ $(use_with gnomecanvas)
+}
+
+src_compile() {
+ emake -j1 all || die "make failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "Compiling native code failed"
+ fi
+}
+
+install_examples() {
+ insinto /usr/share/doc/${P}/examples
+ doins examples/*.ml examples/*.rgb examples/*.png examples/*.xpm
+
+ # Install examples for optional components
+ use gnomecanvas && insinto /usr/share/doc/${PF}/examples/canvas && doins examples/canvas/*.ml examples/canvas/*.png
+ use svg && insinto /usr/share/doc/${PF}/examples/rsvg && doins examples/rsvg/*.ml examples/rsvg/*.svg
+ use glade && insinto /usr/share/doc/${PF}/examples/glade && doins examples/glade/*.ml examples/glade/*.glade*
+ use sourceview && insinto /usr/share/doc/${PF}/examples/sourceview && doins examples/sourceview/*.ml examples/sourceview/*.lang
+ use opengl && insinto /usr/share/doc/${PF}/examples/GL && doins examples/GL/*.ml
+ use gnome && insinto /usr/share/doc/${PF}/examples/panel && doins examples/panel/*
+}
+
+src_install () {
+ findlib_src_preinst
+ export OCAMLPATH="${OCAMLFIND_DESTDIR}"
+ emake install DESTDIR="${D}" || die
+
+ dodoc CHANGES README CHANGES.API
+ use examples && install_examples
+}
+
+pkg_postinst () {
+ if use examples; then
+ elog "To run the examples you can use the lablgtk2 toplevel."
+ elog "e.g: lablgtk2 /usr/share/doc/${PF}/examples/testgtk.ml"
+ fi
+}