summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2005-02-14 19:11:54 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2005-02-14 19:11:54 +0000
commit454d120a492c50c75b0d3bcfed8e2729133330a9 (patch)
tree5d91a09b25c264304a26de7a5de4c7f96eff9933 /dev-ml/lablgl
parentRemoved sparc64-multilib reference. (diff)
downloadgentoo-2-454d120a492c50c75b0d3bcfed8e2729133330a9.tar.gz
gentoo-2-454d120a492c50c75b0d3bcfed8e2729133330a9.tar.bz2
gentoo-2-454d120a492c50c75b0d3bcfed8e2729133330a9.zip
Added eerror when ocaml doesn't support tcltk, but user have enabled tcltk use flag, bug #44057
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-ml/lablgl')
-rw-r--r--dev-ml/lablgl/ChangeLog7
-rw-r--r--dev-ml/lablgl/lablgl-1.00.ebuild13
2 files changed, 13 insertions, 7 deletions
diff --git a/dev-ml/lablgl/ChangeLog b/dev-ml/lablgl/ChangeLog
index f08e6702a716..0636012a2855 100644
--- a/dev-ml/lablgl/ChangeLog
+++ b/dev-ml/lablgl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/lablgl
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/ChangeLog,v 1.30 2004/12/29 22:46:11 ciaranm Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/ChangeLog,v 1.31 2005/02/14 19:11:54 sekretarz Exp $
+
+ 14 Feb 2005; Karol Wojtaszek <sekretarz@gentoo.org> lablgl-1.00.ebuild:
+ Added eerror when ocaml doesn't support tcltk, but user have enabled tcltk use flag, bug #44057
29 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/dev-ml/lablgl/lablgl-1.00.ebuild b/dev-ml/lablgl/lablgl-1.00.ebuild
index f7c080ec9cc9..55d8e1a8a103 100644
--- a/dev-ml/lablgl/lablgl-1.00.ebuild
+++ b/dev-ml/lablgl/lablgl-1.00.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/lablgl-1.00.ebuild,v 1.15 2004/08/25 21:41:38 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/lablgl-1.00.ebuild,v 1.16 2005/02/14 19:11:54 sekretarz Exp $
+
+inherit eutils
IUSE="tcltk glut doc"
@@ -23,14 +25,15 @@ pkg_setup()
if ( use tcltk )
then
#lablgl requires ocaml compiled with tk support while ocaml has it as an optional dependency
- if ( ! which labltk )
+ if ( ! built_with_use dev-lang/ocaml tcltk )
then
- eerror "It seems you don't have ocaml compiled with tk support"
+ eerror "You don't have ocaml compiled with tk support"
eerror ""
eerror "lablgl requires ocaml be built with tk support."
eerror ""
eerror "Please make sure that ocaml is installed with tk support."
- false;
+ sleep 5;
+ die "Ocaml is missing tk support";
fi
fi
}