summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-08-21 17:45:22 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-08-21 17:45:22 +0000
commit442ba570fd85300640b33e75f2dcba0a3635c3e7 (patch)
treeec5ff6c312eebf5e4f6cdc0cc0369a672c22b29d /dev-ml/findlib/findlib-1.0.4-r1.ebuild
parentFixed a link-error. (Manifest recommit) (diff)
downloadgentoo-2-442ba570fd85300640b33e75f2dcba0a3635c3e7.tar.gz
gentoo-2-442ba570fd85300640b33e75f2dcba0a3635c3e7.tar.bz2
gentoo-2-442ba570fd85300640b33e75f2dcba0a3635c3e7.zip
Findlib eclass introduction changes, remove old versions and add check for correct ld.conf on install.
Diffstat (limited to 'dev-ml/findlib/findlib-1.0.4-r1.ebuild')
-rw-r--r--dev-ml/findlib/findlib-1.0.4-r1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/dev-ml/findlib/findlib-1.0.4-r1.ebuild b/dev-ml/findlib/findlib-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..ad4d401ec308
--- /dev/null
+++ b/dev-ml/findlib/findlib-1.0.4-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/findlib-1.0.4-r1.ebuild,v 1.1 2004/08/21 17:45:22 mattam Exp $
+
+IUSE="tcltk"
+
+DESCRIPTION="OCaml tool to find/use non-standard packages."
+HOMEPAGE="http://www.ocaml-programming.de/packages/"
+SRC_URI="http://www.ocaml-programming.de/packages/${P}.tar.gz"
+
+LICENSE="MIT X11"
+
+SLOT="0"
+KEYWORDS="x86 ppc sparc ~amd64"
+
+DEPEND=">=dev-lang/ocaml-3.07"
+
+ocamlfind_destdir="/usr/lib/ocaml/site-packages"
+
+pkg_setup()
+{
+ if ( use tcltk && which ocaml && ! which labltk ); then
+ eerror "It seems you don't have ocaml compiled with tk support"
+ eerror ""
+ eerror "The findlib toolbox requires ocaml be built with tk support."
+ eerror ""
+ eerror "Please make sure that ocaml is installed with tk support or remove the USE flag"
+
+ false;
+ fi
+}
+
+src_compile() {
+ ./configure
+
+ ./configure -bindir /usr/bin -mandir /usr/share/man \
+ -sitelib ${ocamlfind_destdir} \
+ -config ${ocamlfind_destdir}/findlib/findlib.conf || die "configure failed"
+
+ make all || die
+ make opt || die # optimized code
+}
+
+src_install() {
+ dodir `ocamlc -where`
+
+ make prefix=${D} install || die
+
+ cd ${S}/doc
+ dodoc QUICKSTART README
+ dohtml html/*
+}
+
+check_stublibs() {
+ local stublibs=${ocamlfind_destdir}/stublibs
+ local ocaml_stdlib=`ocamlc -where`
+ local ldconf=${ocaml_stdlib}/ld.conf
+
+ if [ ! -e ${ldconf} ]
+ then
+ echo ${ocaml_stdlib} > ${ldconf}
+ fi
+
+ if [ -z `grep -e ${stublibs} ${ldconf}` ]
+ then
+ echo ${stublibs} >> ${ldconf}
+ fi
+}
+
+pkg_postinst() {
+ check_stublibs
+} \ No newline at end of file