summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-11-10 14:18:20 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-11-10 14:18:20 +0000
commita5989fb75efb71120cd12671ef29ee1270a475ea (patch)
tree192f3930bbef71ab3dc4e06acdcbe93e32eea0f1 /dev-ml/camlzip
parentamd64 stable (diff)
downloadgentoo-2-a5989fb75efb71120cd12671ef29ee1270a475ea.tar.gz
gentoo-2-a5989fb75efb71120cd12671ef29ee1270a475ea.tar.bz2
gentoo-2-a5989fb75efb71120cd12671ef29ee1270a475ea.zip
also install zlib support, thanks to Pierre Clairambault <pclairam@gmail.com>, bug #198466
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-ml/camlzip')
-rw-r--r--dev-ml/camlzip/ChangeLog9
-rw-r--r--dev-ml/camlzip/camlzip-1.03-r1.ebuild36
-rw-r--r--dev-ml/camlzip/files/camlzip-1.03-Makefile-findlib.patch36
-rw-r--r--dev-ml/camlzip/files/digest-camlzip-1.03-r13
4 files changed, 83 insertions, 1 deletions
diff --git a/dev-ml/camlzip/ChangeLog b/dev-ml/camlzip/ChangeLog
index 25796618009d..ffba10ccd88e 100644
--- a/dev-ml/camlzip/ChangeLog
+++ b/dev-ml/camlzip/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ml/camlzip
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/ChangeLog,v 1.5 2007/05/26 20:34:04 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/ChangeLog,v 1.6 2007/11/10 14:18:20 aballier Exp $
+
+*camlzip-1.03-r1 (10 Nov 2007)
+
+ 10 Nov 2007; Alexis Ballier <aballier@gentoo.org>
+ +files/camlzip-1.03-Makefile-findlib.patch, +camlzip-1.03-r1.ebuild:
+ also install zlib support, thanks to Pierre Clairambault
+ <pclairam@gmail.com>, bug #198466
*camlzip-1.03 (26 May 2007)
diff --git a/dev-ml/camlzip/camlzip-1.03-r1.ebuild b/dev-ml/camlzip/camlzip-1.03-r1.ebuild
new file mode 100644
index 000000000000..645cebe040b6
--- /dev/null
+++ b/dev-ml/camlzip/camlzip-1.03-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/camlzip-1.03-r1.ebuild,v 1.1 2007/11/10 14:18:20 aballier Exp $
+
+inherit findlib eutils
+
+IUSE=""
+
+DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
+HOMEPAGE="http://cristal.inria.fr/~xleroy/software.html#camlzip"
+SRC_URI="http://caml.inria.fr/distrib/bazar-ocaml/${P}.tar.gz"
+
+SLOT="1"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=">=dev-lang/ocaml-3.04 \
+ >=sys-libs/zlib-1.1.3"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-Makefile-findlib.patch"
+ sed -e "s/VERSION/${PV}/" "${FILESDIR}/META" >> META
+}
+
+src_compile() {
+ emake all || die "Failed at compilation step !!!"
+ emake allopt || die "Failed at ML compilation step !!!"
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc README
+}
diff --git a/dev-ml/camlzip/files/camlzip-1.03-Makefile-findlib.patch b/dev-ml/camlzip/files/camlzip-1.03-Makefile-findlib.patch
new file mode 100644
index 000000000000..6eefb5021f8a
--- /dev/null
+++ b/dev-ml/camlzip/files/camlzip-1.03-Makefile-findlib.patch
@@ -0,0 +1,36 @@
+--- Makefile.orig 2007-11-08 18:07:44.000000000 +0100
++++ Makefile 2007-11-08 18:09:35.000000000 +0100
+@@ -19,10 +19,13 @@
+ OCAMLOPT=ocamlopt
+ OCAMLDEP=ocamldep
+ OCAMLMKLIB=ocamlmklib
++OCAMLFIND=ocamlfind
+
+ OBJS=zlib.cmo zip.cmo gzip.cmo
+ C_OBJS=zlibstubs.o
+
++LIBINSTALL_FILES = $(wildcard *.mli *.cmi *.cma *.cmxa *.a *.so *.cmx)
++
+ all: libcamlzip.a zip.cma
+
+ allopt: libcamlzip.a zip.cmxa
+@@ -55,18 +58,7 @@
+ rm -f *.o *.a
+
+ install:
+- mkdir -p $(INSTALLDIR)
+- cp zip.cma zip.cmi gzip.cmi zip.mli gzip.mli libcamlzip.a $(INSTALLDIR)
+- if test -f dllcamlzip.so; then \
+- cp dllcamlzip.so $(INSTALLDIR); \
+- ldconf=`$(OCAMLC) -where`/ld.conf; \
+- installdir=$(INSTALLDIR); \
+- if test `grep -s -c $$installdir'$$' $$ldconf || :` = 0; \
+- then echo $$installdir >> $$ldconf; fi \
+- fi
+-
+-installopt:
+- cp zip.cmxa zip.a zip.cmx gzip.cmx $(INSTALLDIR)
++ $(OCAMLFIND) install camlzip META $(LIBINSTALL_FILES)
+
+ depend:
+ gcc -MM -I$(ZLIB_INCLUDE) *.c > .depend
diff --git a/dev-ml/camlzip/files/digest-camlzip-1.03-r1 b/dev-ml/camlzip/files/digest-camlzip-1.03-r1
new file mode 100644
index 000000000000..f287fc345617
--- /dev/null
+++ b/dev-ml/camlzip/files/digest-camlzip-1.03-r1
@@ -0,0 +1,3 @@
+MD5 65cee9abf1df6544cae554b94128d441 camlzip-1.03.tar.gz 24562
+RMD160 fc773c0e351863538817f5c803a1b1d6cf9bc6e5 camlzip-1.03.tar.gz 24562
+SHA256 d45af5deee6126137eb1bd896373ceeabacb916e30b977122de2eb3134336f08 camlzip-1.03.tar.gz 24562