summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2010-11-05 22:13:24 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2010-11-05 22:13:24 +0000
commit5cd19ef2bf46e0b9833cfb391956554159687d8c (patch)
treee4f1b34c65247d6db9df93d4ef96d858e8a18875 /dev-lua
parentVersion bump. Enable introspection support but disable related tests, they se... (diff)
downloadgentoo-2-5cd19ef2bf46e0b9833cfb391956554159687d8c.tar.gz
gentoo-2-5cd19ef2bf46e0b9833cfb391956554159687d8c.tar.bz2
gentoo-2-5cd19ef2bf46e0b9833cfb391956554159687d8c.zip
Moved from dev-lang to dev-lua. Added myself to metadata.xml.
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luarocks/ChangeLog15
-rw-r--r--dev-lua/luarocks/luarocks-1.0.ebuild48
-rw-r--r--dev-lua/luarocks/metadata.xml17
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-lua/luarocks/ChangeLog b/dev-lua/luarocks/ChangeLog
new file mode 100644
index 000000000000..9c5e3b096052
--- /dev/null
+++ b/dev-lua/luarocks/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for dev-lua/luarocks
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luarocks/ChangeLog,v 1.1 2010/11/05 22:13:24 rafaelmartins Exp $
+
+ 05 Nov 2010; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +luarocks-1.0.ebuild, +metadata.xml:
+ Moved from dev-lang to dev-lua. Added myself to metadata.xml.
+
+*luarocks-1.0 (22 Oct 2008)
+
+ 22 Oct 2008; Matti Bickel <mabi@gentoo.org> +metadata.xml,
+ +luarocks-1.0.ebuild:
+ initial version. Thanks to A.S. Bradbury (asb@asbradbury.org) for the
+ original ebuild
+
diff --git a/dev-lua/luarocks/luarocks-1.0.ebuild b/dev-lua/luarocks/luarocks-1.0.ebuild
new file mode 100644
index 000000000000..921d396f39cb
--- /dev/null
+++ b/dev-lua/luarocks/luarocks-1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luarocks/luarocks-1.0.ebuild,v 1.1 2010/11/05 22:13:24 rafaelmartins Exp $
+
+inherit eutils
+
+DESCRIPTION="A deployment and management system for Lua modules"
+HOMEPAGE="http://www.luarocks.org"
+SRC_URI="http://luaforge.net/frs/download.php/3727/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="curl openssl"
+
+DEPEND="dev-lang/lua
+ curl? ( net-misc/curl )
+ openssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}
+ app-arch/unzip"
+
+src_compile() {
+ USE_MD5="md5sum"
+ USE_FETCH="wget"
+ use openssl && USE_MD5="openssl"
+ use curl && USE_FETCH="curl"
+
+ # econf doesn't work b/c it passes variables the custom configure can't
+ # handle
+ ./configure \
+ --prefix=/usr \
+ --scripts-dir=/usr/bin \
+ --with-lua=/usr \
+ --with-lua-lib=/usr/$(get_libdir) \
+ --rocks-tree=/usr/lib/lua/luarocks \
+ --with-downloader=$USE_FETCH \
+ --with-md5-checker=$USE_MD5 \
+ --force-config || die "configure failed"
+ emake DESTDIR="${D}" || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "einstall"
+}
+
+pkg_preinst() {
+ find "${D}" -type f | xargs sed -i -e "s:${D}::g" || die "sed failed"
+}
diff --git a/dev-lua/luarocks/metadata.xml b/dev-lua/luarocks/metadata.xml
new file mode 100644
index 000000000000..82426290bd38
--- /dev/null
+++ b/dev-lua/luarocks/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>mabi@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name='curl'>Uses <pkg>net-misc/curl</pkg> for fetching lua
+ packages instead of <pkg>net-misc/wget</pkg>.</flag>
+ <flag name='openssl'>Uses <pkg>dev-libs/openssl</pkg> for verifying lua
+ packages instead of md5sum.</flag>
+ </use>
+</pkgmetadata>