summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-10-17 16:33:15 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-10-17 16:33:15 +0000
commita03e127926968daa745caebd21b711134c1e2100 (patch)
tree9a4300cd3311905058968e5ce8a1054508f8783e /dev-lisp
parentFix SRC_URI (diff)
downloadgentoo-2-a03e127926968daa745caebd21b711134c1e2100.tar.gz
gentoo-2-a03e127926968daa745caebd21b711134c1e2100.tar.bz2
gentoo-2-a03e127926968daa745caebd21b711134c1e2100.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-sha1/ChangeLog6
-rw-r--r--dev-lisp/cl-sha1/Manifest7
-rw-r--r--dev-lisp/cl-sha1/cl-sha1-1.0.ebuild10
-rw-r--r--dev-lisp/cl-sha1/files/cl-sha1-gentoo.patch60
-rw-r--r--dev-lisp/cl-sha1/metadata.xml5
5 files changed, 56 insertions, 32 deletions
diff --git a/dev-lisp/cl-sha1/ChangeLog b/dev-lisp/cl-sha1/ChangeLog
index c4f4fac26f90..77cc31d08190 100644
--- a/dev-lisp/cl-sha1/ChangeLog
+++ b/dev-lisp/cl-sha1/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/cl-sha1
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sha1/ChangeLog,v 1.1 2003/09/28 23:31:38 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sha1/ChangeLog,v 1.2 2003/10/17 16:33:03 mkennedy Exp $
+
+ 17 Oct 2003; Matthew Kennedy <mkennedy@gentoo.org> cl-sha1-1.0.ebuild,
+ metadata.xml, files/cl-sha1-gentoo.patch:
+ make portable for non-sbcl CL impl, add postrm, preinst
*cl-sha1-1.0 (27 Sep 2003)
diff --git a/dev-lisp/cl-sha1/Manifest b/dev-lisp/cl-sha1/Manifest
index 93eec8ddf820..b43eab1c0839 100644
--- a/dev-lisp/cl-sha1/Manifest
+++ b/dev-lisp/cl-sha1/Manifest
@@ -1,4 +1,5 @@
-MD5 6e5dd72538b044152a5795803de02d59 ChangeLog 317
-MD5 0b7958344bbfca550351218e8624e771 cl-sha1-1.0.ebuild 751
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
+MD5 834a7c99ffb927a0dd644528edbf997a ChangeLog 493
+MD5 329a701faf67d43d33ec53bb8add98a0 cl-sha1-1.0.ebuild 892
+MD5 0a039383dd5b89d840f854df67586538 files/cl-sha1-gentoo.patch 1558
MD5 8e9b4e113e34b8bd29e9198b7ca943bf files/digest-cl-sha1-1.0 61
-MD5 65f390555f7727b1d879b088df6adb4e files/cl-sha1-gentoo.patch 1309
diff --git a/dev-lisp/cl-sha1/cl-sha1-1.0.ebuild b/dev-lisp/cl-sha1/cl-sha1-1.0.ebuild
index 4389ed19c8fe..05a9671e85cd 100644
--- a/dev-lisp/cl-sha1/cl-sha1-1.0.ebuild
+++ b/dev-lisp/cl-sha1/cl-sha1-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sha1/cl-sha1-1.0.ebuild,v 1.1 2003/09/28 23:31:38 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sha1/cl-sha1-1.0.ebuild,v 1.2 2003/10/17 16:33:03 mkennedy Exp $
inherit common-lisp
@@ -29,3 +29,11 @@ src_install() {
common-lisp-system-symlink
dodoc README
}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
diff --git a/dev-lisp/cl-sha1/files/cl-sha1-gentoo.patch b/dev-lisp/cl-sha1/files/cl-sha1-gentoo.patch
index f87dc0ae064c..b8382997a23d 100644
--- a/dev-lisp/cl-sha1/files/cl-sha1-gentoo.patch
+++ b/dev-lisp/cl-sha1/files/cl-sha1-gentoo.patch
@@ -1,39 +1,45 @@
-diff -ur sb-sha1/sb-sha1.asd sb-sha1-1.0/sb-sha1.asd
---- sb-sha1/sb-sha1.asd 2003-08-08 02:28:18.000000000 -0500
-+++ sb-sha1-1.0/sb-sha1.asd 2003-09-28 17:40:58.254138000 -0500
-@@ -6,7 +6,6 @@
+diff -u sb-sha1.orig/sb-sha1.asd sb-sha1/sb-sha1.asd
+--- sb-sha1.orig/sb-sha1.asd 2003-08-08 02:28:18.000000000 -0500
++++ sb-sha1/sb-sha1.asd 2003-10-17 11:21:43.789994592 -0500
+@@ -5,11 +5,15 @@
+
(in-package #:sb-sha1-system)
- (defsystem sb-sha1
-- :depends-on (sb-rotate-byte)
+-(defsystem sb-sha1
++#+sbcl (defsystem sb-sha1
+ :depends-on (sb-rotate-byte)
:version "1.0"
:components ((:file "sha1")))
-@@ -18,11 +17,9 @@
- (operate 'test-op 'sb-sha1-tests))
-
- (defsystem sb-sha1-tests
-- :depends-on (sb-sha1 sb-rt)
- :version "1.0"
- :components ((:file "sha1-tests")))
++#-sbcl (defsystem sb-sha1
++ :version "1.0"
++ :components ((:file "sha1")))
++
+ (defmethod perform :after ((o load-op) (c (eql (find-system :sb-sha1))))
+ (provide 'sb-sha1))
+@@ -25,4 +29,3 @@
(defmethod perform ((o test-op) (c (eql (find-system :sb-sha1-tests))))
(or (funcall (intern "DO-TESTS" (find-package "SB-RT")))
(error "test-op failed")))
-
\ No newline at end of file
-Only in sb-sha1-1.0/: sb-sha1.asd~
-diff -ur sb-sha1/sha1.lisp sb-sha1-1.0/sha1.lisp
---- sb-sha1/sha1.lisp 2003-09-11 02:40:20.000000000 -0500
-+++ sb-sha1-1.0/sha1.lisp 2003-09-28 18:05:03.615409688 -0500
-@@ -125,9 +125,6 @@
- (kernel:32bit-logical-or #+little-endian (kernel:shift-towards-end a s)
- #+big-endian (kernel:shift-towards-start a s)
- (ash a (- s 32)))
-- #+sbcl
-- (sb-rotate-byte:rotate-byte s (byte 32 0) a)
-- #-(or sbcl cmu)
- (logior (ldb (byte 32 0) (ash a s)) (ash a (- s 32))))
+Only in sb-sha1/: sb-sha1.asd.orig
+diff -u sb-sha1.orig/sha1.lisp sb-sha1/sha1.lisp
+--- sb-sha1.orig/sha1.lisp 2003-09-11 02:40:20.000000000 -0500
++++ sb-sha1/sha1.lisp 2003-10-17 11:25:03.897573616 -0500
+@@ -526,9 +526,11 @@
+ (update-sha1-state state sequence :start start :end real-end))
+ (finalize-sha1-state state)))
+
+-(defconstant +buffer-size+ (* 128 1024)
+- "Size of internal buffer to use for sha1sum-stream and sha1sum-file
+-operations. This should be a multiple of 64, the SHA1 block size.")
++(eval-when (:compile-toplevel)
++ (defconstant +buffer-size+ (* 128 1024)
++ "Size of internal buffer to use for sha1sum-stream and
++sha1sum-file operations. This should be a multiple of 64, the SHA1
++block size."))
+
+ (deftype buffer-index () `(integer 0 ,+buffer-size+))
- ;;; helper macro for rounds, with variable capture
-Only in sb-sha1-1.0/: sha1.lisp~
diff --git a/dev-lisp/cl-sha1/metadata.xml b/dev-lisp/cl-sha1/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-sha1/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>