summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2015-02-01 06:34:48 +0000
committerMark Wright <gienah@gentoo.org>2015-02-01 06:34:48 +0000
commit8c34abd80befe28af7964bfd0ca36e9b90efb7dd (patch)
treed131aeb9a8eb01e5b9fb31d208c9eecaaaa923cd /dev-lisp
parentupdating deps on 2014.2.9999 (diff)
downloadgentoo-2-8c34abd80befe28af7964bfd0ca36e9b90efb7dd.tar.gz
gentoo-2-8c34abd80befe28af7964bfd0ca36e9b90efb7dd.tar.bz2
gentoo-2-8c34abd80befe28af7964bfd0ca36e9b90efb7dd.zip
Applied my fix from sbcl-1.2.7 to all the remaining ebuilds to fix Bug 526194 - dev-lisp/sbcl-1.2.4 does not respect CFLAGS and LDFLAGS
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/sbcl/ChangeLog7
-rw-r--r--dev-lisp/sbcl/sbcl-1.1.18.ebuild9
-rw-r--r--dev-lisp/sbcl/sbcl-1.2.2.ebuild9
-rw-r--r--dev-lisp/sbcl/sbcl-1.2.4.ebuild9
4 files changed, 27 insertions, 7 deletions
diff --git a/dev-lisp/sbcl/ChangeLog b/dev-lisp/sbcl/ChangeLog
index 717703b8b936..2231a2b007ce 100644
--- a/dev-lisp/sbcl/ChangeLog
+++ b/dev-lisp/sbcl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/sbcl
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.216 2015/02/01 01:46:12 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.217 2015/02/01 06:34:48 gienah Exp $
+
+ 01 Feb 2015; Mark Wright <gienah@gentoo.org> sbcl-1.1.18.ebuild,
+ sbcl-1.2.2.ebuild, sbcl-1.2.4.ebuild:
+ Applied my fix from sbcl-1.2.7 to all the remaining ebuilds to fix Bug 526194
+ - dev-lisp/sbcl-1.2.4 does not respect CFLAGS and LDFLAGS
01 Feb 2015; Mark Wright <gienah@gentoo.org>
+files/sbcl-1.0.55-newglibc.patch, sbcl-1.0.55-r1.ebuild:
diff --git a/dev-lisp/sbcl/sbcl-1.1.18.ebuild b/dev-lisp/sbcl/sbcl-1.1.18.ebuild
index 10eecf2c5762..91b60d294890 100644
--- a/dev-lisp/sbcl/sbcl-1.1.18.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.1.18.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.1.18.ebuild,v 1.5 2014/10/20 14:51:55 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.1.18.ebuild,v 1.6 2015/02/01 06:34:48 gienah Exp $
EAPI=5
inherit multilib eutils flag-o-matic pax-utils
@@ -92,6 +92,11 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.1.17-gentoo-fix_nopie_for_hardened_toolchain.patch
fi
+ # bug #526194
+ sed -e "s@CFLAGS =@CFLAGS = ${CFLAGS}@" \
+ -e "s@LINKFLAGS =@LINKFLAGS = ${LDFLAGS}@" \
+ -i src/runtime/GNUmakefile || die
+
cp /usr/share/common-lisp/source/asdf/build/asdf.lisp contrib/asdf/ || die
use source && sed 's%"$(BUILD_ROOT)%$(MODULE).lisp "$(BUILD_ROOT)%' -i contrib/vanilla-module.mk
diff --git a/dev-lisp/sbcl/sbcl-1.2.2.ebuild b/dev-lisp/sbcl/sbcl-1.2.2.ebuild
index 2f2ba82a2b89..0e1bdb4b8458 100644
--- a/dev-lisp/sbcl/sbcl-1.2.2.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.2.2.ebuild,v 1.4 2014/10/20 14:51:55 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.2.2.ebuild,v 1.5 2015/02/01 06:34:48 gienah Exp $
EAPI=5
inherit multilib eutils flag-o-matic pax-utils
@@ -92,6 +92,11 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.1.17-gentoo-fix_nopie_for_hardened_toolchain.patch
fi
+ # bug #526194
+ sed -e "s@CFLAGS =@CFLAGS = ${CFLAGS}@" \
+ -e "s@LINKFLAGS =@LINKFLAGS = ${LDFLAGS}@" \
+ -i src/runtime/GNUmakefile || die
+
cp /usr/share/common-lisp/source/asdf/build/asdf.lisp contrib/asdf/ || die
use source && sed 's%"$(BUILD_ROOT)%$(MODULE).lisp "$(BUILD_ROOT)%' -i contrib/vanilla-module.mk
diff --git a/dev-lisp/sbcl/sbcl-1.2.4.ebuild b/dev-lisp/sbcl/sbcl-1.2.4.ebuild
index 040fb8caf1ff..08273a0d7b08 100644
--- a/dev-lisp/sbcl/sbcl-1.2.4.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.2.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.2.4.ebuild,v 1.1 2014/10/20 14:51:55 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.2.4.ebuild,v 1.2 2015/02/01 06:34:48 gienah Exp $
EAPI=5
inherit multilib eutils flag-o-matic pax-utils
@@ -92,6 +92,11 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.1.17-gentoo-fix_nopie_for_hardened_toolchain.patch
fi
+ # bug #526194
+ sed -e "s@CFLAGS =@CFLAGS = ${CFLAGS}@" \
+ -e "s@LINKFLAGS =@LINKFLAGS = ${LDFLAGS}@" \
+ -i src/runtime/GNUmakefile || die
+
cp /usr/share/common-lisp/source/asdf/build/asdf.lisp contrib/asdf/ || die
use source && sed 's%"$(BUILD_ROOT)%$(MODULE).lisp "$(BUILD_ROOT)%' -i contrib/vanilla-module.mk