summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2010-05-01 12:10:40 +0000
committerAndrey Grozin <grozin@gentoo.org>2010-05-01 12:10:40 +0000
commit56b761d129650fd79c04fbe8637841e7df8876ec (patch)
tree7d77b22445b1211bcb7d937ec8ad0d0ddfef67e9 /dev-lisp
parentVersion bump (bug 310945) and 0.15.8 stable on amd64 (bug 309389), thanks to ... (diff)
downloadgentoo-2-56b761d129650fd79c04fbe8637841e7df8876ec.tar.gz
gentoo-2-56b761d129650fd79c04fbe8637841e7df8876ec.tar.bz2
gentoo-2-56b761d129650fd79c04fbe8637841e7df8876ec.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clozurecl/ChangeLog9
-rw-r--r--dev-lisp/clozurecl/clozurecl-1.5.ebuild86
2 files changed, 93 insertions, 2 deletions
diff --git a/dev-lisp/clozurecl/ChangeLog b/dev-lisp/clozurecl/ChangeLog
index 824227b0c350..de6614c3a130 100644
--- a/dev-lisp/clozurecl/ChangeLog
+++ b/dev-lisp/clozurecl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/clozurecl
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/ChangeLog,v 1.1 2009/12/17 12:16:40 grozin Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/ChangeLog,v 1.2 2010/05/01 12:10:40 grozin Exp $
+
+*clozurecl-1.5 (01 May 2010)
+
+ 01 May 2010; Andrey Grozin <grozin@gentoo.org> +clozurecl-1.5.ebuild:
+ Version bump
*clozurecl-1.4 (17 Dec 2009)
diff --git a/dev-lisp/clozurecl/clozurecl-1.5.ebuild b/dev-lisp/clozurecl/clozurecl-1.5.ebuild
new file mode 100644
index 000000000000..edec094e04b1
--- /dev/null
+++ b/dev-lisp/clozurecl/clozurecl-1.5.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/clozurecl-1.5.ebuild,v 1.1 2010/05/01 12:10:40 grozin Exp $
+
+EAPI=3
+inherit eutils
+
+MY_PN=ccl
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="ClozureCL is a Common Lisp implementation, derived from Digitool's MCL product"
+HOMEPAGE="http://ccl.clozure.com/"
+SRC_URI="x86? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxx86.tar.gz )
+ amd64? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxx86.tar.gz )"
+ # ppc? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxppc.tar.gz )
+ # ppc64? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxppc.tar.gz )"
+
+LICENSE="LLGPL-2.1"
+SLOT="0"
+# KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="!dev-lisp/openmcl"
+
+PROVIDE="virtual/commonlisp"
+
+S="${WORKDIR}"/${MY_PN}
+
+ENVD="${T}"/50ccl
+
+src_prepare() {
+ find "${S}" -type d -name .svn -exec rm -rf {} ';' &>/dev/null
+ find "${S}" -type f -name .cvsignore -delete &>/dev/null
+ epatch "${FILESDIR}"/fix_user-homedir-pathname.patch
+}
+
+src_configure() {
+ if use x86; then
+ CCL_RUNTIME=lx86cl; CCL_HEADERS=x86-headers
+ elif use amd64; then
+ CCL_RUNTIME=lx86cl64; CCL_HEADERS=x86-headers64
+ elif use ppc; then
+ CCL_RUNTIME=ppccl; CCL_HEADERS=headers
+ elif use ppc64; then
+ CCL_RUNTIME=ppccl64; CCL_HEADERS=headers64
+ fi
+}
+
+src_compile() {
+ unset CCL_DEFAULT_DIRECTORY
+ ./${CCL_RUNTIME} -n -b -Q -e '(ccl:rebuild-ccl :full t)' -e '(ccl:quit)' || die "Compilation failed"
+
+ # remove non-owner write permissions on the full-image
+ chmod go-w ${CCL_RUNTIME}{,.image}
+}
+
+src_install() {
+ local install_dir=/usr/$(get_libdir)/${PN}
+
+ exeinto ${install_dir}
+ # install executable
+ doexe ${CCL_RUNTIME}
+ # install core image
+ cp ${CCL_RUNTIME}.image "${D}"/${install_dir} || die
+ # install optional libraries
+ dodir ${install_dir}/tools
+ cp tools/*fsl "${D}"/${install_dir}/tools || die
+
+ # until we figure out which source files are necessary for runtime
+ # optional features and which aren't, we install all sources
+ find . -type f -name '*fsl' -delete
+ cp -a compiler level-0 level-1 lib library \
+ lisp-kernel scripts tools xdump \
+ "${D}"/${install_dir} || die
+ cp -a ${CCL_HEADERS} "${D}"/${install_dir} || die
+
+ make_wrapper ccl "${install_dir}/${CCL_RUNTIME}"
+
+ echo "CCL_DEFAULT_DIRECTORY=${install_dir}" > "${ENVD}"
+ doenvd "${ENVD}"
+
+ dodoc doc/release-notes.txt
+ dohtml doc/ccl-documentation.html
+ use doc && dohtml -r examples
+}