summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-10 17:39:35 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-10 17:39:35 +0000
commit20e883a6c6274ecf34704050619994d44e7cb502 (patch)
tree91626cccf15e610631b27dc131fc607b82b74f07 /dev-lisp
parentdont access $CC (diff)
downloadgentoo-2-20e883a6c6274ecf34704050619994d44e7cb502.tar.gz
gentoo-2-20e883a6c6274ecf34704050619994d44e7cb502.tar.bz2
gentoo-2-20e883a6c6274ecf34704050619994d44e7cb502.zip
if anyone reads these diffs, these were good examples of things you should never do in your ebuild
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clisp/clisp-2.28.ebuild23
-rw-r--r--dev-lisp/clisp/clisp-2.29.ebuild25
-rw-r--r--dev-lisp/clisp/clisp-2.30-r1.ebuild12
-rw-r--r--dev-lisp/clisp/clisp-2.30.ebuild11
-rw-r--r--dev-lisp/clisp/clisp-2.33-r1.ebuild74
5 files changed, 65 insertions, 80 deletions
diff --git a/dev-lisp/clisp/clisp-2.28.ebuild b/dev-lisp/clisp/clisp-2.28.ebuild
index 0bf05fdd2313..c2babebc5d39 100644
--- a/dev-lisp/clisp/clisp-2.28.ebuild
+++ b/dev-lisp/clisp/clisp-2.28.ebuild
@@ -1,24 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.28.ebuild,v 1.6 2004/03/30 20:58:13 spyderous Exp $
-
-IUSE="X"
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.28.ebuild,v 1.7 2004/05/10 17:39:35 vapier Exp $
DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
HOMEPAGE="http://clisp.sourceforge.net/"
SRC_URI="http://cvs2.cons.org/ftp-area/clisp/source/latest/${P}.tar.gz"
-S=${WORKDIR}/${P}
-DEPEND="X? ( virtual/x11 )"
-RDEPEND="$DEPEND"
+
LICENSE="GPL-2"
SLOT="2"
KEYWORDS="x86"
+IUSE="X"
+
+DEPEND="X? ( virtual/x11 )"
src_compile() {
local myconf="--with-dynamic-ffi --with-dynamic-modules --with-export-syscalls --with-module=wildcard --with-module=regexp --with-module=bindings/linuxlibc6"
- if [ -n "`use X`" ] ; then
- myconf="${myconf} --with-module=clx/new-clx"
- fi
+ use X && myconf="${myconf} --with-module=clx/new-clx"
unset CHOST # compilation of modules fails if we don't do this
unset CFLAGS
@@ -33,11 +30,9 @@ src_compile() {
make || die
}
-src_install () {
+src_install() {
cd src
make DESTDIR=${D} prefix=/usr install-bin || die
- install -Dm 644 clisp.1 ${D}/usr/share/man/man1/clisp.1
- install -Dm 644 clreadline.3 ${D}/usr/share/man/man3/clreadline.3
- dodoc SUMMARY README* NEWS MAGIC.add GNU-GPL COPYRIGHT ANNOUNCE clisp.dvi clisp.html clreadline.dvi clreadline.html
+ doman clisp.1 clreadline.3
+ dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE clisp.dvi clisp.html clreadline.dvi clreadline.html
}
-
diff --git a/dev-lisp/clisp/clisp-2.29.ebuild b/dev-lisp/clisp/clisp-2.29.ebuild
index e1be94c9e1d2..c1c8eb353394 100644
--- a/dev-lisp/clisp/clisp-2.29.ebuild
+++ b/dev-lisp/clisp/clisp-2.29.ebuild
@@ -1,24 +1,23 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.29.ebuild,v 1.7 2004/03/30 20:58:13 spyderous Exp $
-
-IUSE="X"
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.29.ebuild,v 1.8 2004/05/10 17:39:35 vapier Exp $
DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
HOMEPAGE="http://clisp.sourceforge.net/"
SRC_URI="http://cvs2.cons.org/ftp-area/clisp/source/latest/${P}.tar.gz"
-S=${WORKDIR}/${PN}
-DEPEND="X? ( virtual/x11 )"
-RDEPEND="$DEPEND"
+
LICENSE="GPL-2"
SLOT="2"
KEYWORDS="x86 ~ppc"
+IUSE="X"
+
+DEPEND="X? ( virtual/x11 )"
+
+S=${WORKDIR}/${PN}
src_compile() {
local myconf="--with-dynamic-ffi --with-dynamic-modules --with-export-syscalls --with-module=wildcard --with-module=regexp --with-module=bindings/linuxlibc6"
- if [ -n "`use X`" ] ; then
- myconf="${myconf} --with-module=clx/new-clx"
- fi
+ use X && myconf="${myconf} --with-module=clx/new-clx"
# compilation of modules fails if we don't do this (mkennedy: yep
# -- confirmed on gcc3.2 too)
@@ -37,11 +36,9 @@ src_compile() {
make || die
}
-src_install () {
+src_install() {
cd src
make DESTDIR=${D} prefix=/usr install-bin || die
- install -Dm 644 clisp.1 ${D}/usr/share/man/man1/clisp.1
- install -Dm 644 clreadline.3 ${D}/usr/share/man/man3/clreadline.3
- dodoc SUMMARY README* NEWS MAGIC.add GNU-GPL COPYRIGHT ANNOUNCE clisp.dvi clisp.html clreadline.dvi clreadline.html
+ doman clisp.1 clreadline.3
+ dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE clisp.dvi clisp.html clreadline.dvi clreadline.html
}
-
diff --git a/dev-lisp/clisp/clisp-2.30-r1.ebuild b/dev-lisp/clisp/clisp-2.30-r1.ebuild
index 1d0716c2a83c..b11745fc053b 100644
--- a/dev-lisp/clisp/clisp-2.30-r1.ebuild
+++ b/dev-lisp/clisp/clisp-2.30-r1.ebuild
@@ -1,19 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.30-r1.ebuild,v 1.4 2004/03/30 20:58:13 spyderous Exp $
-
-IUSE="X threads"
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.30-r1.ebuild,v 1.5 2004/05/10 17:39:35 vapier Exp $
DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
HOMEPAGE="http://clisp.sourceforge.net/"
SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-S=${WORKDIR}/${P}
-DEPEND="X? ( virtual/x11 )
- dev-lisp/common-lisp-controller"
LICENSE="GPL-2"
SLOT="2"
KEYWORDS="~x86 ~ppc"
+IUSE="X threads"
+
+DEPEND="X? ( virtual/x11 )
+ dev-lisp/common-lisp-controller"
src_unpack() {
unpack ${A}
@@ -74,4 +73,3 @@ pkg_postinst() {
pkg_prerm() {
/usr/sbin/unregister-common-lisp-implementation clisp
}
-
diff --git a/dev-lisp/clisp/clisp-2.30.ebuild b/dev-lisp/clisp/clisp-2.30.ebuild
index a7b7a58a9ad4..4ba9767c9e11 100644
--- a/dev-lisp/clisp/clisp-2.30.ebuild
+++ b/dev-lisp/clisp/clisp-2.30.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.30.ebuild,v 1.2 2004/03/30 20:58:13 spyderous Exp $
-
-IUSE="X threads"
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.30.ebuild,v 1.3 2004/05/10 17:39:35 vapier Exp $
DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
HOMEPAGE="http://clisp.sourceforge.net/"
SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-S=${WORKDIR}/${P}
-DEPEND="X? ( virtual/x11 )"
-RDEPEND="$DEPEND"
+
LICENSE="GPL-2"
SLOT="2"
KEYWORDS="~x86 ~ppc"
+IUSE="X threads"
+
+DEPEND="X? ( virtual/x11 )"
src_unpack() {
unpack ${A}
diff --git a/dev-lisp/clisp/clisp-2.33-r1.ebuild b/dev-lisp/clisp/clisp-2.33-r1.ebuild
index f3d659f888b2..b2dbd7ae23b1 100644
--- a/dev-lisp/clisp/clisp-2.33-r1.ebuild
+++ b/dev-lisp/clisp/clisp-2.33-r1.ebuild
@@ -1,47 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.33-r1.ebuild,v 1.3 2004/05/10 17:34:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.33-r1.ebuild,v 1.4 2004/05/10 17:39:35 vapier Exp $
inherit flag-o-matic common-lisp-common eutils gcc
-IUSE="X fastcgi postgres nls berkdb pcre"
-
-# Handle the case where the user has some other -falign-functions
-# option set. Bug 34630.
-
-if ! is-flag '-falign-functions=4' \
- && expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)' >/dev/null; then
- CFLAGS=${CFLAGS/\
-$(expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)')/\
--falign-functions=4}
-fi
-
-# Fails to compile without -falign-functions=4 when -march=pentium4
-# (or -march=pentium3, sometimes??) is defined. Bugs 33425 and 34630.
-
-if (is-flag '-march=pentium4' || is-flag '-march=pentium3') \
- && ! is-flag '-falign-functions=4'; then
- append-flags '-falign-functions=4'
-fi
-
-# Athlon XP users report problems with -O3 optimization. In this
-# block, we remove any optimization flag. Depending on bug 34497. we
-# may be able to reduce optimization to -O2.
-
-if is-flag '-march=athlon-xp'; then
- filter-flags '-O*'
-fi
-
-# The previous stanza might not be necessary. Bug 39830.
-
-if is-flag '-march=athlon-xp'; then
- replace-flags '-march=athlon-xp' '-mcpu=athlon-xp'
-fi
-
DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
HOMEPAGE="http://clisp.sourceforge.net/"
SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-S=${WORKDIR}/${P}
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~x86"
+IUSE="X fastcgi postgres nls berkdb pcre"
+
DEPEND="dev-libs/libsigsegv
dev-lisp/common-lisp-controller
fastcgi? ( dev-libs/fcgi )
@@ -51,9 +22,6 @@ DEPEND="dev-libs/libsigsegv
nls? ( sys-devel/gettext )
berkdb? ( =sys-libs/db-4* )
pcre? ( dev-libs/libpcre )"
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="~x86"
src_unpack() {
unpack ${A}
@@ -62,6 +30,34 @@ src_unpack() {
}
src_compile() {
+ # Handle the case where the user has some other -falign-functions
+ # option set. Bug 34630.
+ if ! is-flag '-falign-functions=4' \
+ && expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)' >/dev/null; then
+ CFLAGS=${CFLAGS/\
+ $(expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)')/\
+ -falign-functions=4}
+ fi
+
+ # Fails to compile without -falign-functions=4 when -march=pentium4
+ # (or -march=pentium3, sometimes??) is defined. Bugs 33425 and 34630.
+ if (is-flag '-march=pentium4' || is-flag '-march=pentium3') \
+ && ! is-flag '-falign-functions=4'; then
+ append-flags '-falign-functions=4'
+ fi
+
+ # Athlon XP users report problems with -O3 optimization. In this
+ # block, we remove any optimization flag. Depending on bug 34497. we
+ # may be able to reduce optimization to -O2.
+ if is-flag '-march=athlon-xp'; then
+ filter-flags '-O*'
+ fi
+
+ # The previous stanza might not be necessary. Bug 39830.
+ if is-flag '-march=athlon-xp'; then
+ replace-flags '-march=athlon-xp' '-mcpu=athlon-xp'
+ fi
+
einfo "Using CFLAGS: ${CFLAGS}"
export CC="$(gcc-getCC) ${CFLAGS}"
unset CFLAGS CXXFLAGS