summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-11-07 21:21:40 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-11-07 21:21:40 +0000
commit7cad6bac470e14df9fd0d014b96c1c0ebfd0f6ad (patch)
tree5d7fc3ba8c05ea33cd9f03fc281e12f1270313db /dev-lisp/cl-xml-psychiatrist
parentonly put boundschecking in IUSE if we're actually using the bounds checking p... (diff)
downloadgentoo-2-7cad6bac470e14df9fd0d014b96c1c0ebfd0f6ad.tar.gz
gentoo-2-7cad6bac470e14df9fd0d014b96c1c0ebfd0f6ad.tar.bz2
gentoo-2-7cad6bac470e14df9fd0d014b96c1c0ebfd0f6ad.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/cl-xml-psychiatrist')
-rw-r--r--dev-lisp/cl-xml-psychiatrist/ChangeLog0
-rw-r--r--dev-lisp/cl-xml-psychiatrist/Manifest3
-rw-r--r--dev-lisp/cl-xml-psychiatrist/cl-xml-psychiatrist-0.4.ebuild43
-rw-r--r--dev-lisp/cl-xml-psychiatrist/files/digest-cl-xml-psychiatrist-0.41
-rw-r--r--dev-lisp/cl-xml-psychiatrist/metadata.xml9
5 files changed, 56 insertions, 0 deletions
diff --git a/dev-lisp/cl-xml-psychiatrist/ChangeLog b/dev-lisp/cl-xml-psychiatrist/ChangeLog
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/dev-lisp/cl-xml-psychiatrist/ChangeLog
diff --git a/dev-lisp/cl-xml-psychiatrist/Manifest b/dev-lisp/cl-xml-psychiatrist/Manifest
new file mode 100644
index 000000000000..9fc7441b81ca
--- /dev/null
+++ b/dev-lisp/cl-xml-psychiatrist/Manifest
@@ -0,0 +1,3 @@
+MD5 0cd5d94db68646409209ec1a0e86c8d8 cl-xml-psychiatrist-0.4.ebuild 921
+MD5 30a9bc8500295971e1228982268c3d9f metadata.xml 420
+MD5 1087312bede2c4b0ad908262bdba2ae7 files/digest-cl-xml-psychiatrist-0.4 71
diff --git a/dev-lisp/cl-xml-psychiatrist/cl-xml-psychiatrist-0.4.ebuild b/dev-lisp/cl-xml-psychiatrist/cl-xml-psychiatrist-0.4.ebuild
new file mode 100644
index 000000000000..79c6882b1260
--- /dev/null
+++ b/dev-lisp/cl-xml-psychiatrist/cl-xml-psychiatrist-0.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-xml-psychiatrist/cl-xml-psychiatrist-0.4.ebuild,v 1.1 2004/11/07 21:21:40 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="A powerful XML sanity checker for Common Lisp"
+HOMEPAGE="http://common-lisp.net/project/xml-psychiatrist/"
+SRC_URI="http://common-lisp.net/project/xml-psychiatrist/xml-psychiatrist-${PV}.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+DEPEND="virtual/commonlisp
+ dev-lisp/cl-xmls
+ dev-lisp/cl-ppcre
+ doc? ( dev-tex/latex2html app-text/ghostscript )"
+
+CLPACKAGE=xml-psychiatrist
+
+S=${WORKDIR}/xml-psychiatrist-${PV}
+
+src_compile() {
+ if use doc; then
+ cd doc
+ latex manual.tex
+ dvips manual.dvi -o manual.ps
+ ps2pdf manual.ps
+ latex2html manual.tex
+ fi
+}
+
+src_install() {
+ common-lisp-install *.asd *.lisp
+ common-lisp-system-symlink
+ dodoc README
+ if use doc; then
+ cd doc
+ dohtml manual/*
+ dodoc manual.{ps,pdf}
+ fi
+}
diff --git a/dev-lisp/cl-xml-psychiatrist/files/digest-cl-xml-psychiatrist-0.4 b/dev-lisp/cl-xml-psychiatrist/files/digest-cl-xml-psychiatrist-0.4
new file mode 100644
index 000000000000..595712b83782
--- /dev/null
+++ b/dev-lisp/cl-xml-psychiatrist/files/digest-cl-xml-psychiatrist-0.4
@@ -0,0 +1 @@
+MD5 0d102a98bf7dc87a196869d19ba772e9 xml-psychiatrist-0.4.tar.gz 13833
diff --git a/dev-lisp/cl-xml-psychiatrist/metadata.xml b/dev-lisp/cl-xml-psychiatrist/metadata.xml
new file mode 100644
index 000000000000..55b943a4dac2
--- /dev/null
+++ b/dev-lisp/cl-xml-psychiatrist/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+xml-psychiatrist is an XML sanity checker for Common Lisp which is
+more powerful than DTD or XML Schema.
+</longdescription>
+</pkgmetadata>