summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-02-12 09:13:21 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-02-12 09:13:21 +0000
commit43e3c27dace2a5d95561cae575e8e8d0dff3f0c5 (patch)
treeb8f70a003c2da92e9f475a0fe908686227fc6069 /dev-lisp/cl-tclink/cl-tclink-3.3.1-r1.ebuild
parentBump to 0.5 (Manifest recommit) (diff)
downloadgentoo-2-43e3c27dace2a5d95561cae575e8e8d0dff3f0c5.tar.gz
gentoo-2-43e3c27dace2a5d95561cae575e8e8d0dff3f0c5.tar.bz2
gentoo-2-43e3c27dace2a5d95561cae575e8e8d0dff3f0c5.zip
Fire in the hole!
Diffstat (limited to 'dev-lisp/cl-tclink/cl-tclink-3.3.1-r1.ebuild')
-rw-r--r--dev-lisp/cl-tclink/cl-tclink-3.3.1-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-lisp/cl-tclink/cl-tclink-3.3.1-r1.ebuild b/dev-lisp/cl-tclink/cl-tclink-3.3.1-r1.ebuild
new file mode 100644
index 000000000000..e4d66d9c86aa
--- /dev/null
+++ b/dev-lisp/cl-tclink/cl-tclink-3.3.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tclink/cl-tclink-3.3.1-r1.ebuild,v 1.1 2004/02/12 09:13:20 mkennedy Exp $
+
+inherit common-lisp
+
+DEB_PV=3
+
+DESCRIPTION="A library of Common Lisp bindings to the TrustCommerce transaction authorization system. Now you have no excuse for not doing Business with Common Lisp!"
+HOMEPAGE="http://www.cliki.net/CL-TCLink
+ http://www.mapcar.org/~mrd/cl-tclink/"
+SRC_URI="http://www.mapcar.org/~mrd/debs/unstable/source/${PN}_${PV}.orig.tar.gz
+ http://www.mapcar.org/~mrd/debs/unstable/source/${PN}_${PV}-${DEB_PV}.diff.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+DEPEND="dev-lisp/common-lisp-controller
+ dev-libs/openssl
+ cl-split-sequence
+ cl-uffi
+ doc? ( app-text/tetex )
+ virtual/commonlisp"
+
+CLPACKAGE=tclink
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${PN}_${PV}-${DEB_PV}.diff
+}
+
+src_compile() {
+ make -C libtclink CFLAGS="-fPIC ${CFLAGS}" || die
+# use doc && make -C doc || die
+}
+
+src_install() {
+ common-lisp-install *.asd *.lisp
+ common-lisp-system-symlink
+ dodoc ChangeLog LLGPL LICENSE
+ dodoc doc/cl-tclink.txt
+ exeinto /usr/lib/cl-tclink
+ doexe libtclink/libtclink.so
+ do-debian-credits
+}