summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-02-12 09:13:21 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-02-12 09:13:21 +0000
commit43e3c27dace2a5d95561cae575e8e8d0dff3f0c5 (patch)
treeb8f70a003c2da92e9f475a0fe908686227fc6069 /dev-lisp/cl-odcl
parentBump to 0.5 (Manifest recommit) (diff)
downloadgentoo-2-43e3c27dace2a5d95561cae575e8e8d0dff3f0c5.tar.gz
gentoo-2-43e3c27dace2a5d95561cae575e8e8d0dff3f0c5.tar.bz2
gentoo-2-43e3c27dace2a5d95561cae575e8e8d0dff3f0c5.zip
Fire in the hole!
Diffstat (limited to 'dev-lisp/cl-odcl')
-rw-r--r--dev-lisp/cl-odcl/ChangeLog9
-rw-r--r--dev-lisp/cl-odcl/Manifest6
-rw-r--r--dev-lisp/cl-odcl/cl-odcl-1.3.5.ebuild38
-rw-r--r--dev-lisp/cl-odcl/files/digest-cl-odcl-1.3.51
-rw-r--r--dev-lisp/cl-odcl/metadata.xml16
5 files changed, 66 insertions, 4 deletions
diff --git a/dev-lisp/cl-odcl/ChangeLog b/dev-lisp/cl-odcl/ChangeLog
index 15327ea6530a..7721cea5bb79 100644
--- a/dev-lisp/cl-odcl/ChangeLog
+++ b/dev-lisp/cl-odcl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/cl-odcl
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-odcl/ChangeLog,v 1.2 2003/10/16 07:49:58 mkennedy Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-odcl/ChangeLog,v 1.3 2004/02/12 09:13:14 mkennedy Exp $
+
+*cl-odcl-1.3.5 (12 Feb 2004)
+
+ 12 Feb 2004; <mkennedy@gentoo.org> cl-odcl-1.3.5.ebuild, metadata.xml:
+ Cleanup for eclass changes.
*cl-odcl-1.3.4 (16 Oct 2003)
diff --git a/dev-lisp/cl-odcl/Manifest b/dev-lisp/cl-odcl/Manifest
index 276a92e4f9a8..5fe59f04e958 100644
--- a/dev-lisp/cl-odcl/Manifest
+++ b/dev-lisp/cl-odcl/Manifest
@@ -1,7 +1,9 @@
-MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
MD5 51390a2103a1f43d51bb3b5ad9223fe4 cl-odcl-1.3.3.ebuild 1513
+MD5 b20e765817129eaf41d1bd69051377e6 cl-odcl-1.3.5.ebuild 1138
MD5 b786f41a4ad2cf8627952890d23ae169 cl-odcl-1.3.4.ebuild 1650
MD5 ff39e4faa61ac8ea294e85970ceb31f6 ChangeLog 470
+MD5 2fbabdd1de915ec0c6cae311c1c0a33e metadata.xml 596
MD5 315c60a4469c95eda194018b1eb42117 files/digest-cl-odcl-1.3.3 70
-MD5 f123d753710b35e6ad767e2075f1da8b files/clisp-tests-gentoo.patch 400
MD5 a1c1b87fcf718ca756a57bb9554596f6 files/digest-cl-odcl-1.3.4 70
+MD5 4ae94c8da5ffefff9294edb1e963a3c1 files/digest-cl-odcl-1.3.5 70
+MD5 f123d753710b35e6ad767e2075f1da8b files/clisp-tests-gentoo.patch 400
diff --git a/dev-lisp/cl-odcl/cl-odcl-1.3.5.ebuild b/dev-lisp/cl-odcl/cl-odcl-1.3.5.ebuild
new file mode 100644
index 000000000000..40207ebb4819
--- /dev/null
+++ b/dev-lisp/cl-odcl/cl-odcl-1.3.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-odcl/cl-odcl-1.3.5.ebuild,v 1.1 2004/02/12 09:13:14 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="A Commmon Lisp library of utility functions."
+HOMEPAGE="http://alpha.onshored.com/lisp-software/#odcl"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-odcl/${PN}_${PV}.orig.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=odcl
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ # some tests die on clisp
+ cd ${S} && epatch ${FILESDIR}/clisp-tests-gentoo.patch || die
+}
+
+src_install() {
+ common-lisp-install *.lisp odcl.asd odcl.system
+ dodir /usr/share/common-lisp/systems
+ dosym /usr/share/common-lisp/source/odcl/odcl.asd \
+ /usr/share/common-lisp/systems/odcl.asd
+ dosym /usr/share/common-lisp/source/odcl/odcl.system \
+ /usr/share/common-lisp/systems/odcl.system
+
+ insinto /usr/share/common-lisp/source/odcl/tests
+ doins tests/*.lisp
+ dodoc COPYING ChangeLog NEWS README VERSION
+}
diff --git a/dev-lisp/cl-odcl/files/digest-cl-odcl-1.3.5 b/dev-lisp/cl-odcl/files/digest-cl-odcl-1.3.5
new file mode 100644
index 000000000000..39bec98c862e
--- /dev/null
+++ b/dev-lisp/cl-odcl/files/digest-cl-odcl-1.3.5
@@ -0,0 +1 @@
+MD5 0bb2b09e915776fdfde76a56508623d4 cl-odcl_1.3.5.orig.tar.gz 102958
diff --git a/dev-lisp/cl-odcl/metadata.xml b/dev-lisp/cl-odcl/metadata.xml
index f418045b09c8..752274c40c67 100644
--- a/dev-lisp/cl-odcl/metadata.xml
+++ b/dev-lisp/cl-odcl/metadata.xml
@@ -2,4 +2,20 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>common-lisp</herd>
+<longdescription>
+This package contains a number of useful utility functions for Lisp
+developers. Included are:
+
+ * editing contexts
+ * a transaction system
+ * filesystem database with indexing
+ * a LRU cache algorithm
+ * time functions
+ * simple i18n/l10n
+ * developer diagnostics
+ * a test regression system
+ * SMTP mailer
+ * object property sets
+ * utility functions related to lists, strings and numbers.
+</longdescription>
</pkgmetadata>