summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-03-08 22:40:12 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-03-08 22:40:12 +0000
commit9ec468f5d2fd16a629f86ec5d046d09e905fb27f (patch)
treee6c2589d8183182e52d184b8ee6d64896915c54a /dev-lisp/cl-mcclim
parentset ~ppc as 5.4 breaks building xfree on ppc (Manifest recommit) (diff)
downloadgentoo-2-9ec468f5d2fd16a629f86ec5d046d09e905fb27f.tar.gz
gentoo-2-9ec468f5d2fd16a629f86ec5d046d09e905fb27f.tar.bz2
gentoo-2-9ec468f5d2fd16a629f86ec5d046d09e905fb27f.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/cl-mcclim')
-rw-r--r--dev-lisp/cl-mcclim/ChangeLog6
-rw-r--r--dev-lisp/cl-mcclim/cl-mcclim-0.9.ebuild33
-rw-r--r--dev-lisp/cl-mcclim/files/50mcclim-gentoo.el6
3 files changed, 40 insertions, 5 deletions
diff --git a/dev-lisp/cl-mcclim/ChangeLog b/dev-lisp/cl-mcclim/ChangeLog
index cc8c969028b7..a60374899238 100644
--- a/dev-lisp/cl-mcclim/ChangeLog
+++ b/dev-lisp/cl-mcclim/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/cl-mcclim
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-mcclim/ChangeLog,v 1.1 2004/03/04 21:56:45 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-mcclim/ChangeLog,v 1.2 2004/03/08 22:40:12 mkennedy Exp $
+
+ 08 Mar 2004; <mkennedy@gentoo.org> cl-mcclim-0.9.ebuild,
+ files/50mcclim-gentoo.el:
+ Emacs support for CLIM symbol lookup and CLIM-specific indentation.
*cl-mcclim-0.9 (04 Mar 2004)
diff --git a/dev-lisp/cl-mcclim/cl-mcclim-0.9.ebuild b/dev-lisp/cl-mcclim/cl-mcclim-0.9.ebuild
index fd192efbeb8a..6d743417889c 100644
--- a/dev-lisp/cl-mcclim/cl-mcclim-0.9.ebuild
+++ b/dev-lisp/cl-mcclim/cl-mcclim-0.9.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-mcclim/cl-mcclim-0.9.ebuild,v 1.1 2004/03/04 21:56:45 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-mcclim/cl-mcclim-0.9.ebuild,v 1.2 2004/03/08 22:40:12 mkennedy Exp $
-inherit common-lisp
+inherit common-lisp elisp
DESCRIPTION="McCLIM is a free software implementation of CLIM."
HOMEPAGE="http://clim.mikemac.com/
@@ -16,12 +16,16 @@ DEPEND="dev-lisp/common-lisp-controller
dev-lisp/cl-clx-sbcl
doc? ( media-gfx/transfig
media-libs/netpbm
- virtual/tetex )"
-
+ virtual/tetex )
+ emacs? ( virtual/emacs )"
+IUSE="emacs"
CLPACKAGE="clim clim-clx clim-examples"
+SITEFILE=${FILESDIR}/50mcclim-gentoo.el
S=${WORKDIR}/McCLIM
+ELISP_SOURCES="Tools/Emacs/indent-clim.el Spec/climbols.el"
+
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${PV}/system.lisp-gentoo.patch
@@ -50,6 +54,11 @@ src_compile() {
ewarn "Documentation cannot be built with CLISP at this time"
fi
fi
+
+ if use emacs; then
+ cp ${ELISP_SOURCES} .
+ elisp-compile *.el
+ fi
}
src_install() {
@@ -76,4 +85,20 @@ src_install() {
fi
find ${D} -type d -name CVS -print |xargs rm -rf
+
+ if use emacs; then
+ insinto /usr/share/emacs/site-lisp/${PN}
+ doins *.el *.elc
+ elisp-site-file-install ${SITEFILE}
+ fi
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+ common-lisp_pkg_postinst
+}
+
+pkg_postrm() {
+ elisp_pkg_postinst
+ common-lisp_pkg_postrm
}
diff --git a/dev-lisp/cl-mcclim/files/50mcclim-gentoo.el b/dev-lisp/cl-mcclim/files/50mcclim-gentoo.el
new file mode 100644
index 000000000000..8769b164764f
--- /dev/null
+++ b/dev-lisp/cl-mcclim/files/50mcclim-gentoo.el
@@ -0,0 +1,6 @@
+
+;; mcclim site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(load-library "indent-clim")
+(load-library "climbols")