summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-04-24 21:40:59 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-04-24 21:40:59 +0000
commit850c5643a9ef0724842a46bc88e9b5cf92ca1e7a (patch)
tree2112792a1080dca575824516f566e8fc159af765 /dev-lisp/cl-jpeg
parentadded freebsd patches (#128937) and possible solution to doc generation bug (... (diff)
downloadgentoo-2-850c5643a9ef0724842a46bc88e9b5cf92ca1e7a.tar.gz
gentoo-2-850c5643a9ef0724842a46bc88e9b5cf92ca1e7a.tar.bz2
gentoo-2-850c5643a9ef0724842a46bc88e9b5cf92ca1e7a.zip
Don't try the compile-time *quantization-optimization* test when CLISP is being used; Resolves Bug #104857.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'dev-lisp/cl-jpeg')
-rw-r--r--dev-lisp/cl-jpeg/ChangeLog10
-rw-r--r--dev-lisp/cl-jpeg/cl-jpeg-1.033-r1.ebuild10
-rw-r--r--dev-lisp/cl-jpeg/files/1.033-quantize-optimization-clisp-gentoo.patch13
3 files changed, 27 insertions, 6 deletions
diff --git a/dev-lisp/cl-jpeg/ChangeLog b/dev-lisp/cl-jpeg/ChangeLog
index 1a387108c9e1..13a3fe927c50 100644
--- a/dev-lisp/cl-jpeg/ChangeLog
+++ b/dev-lisp/cl-jpeg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/cl-jpeg
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-jpeg/ChangeLog,v 1.10 2005/05/24 18:48:33 mkennedy Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-jpeg/ChangeLog,v 1.11 2006/04/24 21:40:59 mkennedy Exp $
+
+ 24 Apr 2006; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/1.033-quantize-optimization-clisp-gentoo.patch,
+ cl-jpeg-1.033-r1.ebuild:
+ Don't try the compile-time *quantization-optimization* test when CLISP is
+ being used; Resolves Bug #104857.
24 May 2005; <mkennedy@gentoo.org> cl-jpeg-1.033-r1.ebuild:
Keywording ~sparc
diff --git a/dev-lisp/cl-jpeg/cl-jpeg-1.033-r1.ebuild b/dev-lisp/cl-jpeg/cl-jpeg-1.033-r1.ebuild
index 7f5d468e26ff..fa1306d92bc5 100644
--- a/dev-lisp/cl-jpeg/cl-jpeg-1.033-r1.ebuild
+++ b/dev-lisp/cl-jpeg/cl-jpeg-1.033-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-jpeg/cl-jpeg-1.033-r1.ebuild,v 1.8 2005/05/24 18:48:33 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-jpeg/cl-jpeg-1.033-r1.ebuild,v 1.9 2006/04/24 21:40:59 mkennedy Exp $
inherit common-lisp eutils
@@ -21,8 +21,10 @@ src_unpack() {
unpack ${A}
# patch: defconstant - compilation fix for SBCL
# patch: exports - export symbols at load time as well
- epatch ${FILESDIR}/${PV}-defconstant-gentoo.patch || die
- epatch ${FILESDIR}/${PV}-exports-gentoo.patch || die
+ # patch: quantize-optimization-clisp - dont bother on CLISP
+ epatch ${FILESDIR}/${PV}-defconstant-gentoo.patch
+ epatch ${FILESDIR}/${PV}-exports-gentoo.patch
+ epatch ${FILESDIR}/${PV}-quantize-optimization-clisp-gentoo.patch
}
src_install() {
diff --git a/dev-lisp/cl-jpeg/files/1.033-quantize-optimization-clisp-gentoo.patch b/dev-lisp/cl-jpeg/files/1.033-quantize-optimization-clisp-gentoo.patch
new file mode 100644
index 000000000000..0f0edb41da5b
--- /dev/null
+++ b/dev-lisp/cl-jpeg/files/1.033-quantize-optimization-clisp-gentoo.patch
@@ -0,0 +1,13 @@
+diff -ur cljl.orig/jpeg.lisp cljl/jpeg.lisp
+--- cljl.orig/jpeg.lisp 2003-10-06 12:49:30.000000000 -0500
++++ cljl/jpeg.lisp 2006-04-24 16:37:38.000000000 -0500
+@@ -256,7 +256,8 @@
+ (finish-output)
+
+ (defvar *quantize-optimization*
+- (<= (let ((time1 (get-internal-run-time)))
++ #+clisp t
++ #-clisp (<= (let ((time1 (get-internal-run-time)))
+ (loop for i fixnum from 1 to 3000 do
+ (loop for row across *q-luminance* do
+ (loop for q-coef fixnum across row