summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-21 22:09:06 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-21 22:09:06 +0000
commita8236de5da22bdb06083168ab1fb0a77839f1dfc (patch)
tree856c049019463edc1124ab19f1c6b4190ca88210 /dev-libs
parentnew package. fixes #3841 (diff)
downloadgentoo-2-a8236de5da22bdb06083168ab1fb0a77839f1dfc.tar.gz
gentoo-2-a8236de5da22bdb06083168ab1fb0a77839f1dfc.tar.bz2
gentoo-2-a8236de5da22bdb06083168ab1fb0a77839f1dfc.zip
new package. fixes #3863
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/ucl/ChangeLog13
-rw-r--r--dev-libs/ucl/files/digest-ucl-1.011
-rw-r--r--dev-libs/ucl/ucl-1.01.ebuild22
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/ucl/ChangeLog b/dev-libs/ucl/ChangeLog
new file mode 100644
index 000000000000..f61b8b925a30
--- /dev/null
+++ b/dev-libs/ucl/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for dev-libs/ucl
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ucl/ChangeLog,v 1.1 2002/06/21 22:07:10 rphillips Exp $
+
+*ucl-1.01 (21 Jun 2002)
+
+ 21 Jun 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/dev-libs/ucl/files/digest-ucl-1.01 b/dev-libs/ucl/files/digest-ucl-1.01
new file mode 100644
index 000000000000..fa45b0a60ede
--- /dev/null
+++ b/dev-libs/ucl/files/digest-ucl-1.01
@@ -0,0 +1 @@
+MD5 1152323cd54eee905b3a9423ff43c373 ucl-1.01.tar.gz 341562
diff --git a/dev-libs/ucl/ucl-1.01.ebuild b/dev-libs/ucl/ucl-1.01.ebuild
new file mode 100644
index 000000000000..5f39027ba838
--- /dev/null
+++ b/dev-libs/ucl/ucl-1.01.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1998-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Will Glynn <delta407@lerfjhax.com>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ucl/ucl-1.01.ebuild,v 1.1 2002/06/21 22:07:10 rphillips Exp $
+
+DESCRIPTION="UCL: The UCL Compression Library"
+SRC_URI="http://www.oberhumer.com/opensource/ucl/download/ucl-1.01.tar.gz"
+HOMEPAGE="http://www.oberhumer.com/opensource/ucl/"
+LICENSE="GPL"
+
+src_compile() {
+ cd ${S}
+ ./configure --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ mkdir -p ${D}usr/src/
+ cp -r ${S} ${D}usr/src/
+}
+