summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-12-24 12:32:02 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-12-24 12:32:02 +0000
commit4f4cc10dffb9e14952d30799790c7bf01c37b52d (patch)
tree78d6decc7d4ca08955bde9c6da155839aa0fee08 /dev-libs
parentChanges from the php-overlay (diff)
downloadgentoo-2-4f4cc10dffb9e14952d30799790c7bf01c37b52d.tar.gz
gentoo-2-4f4cc10dffb9e14952d30799790c7bf01c37b52d.tar.bz2
gentoo-2-4f4cc10dffb9e14952d30799790c7bf01c37b52d.zip
Version bump, Bug 185287, from the php-overlay
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/yaz/ChangeLog8
-rw-r--r--dev-libs/yaz/files/digest-yaz-3.0.163
-rw-r--r--dev-libs/yaz/files/yaz-3.0.16-icu-automagic.patch21
-rw-r--r--dev-libs/yaz/yaz-3.0.16.ebuild60
4 files changed, 91 insertions, 1 deletions
diff --git a/dev-libs/yaz/ChangeLog b/dev-libs/yaz/ChangeLog
index a21e5f5bb5d4..d69da41de8bd 100644
--- a/dev-libs/yaz/ChangeLog
+++ b/dev-libs/yaz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/yaz
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz/ChangeLog,v 1.39 2007/08/23 05:48:26 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz/ChangeLog,v 1.40 2007/12/24 12:32:01 armin76 Exp $
+
+*yaz-3.0.16 (24 Dec 2007)
+
+ 24 Dec 2007; Raúl Porcel <armin76@gentoo.org>
+ +files/yaz-3.0.16-icu-automagic.patch, +yaz-3.0.16.ebuild:
+ Version bump, Bug 185287, from the php-overlay
23 Aug 2007; Joshua Kinard <kumba@gentoo.org> yaz-2.1.42.ebuild:
Stable on mips, per #173849.
diff --git a/dev-libs/yaz/files/digest-yaz-3.0.16 b/dev-libs/yaz/files/digest-yaz-3.0.16
new file mode 100644
index 000000000000..e7ab4a8b5322
--- /dev/null
+++ b/dev-libs/yaz/files/digest-yaz-3.0.16
@@ -0,0 +1,3 @@
+MD5 ccaf14874f65e0519809b41181a5adea yaz-3.0.16.tar.gz 1817589
+RMD160 228bd3dea04168debb7a6cc13d9883aba9c53f10 yaz-3.0.16.tar.gz 1817589
+SHA256 1040c9a8234de250882c54dce10458f23d9064b13a963d888ddae111bc0bb246 yaz-3.0.16.tar.gz 1817589
diff --git a/dev-libs/yaz/files/yaz-3.0.16-icu-automagic.patch b/dev-libs/yaz/files/yaz-3.0.16-icu-automagic.patch
new file mode 100644
index 000000000000..d5fc86491f28
--- /dev/null
+++ b/dev-libs/yaz/files/yaz-3.0.16-icu-automagic.patch
@@ -0,0 +1,21 @@
+--- configure.ac.orig 2007-11-12 09:58:16.000000000 +0100
++++ configure.ac 2007-12-18 13:22:33.000000000 +0100
+@@ -314,10 +314,14 @@
+ AC_SUBST(YAZ_CONFIG_CFLAGS)
+ dnl
+ dnl
+-AC_CHECK_ICU([3.6],[
+- ICU_CPPFLAGS="$ICU_CPPFLAGS -D YAZ_HAVE_ICU=1"],[
+- AC_MSG_WARN([For ICU support please install libicu36-dev or similar])
+-])
++dnl ------ ICU
++AC_ARG_ENABLE(icu, [ --enable-icu enable ICU support],[enable_icu=$enableval],[enable_icu=no])
++if test "$enable_icu" = "yes"; then
++ AC_CHECK_ICU([3.6],[
++ ICU_CPPFLAGS="$ICU_CPPFLAGS -D YAZ_HAVE_ICU=1"],[
++ AC_MSG_ERROR([For ICU support please install libicu36-dev or similar])
++ ])
++fi
+ dnl ------ GNU threads
+ HAVETHREADS=0
+ AC_ARG_ENABLE(pth, [ --enable-pth enable GNU threads],[enable_pth=$enableval],[enable_pth=no])
diff --git a/dev-libs/yaz/yaz-3.0.16.ebuild b/dev-libs/yaz/yaz-3.0.16.ebuild
new file mode 100644
index 000000000000..22c8044578e1
--- /dev/null
+++ b/dev-libs/yaz/yaz-3.0.16.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz/yaz-3.0.16.ebuild,v 1.1 2007/12/24 12:32:01 armin76 Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="C/C++ programmer's toolkit supporting the development of Z39.50v3 clients and servers"
+HOMEPAGE="http://www.indexdata.dk/yaz"
+SRC_URI="http://ftp.indexdata.dk/pub/${PN}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="debug icu tcpd ziffy"
+
+RDEPEND="dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/openssl
+ icu? ( dev-libs/icu )
+ tcpd? ( sys-apps/tcp-wrappers )
+ ziffy? ( net-libs/libpcap )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-lang/tcl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-icu-automagic.patch
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ econf \
+ --enable-static \
+ --enable-shared \
+ $(use_enable debug memdebug) \
+ $(use_enable icu) \
+ $(use_enable tcpd tcpd /usr) \
+ $(use_with ziffy pcap /usr)
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ local docdir="/usr/share/doc/${PF}"
+ emake DESTDIR="${D}" docdir="${docdir}" install || die "install failed"
+
+ dodir ${docdir}/html
+ mv -f "${D}"/${docdir}/*.{html,png} "${D}"/${docdir}/html/ || die "Failed to move HTML docs"
+ mv -f "${D}"/usr/share/doc/${PN}/common "${D}"/${docdir}/html/ || die "Failed to move HTML docs"
+ rm -rf "${D}"/usr/share/doc/${PN}
+
+ dodoc ChangeLog NEWS README TODO
+ if use ziffy ; then
+ for doc in AUTHORS ChangeLog FAQ NEWS README TODO ; do
+ newdoc ziffy/${doc} ${doc}-ziffy
+ done
+ fi
+}