summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-06-27 08:46:59 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-06-27 08:46:59 +0000
commit14ebabc48bef83ecbdb2b8851ff53b350068d994 (patch)
tree305995c5a06320eddeb2043c964fb0c1e125d8b3 /dev-libs
parentMove econf to src_configure, drop static use flag. Bug #515396. (diff)
downloadgentoo-2-14ebabc48bef83ecbdb2b8851ff53b350068d994.tar.gz
gentoo-2-14ebabc48bef83ecbdb2b8851ff53b350068d994.tar.bz2
gentoo-2-14ebabc48bef83ecbdb2b8851ff53b350068d994.zip
Bump to 6.1.8, thanks to slepnoga
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/ucommon/ChangeLog9
-rw-r--r--dev-libs/ucommon/files/6.1/disable_rtf_gen_doxy.patch11
-rw-r--r--dev-libs/ucommon/files/6.1/gcrypt_autotools.patch58
-rw-r--r--dev-libs/ucommon/files/6.1/install_gcrypt.m4_file.patch128
-rw-r--r--dev-libs/ucommon/ucommon-6.1.8.ebuild75
5 files changed, 280 insertions, 1 deletions
diff --git a/dev-libs/ucommon/ChangeLog b/dev-libs/ucommon/ChangeLog
index 080e3073d88b..e983df99a7ea 100644
--- a/dev-libs/ucommon/ChangeLog
+++ b/dev-libs/ucommon/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/ucommon
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ucommon/ChangeLog,v 1.19 2014/03/01 22:19:31 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ucommon/ChangeLog,v 1.20 2014/06/27 08:46:59 maksbotan Exp $
+
+*ucommon-6.1.8 (27 Jun 2014)
+
+ 27 Jun 2014; Maxim Koltsov <maksbotan@gentoo.org>
+ +files/6.1/disable_rtf_gen_doxy.patch, +files/6.1/gcrypt_autotools.patch,
+ +files/6.1/install_gcrypt.m4_file.patch, +ucommon-6.1.8.ebuild:
+ Bump to 6.1.8, thanks to slepnoga
01 Mar 2014; Michał Górny <mgorny@gentoo.org> ucommon-5.2.2-r3.ebuild,
ucommon-6.0.3.ebuild:
diff --git a/dev-libs/ucommon/files/6.1/disable_rtf_gen_doxy.patch b/dev-libs/ucommon/files/6.1/disable_rtf_gen_doxy.patch
new file mode 100644
index 000000000000..1aaf478ed320
--- /dev/null
+++ b/dev-libs/ucommon/files/6.1/disable_rtf_gen_doxy.patch
@@ -0,0 +1,11 @@
+--- Doxyfile.orig 2014-06-26 23:56:45.724303475 +0300
++++ Doxyfile 2014-06-26 23:57:12.875021734 +0300
+@@ -40,7 +40,7 @@
+ GENERATE_HTMLHELP = YES
+ GENERATE_TREEVIEW = NO
+ TREEVIEW_WIDTH = 256
+-GENERATE_LATEX = YES
++GENERATE_LATEX = NO
+ COMPACT_LATEX = YES
+ PDF_HYPERLINKS = YES
+ USE_PDFLATEX = NO
diff --git a/dev-libs/ucommon/files/6.1/gcrypt_autotools.patch b/dev-libs/ucommon/files/6.1/gcrypt_autotools.patch
new file mode 100644
index 000000000000..2ec0858245d9
--- /dev/null
+++ b/dev-libs/ucommon/files/6.1/gcrypt_autotools.patch
@@ -0,0 +1,58 @@
+diff --git a/Makefile.am b/Makefile.am
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -8,6 +8,8 @@
+ # WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
+ # implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+
++ACLOCAL_AMFLAGS = -I m4
++
+ EXTRA_DIST = autogen.sh README* *.pc.in *.spec.in *.spec *-config.in \
+ *-config.1 Doxyfile cmodel.sh BUILDS SUPPORT COPYING* COPYRIGHT \
+ CMakeLists.txt ucommon-config.cmake ucommon.pc.cmake cmake-abi.sh \
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -40,6 +40,9 @@
+
+ CHECKFLAGS="$CHECKFLAGS"
+
++m4_include([m4/libgcrypt.m4])
++
++
+ case "$with_crypto" in
+ ssl|openssl)
+ ssl="openssl"
+@@ -698,6 +701,8 @@
+ gnutls|gnu)
+ if test ! -z "$GNUTLS_LIBS" ; then
+ SECURE_LIBS="$GNUTLS_LIBS"
++ AM_PATH_LIBGCRYPT
++ SECURE_LIBS="$GNUTLS_LIBS $LIBGCRYPT_LIBS"
+ SECURE="gnutls"
+ fi
+ ;;
+diff --git a/utils/Makefile.am b/utils/Makefile.am
+--- a/utils/Makefile.am
++++ b/utils/Makefile.am
+@@ -9,9 +9,9 @@
+ # implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+
+ MAINTAINERCLEANFILES = Makefile.in Makefile
+-AM_CXXFLAGS = -I$(top_srcdir)/inc @UCOMMON_FLAGS@
++AM_CXXFLAGS = -I$(top_srcdir)/inc @UCOMMON_FLAGS@ @LIBGCRYPT_CFLAGS@
+ AM_CPPFLAGS = -I$(top_srcdir)/inc
+-LDADD = ../corelib/libucommon.la @UCOMMON_LIBS@ @UCOMMON_CLINK@
++LDADD = ../corelib/libucommon.la @UCOMMON_LIBS@ @UCOMMON_CLINK@ @LIBGCRYPT_LIBS@
+ EXTRA_DIST = *.1
+
+ man_MANS = args.1 scrub-files.1 mdsum.1 zerofill.1 car.1 sockaddr.1 \
+@@ -30,7 +30,7 @@
+ scrub_files_LDFLAGS = @SECURE_LOCAL@
+
+ mdsum_SOURCES = mdsum.cpp
+-mdsum_LDFLAGS = @SECURE_LOCAL@
++mdsum_LDFLAGS = @SECURE_LOCAL@ @LIBGCRYPT_LIBS@
+
+ zerofill_SOURCES = zerofill.cpp
+ zerofill_LDFLAGS = @SECURE_LOCAL@
diff --git a/dev-libs/ucommon/files/6.1/install_gcrypt.m4_file.patch b/dev-libs/ucommon/files/6.1/install_gcrypt.m4_file.patch
new file mode 100644
index 000000000000..5fb0cc3b878d
--- /dev/null
+++ b/dev-libs/ucommon/files/6.1/install_gcrypt.m4_file.patch
@@ -0,0 +1,128 @@
+diff --git a/m4/libgcrypt.m4 b/m4/libgcrypt.m4
+new file mode 100644
+--- /dev/null
++++ m4/libgcrypt.m4
+@@ -0,0 +1,123 @@
++dnl Autoconf macros for libgcrypt
++dnl Copyright (C) 2002, 2004 Free Software Foundation, Inc.
++dnl
++dnl This file is free software; as a special exception the author gives
++dnl unlimited permission to copy and/or distribute it, with or without
++dnl modifications, as long as this notice is preserved.
++dnl
++dnl This file is distributed in the hope that it will be useful, but
++dnl WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
++dnl implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
++
++
++dnl AM_PATH_LIBGCRYPT([MINIMUM-VERSION,
++dnl [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND ]]])
++dnl Test for libgcrypt and define LIBGCRYPT_CFLAGS and LIBGCRYPT_LIBS.
++dnl MINIMUN-VERSION is a string with the version number optionalliy prefixed
++dnl with the API version to also check the API compatibility. Example:
++dnl a MINIMUN-VERSION of 1:1.2.5 won't pass the test unless the installed
++dnl version of libgcrypt is at least 1.2.5 *and* the API number is 1. Using
++dnl this features allows to prevent build against newer versions of libgcrypt
++dnl with a changed API.
++dnl
++AC_DEFUN([AM_PATH_LIBGCRYPT],
++[ AC_ARG_WITH(libgcrypt-prefix,
++ AC_HELP_STRING([--with-libgcrypt-prefix=PFX],
++ [prefix where LIBGCRYPT is installed (optional)]),
++ libgcrypt_config_prefix="$withval", libgcrypt_config_prefix="")
++ if test x$libgcrypt_config_prefix != x ; then
++ if test x${LIBGCRYPT_CONFIG+set} != xset ; then
++ LIBGCRYPT_CONFIG=$libgcrypt_config_prefix/bin/libgcrypt-config
++ fi
++ fi
++
++ AC_PATH_TOOL(LIBGCRYPT_CONFIG, libgcrypt-config, no)
++ tmp=ifelse([$1], ,1:1.2.0,$1)
++ if echo "$tmp" | grep ':' >/dev/null 2>/dev/null ; then
++ req_libgcrypt_api=`echo "$tmp" | sed 's/\(.*\):\(.*\)/\1/'`
++ min_libgcrypt_version=`echo "$tmp" | sed 's/\(.*\):\(.*\)/\2/'`
++ else
++ req_libgcrypt_api=0
++ min_libgcrypt_version="$tmp"
++ fi
++
++ AC_MSG_CHECKING(for LIBGCRYPT - version >= $min_libgcrypt_version)
++ ok=no
++ if test "$LIBGCRYPT_CONFIG" != "no" ; then
++ req_major=`echo $min_libgcrypt_version | \
++ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\1/'`
++ req_minor=`echo $min_libgcrypt_version | \
++ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\2/'`
++ req_micro=`echo $min_libgcrypt_version | \
++ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\3/'`
++ libgcrypt_config_version=`$LIBGCRYPT_CONFIG --version`
++ major=`echo $libgcrypt_config_version | \
++ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\1/'`
++ minor=`echo $libgcrypt_config_version | \
++ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\2/'`
++ micro=`echo $libgcrypt_config_version | \
++ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\3/'`
++ if test "$major" -gt "$req_major"; then
++ ok=yes
++ else
++ if test "$major" -eq "$req_major"; then
++ if test "$minor" -gt "$req_minor"; then
++ ok=yes
++ else
++ if test "$minor" -eq "$req_minor"; then
++ if test "$micro" -ge "$req_micro"; then
++ ok=yes
++ fi
++ fi
++ fi
++ fi
++ fi
++ fi
++ if test $ok = yes; then
++ AC_MSG_RESULT([yes ($libgcrypt_config_version)])
++ else
++ AC_MSG_RESULT(no)
++ fi
++ if test $ok = yes; then
++ # If we have a recent libgcrypt, we should also check that the
++ # API is compatible
++ if test "$req_libgcrypt_api" -gt 0 ; then
++ tmp=`$LIBGCRYPT_CONFIG --api-version 2>/dev/null || echo 0`
++ if test "$tmp" -gt 0 ; then
++ AC_MSG_CHECKING([LIBGCRYPT API version])
++ if test "$req_libgcrypt_api" -eq "$tmp" ; then
++ AC_MSG_RESULT([okay])
++ else
++ ok=no
++ AC_MSG_RESULT([does not match. want=$req_libgcrypt_api got=$tmp])
++ fi
++ fi
++ fi
++ fi
++ if test $ok = yes; then
++ LIBGCRYPT_CFLAGS=`$LIBGCRYPT_CONFIG --cflags`
++ LIBGCRYPT_LIBS=`$LIBGCRYPT_CONFIG --libs`
++ ifelse([$2], , :, [$2])
++ if test x"$host" != x ; then
++ libgcrypt_config_host=`$LIBGCRYPT_CONFIG --host 2>/dev/null || echo none`
++ if test x"$libgcrypt_config_host" != xnone ; then
++ if test x"$libgcrypt_config_host" != x"$host" ; then
++ AC_MSG_WARN([[
++***
++*** The config script $LIBGCRYPT_CONFIG was
++*** built for $libgcrypt_config_host and thus may not match the
++*** used host $host.
++*** You may want to use the configure option --with-libgcrypt-prefix
++*** to specify a matching config script.
++***]])
++ fi
++ fi
++ fi
++ else
++ LIBGCRYPT_CFLAGS=""
++ LIBGCRYPT_LIBS=""
++ ifelse([$3], , :, [$3])
++ fi
++ AC_SUBST(LIBGCRYPT_CFLAGS)
++ AC_SUBST(LIBGCRYPT_LIBS)
++])
diff --git a/dev-libs/ucommon/ucommon-6.1.8.ebuild b/dev-libs/ucommon/ucommon-6.1.8.ebuild
new file mode 100644
index 000000000000..858c5a1c74d8
--- /dev/null
+++ b/dev-libs/ucommon/ucommon-6.1.8.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ucommon/ucommon-6.1.8.ebuild,v 1.1 2014/06/27 08:46:59 maksbotan Exp $
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Portable C++ runtime for threads and sockets"
+HOMEPAGE="http://www.gnu.org/software/commoncpp"
+SRC_URI="mirror://gnu/commoncpp/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE="doc static-libs socks +cxx debug ssl gnutls"
+
+RDEPEND="ssl? (
+ !gnutls? ( dev-libs/openssl )
+ gnutls? (
+ net-libs/gnutls
+ dev-libs/libgcrypt
+ )
+ )"
+
+DEPEND="virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ ${RDEPEND}"
+
+DOCS=(README NEWS SUPPORT ChangeLog AUTHORS)
+PATCHES=( "${FILESDIR}"/6.1/disable_rtf_gen_doxy.patch
+ "${FILESDIR}"/6.1/install_gcrypt.m4_file.patch
+ "${FILESDIR}"/6.1/gcrypt_autotools.patch )
+
+#AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+
+ # Aclocal 1.13 deprecated error BGO #467674
+ sed -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' -i configure.ac || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myconf=""
+ if use ssl; then
+ myconf+=" --with-sslstack=$(usex gnutls gnu ssl) "
+ else
+ myconf+=" --with-sslstack=nossl ";
+ fi
+
+ local myeconfargs=(
+ $(use_enable socks)
+ $(use_enable cxx stdcpp)
+ ${myconf}
+ --enable-atomics
+ --with-pkg-config
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile doxy
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use doc; then
+ dohtml doc/html/*
+ fi
+}