summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-01-11 02:53:14 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-01-11 02:53:14 +0000
commitf9bb611d8c40319491fa2db472ef5e70de68be8e (patch)
treecc7b8686e1cb25f733e9990d704cf8aaa0ac7e99 /dev-libs/xapian/xapian-1.2.13.ebuild
parentstop using built_with_use (diff)
downloadgentoo-2-f9bb611d8c40319491fa2db472ef5e70de68be8e.tar.gz
gentoo-2-f9bb611d8c40319491fa2db472ef5e70de68be8e.tar.bz2
gentoo-2-f9bb611d8c40319491fa2db472ef5e70de68be8e.zip
Version bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-libs/xapian/xapian-1.2.13.ebuild')
-rw-r--r--dev-libs/xapian/xapian-1.2.13.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/xapian/xapian-1.2.13.ebuild b/dev-libs/xapian/xapian-1.2.13.ebuild
new file mode 100644
index 000000000000..0fd84ba0e00f
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.2.13.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/xapian-1.2.13.ebuild,v 1.1 2013/01/11 02:53:14 blueness Exp $
+
+EAPI="4"
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc static-libs -sse +sse2 +brass +chert +inmemory"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local myconf=""
+
+ ewarn
+ if use sse2; then
+ ewarn "Using sse2"
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use sse; then
+ ewarn "Using sse"
+ myconf="${myconf} --enable-sse=sse"
+ else
+ ewarn "Disabling sse and sse2"
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+ ewarn
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use brass || myconf="${myconf} --disable-backend-brass"
+ use chert || myconf="${myconf} --disable-backend-chert"
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+
+ myconf="${myconf} --enable-backend-flint --enable-backend-remote"
+
+ econf $myconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ mv "${D}usr/share/doc/xapian-core" "${D}usr/share/doc/${PF}"
+ use doc || rm -rf "${D}usr/share/doc/${PF}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+}
+
+src_test() {
+ emake check VALGRIND=
+}