summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2013-03-07 23:19:26 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2013-03-07 23:19:26 +0000
commitc0dea6a879b7418a31a9753d16dda673d5612081 (patch)
treee7a03f3978aa82e2130b2200c76b2a1506c2d4af /dev-libs/re2/re2-0_p20130115.ebuild
parentDon't install NOTES for live ebuild (bug #460726 by Joe M). (diff)
downloadgentoo-2-c0dea6a879b7418a31a9753d16dda673d5612081.tar.gz
gentoo-2-c0dea6a879b7418a31a9753d16dda673d5612081.tar.bz2
gentoo-2-c0dea6a879b7418a31a9753d16dda673d5612081.zip
Version bump. Remove old.
(Portage version: 2.1.11.50/cvs/Linux i686, signed Manifest commit with key 30427902)
Diffstat (limited to 'dev-libs/re2/re2-0_p20130115.ebuild')
-rw-r--r--dev-libs/re2/re2-0_p20130115.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/re2/re2-0_p20130115.ebuild b/dev-libs/re2/re2-0_p20130115.ebuild
new file mode 100644
index 000000000000..9bbae2fc5772
--- /dev/null
+++ b/dev-libs/re2/re2-0_p20130115.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/re2/re2-0_p20130115.ebuild,v 1.1 2013/03/07 23:19:26 phajdan.jr Exp $
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="An efficent, principled regular expression library"
+HOMEPAGE="http://code.google.com/p/re2/"
+SRC_URI="http://re2.googlecode.com/files/${PN}-${PV##*_p}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+# TODO: the directory in the tarball should really be versioned.
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # Fix problems with FilteredRE2 symbols not being exported.
+ epatch "${FILESDIR}/${PN}-symbols-r0.patch"
+}
+
+src_compile() {
+ makeopts=(
+ AR="$(tc-getAR)"
+ CXX="$(tc-getCXX)"
+ CXXFLAGS="${CXXFLAGS} -pthread"
+ LDFLAGS="${LDFLAGS} -pthread"
+ NM="$(tc-getNM)"
+ )
+ emake "${makeopts[@]}"
+}
+
+src_test() {
+ emake "${makeopts[@]}" shared-test
+}
+
+src_install() {
+ emake DESTDIR="${ED}" prefix=usr libdir=usr/$(get_libdir) install
+ # TODO: the upstream should not build static library at all.
+ rm "${ED}/usr/$(get_libdir)/libre2.a" || die
+ dodoc AUTHORS CONTRIBUTORS README doc/syntax.txt
+ dohtml doc/syntax.html
+}