summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-05-21 20:14:08 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-05-21 20:14:08 +0000
commit1151663de602e2a3d104962bd6652c4cdd81c4f8 (patch)
tree3b9e58c32ebb5d063b28eaa2976ae160addddf00 /dev-libs/qoauth
parentinherit eutils for make_desktop_entry (diff)
downloadgentoo-2-1151663de602e2a3d104962bd6652c4cdd81c4f8.tar.gz
gentoo-2-1151663de602e2a3d104962bd6652c4cdd81c4f8.tar.bz2
gentoo-2-1151663de602e2a3d104962bd6652c4cdd81c4f8.zip
EAPI=4
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/qoauth')
-rw-r--r--dev-libs/qoauth/ChangeLog5
-rw-r--r--dev-libs/qoauth/qoauth-1.0.1.ebuild18
2 files changed, 13 insertions, 10 deletions
diff --git a/dev-libs/qoauth/ChangeLog b/dev-libs/qoauth/ChangeLog
index 3ec1af3e808a..2e64719dda50 100644
--- a/dev-libs/qoauth/ChangeLog
+++ b/dev-libs/qoauth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/qoauth
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/qoauth/ChangeLog,v 1.17 2012/05/21 19:58:32 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qoauth/ChangeLog,v 1.18 2012/05/21 20:14:08 pesa Exp $
+
+ 21 May 2012; Davide Pesavento <pesa@gentoo.org> qoauth-1.0.1.ebuild:
+ EAPI=4
21 May 2012; Davide Pesavento <pesa@gentoo.org> qoauth-1.0.1.ebuild:
Use more qt4-r2 eclass features.
diff --git a/dev-libs/qoauth/qoauth-1.0.1.ebuild b/dev-libs/qoauth/qoauth-1.0.1.ebuild
index fdd94ad87e6f..195b08d12344 100644
--- a/dev-libs/qoauth/qoauth-1.0.1.ebuild
+++ b/dev-libs/qoauth/qoauth-1.0.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/qoauth/qoauth-1.0.1.ebuild,v 1.8 2012/05/21 19:58:32 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qoauth/qoauth-1.0.1.ebuild,v 1.9 2012/05/21 20:14:08 pesa Exp $
-EAPI=2
+EAPI=4
inherit qt4-r2
@@ -18,7 +18,7 @@ IUSE="debug doc static-libs test"
COMMON_DEPEND="app-crypt/qca:2[debug?]"
DEPEND="${COMMON_DEPEND}
doc? ( app-doc/doxygen )
- test? ( x11-libs/qt-test )
+ test? ( x11-libs/qt-test:4 )
"
RDEPEND="${COMMON_DEPEND}
app-crypt/qca-ossl:2[debug?]
@@ -41,8 +41,8 @@ src_prepare() {
fi
sed -i -e '/^ *docs \\$/d' \
- -e '/^ *build_all \\$/d' \
- -e 's/^\#\(!macx\)/\1/' \
+ -e '/^ *build_all \\$/d' \
+ -e 's/^\#\(!macx\)/\1/' \
src/src.pro || die "sed failed"
sed -i -e "s/\(.*\)lib$/\1$(get_libdir)/" src/pcfile.sh || die "sed failed"
@@ -51,7 +51,7 @@ src_prepare() {
src_compile() {
default
if use static-libs; then
- emake -C src static || die "emake failed"
+ emake -C src static
fi
}
@@ -59,11 +59,11 @@ src_install() {
qt4-r2_src_install
if use static-libs; then
- dolib.a "${S}/lib/lib${PN}.a" || die "dolib failed"
+ dolib.a "${S}"/lib/lib${PN}.a
fi
if use doc; then
- doxygen "${S}/Doxyfile" || die "Failed to generate documentation"
- dohtml "${S}"/doc/html/* || die "Failed to install documentation"
+ doxygen "${S}"/Doxyfile || die "failed to generate documentation"
+ dohtml "${S}"/doc/html/*
fi
}