summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-01-05 13:56:15 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-01-05 13:56:15 +0000
commit424646178fd6c35e72b9f3f29824cd11f00f1a71 (patch)
tree581ff140585c8826912a9f4cca7a7ca2c991b9fa /dev-libs/pkcs11-helper/pkcs11-helper-1.02.ebuild
parentpunt old versions (diff)
downloadgentoo-2-424646178fd6c35e72b9f3f29824cd11f00f1a71.tar.gz
gentoo-2-424646178fd6c35e72b9f3f29824cd11f00f1a71.tar.bz2
gentoo-2-424646178fd6c35e72b9f3f29824cd11f00f1a71.zip
Initial import
(Portage version: 2.1.1-r2)
Diffstat (limited to 'dev-libs/pkcs11-helper/pkcs11-helper-1.02.ebuild')
-rw-r--r--dev-libs/pkcs11-helper/pkcs11-helper-1.02.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/pkcs11-helper/pkcs11-helper-1.02.ebuild b/dev-libs/pkcs11-helper/pkcs11-helper-1.02.ebuild
new file mode 100644
index 000000000000..a764c162c033
--- /dev/null
+++ b/dev-libs/pkcs11-helper/pkcs11-helper-1.02.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pkcs11-helper/pkcs11-helper-1.02.ebuild,v 1.1 2007/01/05 13:56:15 alonbl Exp $
+
+DESCRIPTION="PKCS#11 helper library"
+HOMEPAGE="http://www.opensc-project.org/pkcs11-helper"
+SRC_URI="http://www.opensc-project.org/files/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/openssl-0.9.7"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=app-doc/doxygen-1.4.7 )"
+
+src_compile() {
+ econf $(use_enable doc)
+ emake
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+}