summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-05-16 09:19:58 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-05-16 09:19:58 +0000
commite77bb9df99f56d45903da4db77ea4060120bbe57 (patch)
treef1b4a6af4ed9d5f1fbe414ac86a9033e69d6f09a /dev-libs/openct
parentMigration to virtual/libusb. Verified by code inspection. (diff)
downloadgentoo-2-e77bb9df99f56d45903da4db77ea4060120bbe57.tar.gz
gentoo-2-e77bb9df99f56d45903da4db77ea4060120bbe57.tar.bz2
gentoo-2-e77bb9df99f56d45903da4db77ea4060120bbe57.zip
Migration to virtual/libusb. Verified by code inspection.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/openct')
-rw-r--r--dev-libs/openct/ChangeLog6
-rw-r--r--dev-libs/openct/openct-0.6.14-r1.ebuild6
-rw-r--r--dev-libs/openct/openct-0.6.14.ebuild6
-rw-r--r--dev-libs/openct/openct-0.6.15.ebuild4
4 files changed, 13 insertions, 9 deletions
diff --git a/dev-libs/openct/ChangeLog b/dev-libs/openct/ChangeLog
index ccb65333099c..027941f5ca70 100644
--- a/dev-libs/openct/ChangeLog
+++ b/dev-libs/openct/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/openct
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openct/ChangeLog,v 1.66 2009/05/15 21:54:19 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openct/ChangeLog,v 1.67 2009/05/16 09:19:58 robbat2 Exp $
+
+ 16 May 2009; Robin H. Johnson <robbat2@gentoo.org> openct-0.6.14.ebuild,
+ openct-0.6.14-r1.ebuild, openct-0.6.15.ebuild:
+ Migration to virtual/libusb. Verified by code inspection.
*openct-0.6.16 (15 May 2009)
diff --git a/dev-libs/openct/openct-0.6.14-r1.ebuild b/dev-libs/openct/openct-0.6.14-r1.ebuild
index 8e11c3c0920d..4334d3830f2d 100644
--- a/dev-libs/openct/openct-0.6.14-r1.ebuild
+++ b/dev-libs/openct/openct-0.6.14-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openct/openct-0.6.14-r1.ebuild,v 1.4 2008/08/30 04:47:45 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openct/openct-0.6.14-r1.ebuild,v 1.5 2009/05/16 09:19:58 robbat2 Exp $
inherit eutils flag-o-matic
@@ -14,7 +14,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~spar
IUSE="usb"
RDEPEND=">=sys-fs/udev-096
- usb? ( >=dev-libs/libusb-0.1.7 )"
+ usb? ( =virtual/libusb-0* )"
pkg_setup() {
enewgroup openct
diff --git a/dev-libs/openct/openct-0.6.14.ebuild b/dev-libs/openct/openct-0.6.14.ebuild
index adb5146980dc..92fb711d1775 100644
--- a/dev-libs/openct/openct-0.6.14.ebuild
+++ b/dev-libs/openct/openct-0.6.14.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openct/openct-0.6.14.ebuild,v 1.11 2008/10/31 21:38:26 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openct/openct-0.6.14.ebuild,v 1.12 2009/05/16 09:19:58 robbat2 Exp $
inherit eutils
@@ -14,7 +14,7 @@ KEYWORDS="~alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh ~sparc x86"
IUSE="usb"
RDEPEND="usb? (
- >=dev-libs/libusb-0.1.7
+ =virtual/libusb-0*
|| ( >=sys-fs/udev-096 >=sys-apps/hotplug-20040923 )
)"
diff --git a/dev-libs/openct/openct-0.6.15.ebuild b/dev-libs/openct/openct-0.6.15.ebuild
index 032b2be40a20..a4687fe2e2c7 100644
--- a/dev-libs/openct/openct-0.6.15.ebuild
+++ b/dev-libs/openct/openct-0.6.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openct/openct-0.6.15.ebuild,v 1.7 2009/05/02 19:10:30 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openct/openct-0.6.15.ebuild,v 1.8 2009/05/16 09:19:58 robbat2 Exp $
inherit eutils
@@ -15,7 +15,7 @@ SLOT="0"
IUSE="doc pcsc-lite usb"
RDEPEND="pcsc-lite? ( sys-apps/pcsc-lite )
- usb? ( >=dev-libs/libusb-0.1.7 )
+ usb? ( =virtual/libusb-0* )
>=sys-fs/udev-096"
DEPEND="${RDEPEND}