summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-01-06 13:49:00 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-01-06 13:49:00 +0000
commit6973e3187891ea3d9cfa6d4e2eaf8ce48f7922c5 (patch)
tree1d7fe76df3ea9dcd8ecccc6dccd48c1d0f193569 /dev-libs/log4cxx
parentNew upstream version. (Manifest recommit) (diff)
downloadgentoo-2-6973e3187891ea3d9cfa6d4e2eaf8ce48f7922c5.tar.gz
gentoo-2-6973e3187891ea3d9cfa6d4e2eaf8ce48f7922c5.tar.bz2
gentoo-2-6973e3187891ea3d9cfa6d4e2eaf8ce48f7922c5.zip
Fix compilation failure - bug 59743.
Diffstat (limited to 'dev-libs/log4cxx')
-rw-r--r--dev-libs/log4cxx/ChangeLog8
-rw-r--r--dev-libs/log4cxx/Manifest17
-rw-r--r--dev-libs/log4cxx/files/log4cxx-0.9.5-fix-errno.diff24
-rw-r--r--dev-libs/log4cxx/log4cxx-0.9.5.ebuild25
-rw-r--r--dev-libs/log4cxx/log4cxx-0.9.7-r1.ebuild4
5 files changed, 50 insertions, 28 deletions
diff --git a/dev-libs/log4cxx/ChangeLog b/dev-libs/log4cxx/ChangeLog
index 5788d5bb02a7..19e9d5a4a262 100644
--- a/dev-libs/log4cxx/ChangeLog
+++ b/dev-libs/log4cxx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/log4cxx
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4cxx/ChangeLog,v 1.7 2004/12/28 10:42:23 ka0ttic Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4cxx/ChangeLog,v 1.8 2005/01/06 13:49:00 ka0ttic Exp $
+
+ 06 Jan 2005; Aaron Walker <ka0ttic@gentoo.org>
+ +files/log4cxx-0.9.5-fix-errno.diff, log4cxx-0.9.5.ebuild:
+ Fix compilation failure - bug 59743.
*log4cxx-0.9.7-r1 (28 Dec 2004)
diff --git a/dev-libs/log4cxx/Manifest b/dev-libs/log4cxx/Manifest
index 2f6c80782360..57a07e09f0c5 100644
--- a/dev-libs/log4cxx/Manifest
+++ b/dev-libs/log4cxx/Manifest
@@ -1,17 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 adcca9155baaf2f4fa19a0842596869f log4cxx-0.9.7-r1.ebuild 1559
-MD5 839e6262a6479c9c33123a3d77a195b7 log4cxx-0.9.5.ebuild 848
-MD5 9b028b286906970ba983eea940540811 ChangeLog 1273
+MD5 12058c9b8d19aedcaca564b02779298c log4cxx-0.9.7-r1.ebuild 1559
+MD5 dba0806f9b92c5865d80a6a6f64e2af8 log4cxx-0.9.5.ebuild 883
+MD5 28f604c15b1c3018943c1b589d96a753 ChangeLog 1423
MD5 f8d10f350e91f30316ea4e1bd1e76470 metadata.xml 254
MD5 50fe13b5c404fa59faeaebe40f36b6be files/log4cxx-0.9.7-gentoo.diff 750
MD5 a94dc071335f2e2545d523996053a685 files/digest-log4cxx-0.9.7-r1 65
+MD5 f9e8c2a552b387262cde2f04b5dc9605 files/log4cxx-0.9.5-fix-errno.diff 683
MD5 1135167eb4745c4a16791f44317ba88b files/digest-log4cxx-0.9.5 65
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFB0TiZEZCkKN40op4RAqTlAJ99ywoiYVk2Wp930x1qXkJ6eFIrTQCguvi2
-UcYdCIr3KH1/itbH9DalXEM=
-=HUiL
------END PGP SIGNATURE-----
diff --git a/dev-libs/log4cxx/files/log4cxx-0.9.5-fix-errno.diff b/dev-libs/log4cxx/files/log4cxx-0.9.5-fix-errno.diff
new file mode 100644
index 000000000000..d157ae369747
--- /dev/null
+++ b/dev-libs/log4cxx/files/log4cxx-0.9.5-fix-errno.diff
@@ -0,0 +1,24 @@
+--- src/filewatchdog.cpp.orig 2004-08-07 21:36:34.987676584 -0500
++++ src/filewatchdog.cpp 2004-08-07 21:36:41.562677032 -0500
+@@ -17,10 +17,7 @@
+ #include <log4cxx/helpers/filewatchdog.h>
+ #include <log4cxx/helpers/loglog.h>
+ #include <sys/stat.h>
+-
+-#ifdef WIN32
+-#include <errno.h>
++#include <cerrno>
+-#endif
+
+ using namespace log4cxx;
+ using namespace log4cxx::helpers;
+--- src/socketimpl.cpp.orig 2004-08-07 22:01:02.577569008 -0500
++++ src/socketimpl.cpp 2004-08-07 22:01:23.868332320 -0500
+@@ -15,6 +15,7 @@
+ ***************************************************************************/
+
+ #include <log4cxx/config.h>
++#include <cerrno>
+
+ #ifdef WIN32
+ #include <windows.h>
diff --git a/dev-libs/log4cxx/log4cxx-0.9.5.ebuild b/dev-libs/log4cxx/log4cxx-0.9.5.ebuild
index af430c8a528d..ba11d4e28f4e 100644
--- a/dev-libs/log4cxx/log4cxx-0.9.5.ebuild
+++ b/dev-libs/log4cxx/log4cxx-0.9.5.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4cxx/log4cxx-0.9.5.ebuild,v 1.5 2004/07/14 14:59:44 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4cxx/log4cxx-0.9.5.ebuild,v 1.6 2005/01/06 13:49:00 ka0ttic Exp $
+
+inherit eutils
DESCRIPTION="Library of C++ classes for flexible logging to files, syslog and other destinations"
HOMEPAGE="http://log4cxx.sourceforge.net/"
@@ -9,24 +11,25 @@ SRC_URI="mirror://sourceforge/log4cxx/${P}.tar.gz"
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="~x86"
-
IUSE=""
+
DEPEND="virtual/libc
dev-libs/libxml2"
RDEPEND=""
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-fix-errno.diff
+}
src_compile() {
- ./autogen.sh
- econf || die "./configure failed"
- make || die
+ ./autogen.sh || die "autogen.sh failed"
+ econf || die "econf failed"
+ emake -j1 || die "emake failed"
}
src_install () {
- make prefix=${D}/usr \
- datadir=${D}/usr/share \
- mandir=${D}/usr/share/man \
- docdir=${D}/usr/share/doc/${PF}/html \
- sysconfdir=${D}/etc install || die
+ make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README THANKS TODO
}
diff --git a/dev-libs/log4cxx/log4cxx-0.9.7-r1.ebuild b/dev-libs/log4cxx/log4cxx-0.9.7-r1.ebuild
index 9ef0d5295ee7..d526eaa751c6 100644
--- a/dev-libs/log4cxx/log4cxx-0.9.7-r1.ebuild
+++ b/dev-libs/log4cxx/log4cxx-0.9.7-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4cxx/log4cxx-0.9.7-r1.ebuild,v 1.1 2004/12/28 10:42:23 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4cxx/log4cxx-0.9.7-r1.ebuild,v 1.2 2005/01/06 13:49:00 ka0ttic Exp $
inherit eutils