summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-10-18 19:45:22 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-10-18 19:45:22 +0000
commit4c4af755c00dfe0924e71425afbcdbb30137492b (patch)
treedb108f940d621d3532fec99b5f7a71f77e53678f /dev-libs/log4cpp
parentVersion bump (diff)
downloadgentoo-2-4c4af755c00dfe0924e71425afbcdbb30137492b.tar.gz
gentoo-2-4c4af755c00dfe0924e71425afbcdbb30137492b.tar.bz2
gentoo-2-4c4af755c00dfe0924e71425afbcdbb30137492b.zip
Version bump.
(Portage version: 2.1.2_pre3-r3)
Diffstat (limited to 'dev-libs/log4cpp')
-rw-r--r--dev-libs/log4cpp/ChangeLog5
-rw-r--r--dev-libs/log4cpp/files/0.3.5_rc3-namespace_semikolon.patch9
-rw-r--r--dev-libs/log4cpp/files/digest-log4cpp-0.3.5_rc33
-rw-r--r--dev-libs/log4cpp/log4cpp-0.3.5_rc3.ebuild52
4 files changed, 68 insertions, 1 deletions
diff --git a/dev-libs/log4cpp/ChangeLog b/dev-libs/log4cpp/ChangeLog
index 0ba8d04b6626..71814ba20a37 100644
--- a/dev-libs/log4cpp/ChangeLog
+++ b/dev-libs/log4cpp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/log4cpp
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4cpp/ChangeLog,v 1.12 2006/10/18 16:57:47 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4cpp/ChangeLog,v 1.13 2006/10/18 19:45:22 dev-zero Exp $
+
+ 18 Oct 2006; Tiziano Müller <dev-zero@gentoo.org> ChangeLog:
+ Version bump. More corrections to correctly install docs with new version.
18 Oct 2006; Tiziano Müller <dev-zero@gentoo.org> ChangeLog:
Fixing small doc-install bug.
diff --git a/dev-libs/log4cpp/files/0.3.5_rc3-namespace_semikolon.patch b/dev-libs/log4cpp/files/0.3.5_rc3-namespace_semikolon.patch
new file mode 100644
index 000000000000..b46e59fe2183
--- /dev/null
+++ b/dev-libs/log4cpp/files/0.3.5_rc3-namespace_semikolon.patch
@@ -0,0 +1,9 @@
+--- log4cpp-0.3.5rc3/include/log4cpp/Manipulator.hh.orig 2006-10-18 22:13:48.000000000 +0200
++++ log4cpp-0.3.5rc3/include/log4cpp/Manipulator.hh 2006-10-18 22:13:52.000000000 +0200
+@@ -26,5 +26,5 @@
+ inline tab(unsigned int i) : size(i) {}
+ friend LOG4CPP_EXPORT std::ostream& operator<< (std::ostream& os, const tab& w);
+ };
+-};
++}
+ #endif
diff --git a/dev-libs/log4cpp/files/digest-log4cpp-0.3.5_rc3 b/dev-libs/log4cpp/files/digest-log4cpp-0.3.5_rc3
new file mode 100644
index 000000000000..a5b15b5b62ad
--- /dev/null
+++ b/dev-libs/log4cpp/files/digest-log4cpp-0.3.5_rc3
@@ -0,0 +1,3 @@
+MD5 13177d6bf50e403cc72b15e903326392 log4cpp-0.3.5rc3.tar.gz 472249
+RMD160 ee950db0d7fe1ef0ac0207c67a69dc0a05896fa3 log4cpp-0.3.5rc3.tar.gz 472249
+SHA256 2bcfefc7a59cedd0e3754ed796fa025081e66a2bca5120687c8605ce417325e8 log4cpp-0.3.5rc3.tar.gz 472249
diff --git a/dev-libs/log4cpp/log4cpp-0.3.5_rc3.ebuild b/dev-libs/log4cpp/log4cpp-0.3.5_rc3.ebuild
new file mode 100644
index 000000000000..ca2c8e732506
--- /dev/null
+++ b/dev-libs/log4cpp/log4cpp-0.3.5_rc3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4cpp/log4cpp-0.3.5_rc3.ebuild,v 1.1 2006/10/18 19:45:22 dev-zero Exp $
+
+inherit eutils
+
+KEYWORDS="~x86 ~ppc ~amd64 ~s390"
+
+MY_P=${P/_}
+
+DESCRIPTION="library of C++ classes for flexible logging to files, syslog, IDSA and other destinations"
+HOMEPAGE="http://log4cpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc threads"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-namespace_semikolon.patch"
+
+ # We have to fix it directly in Makefile.in to avoid
+ # loosing configuration-options
+ cd "${S}/doc"
+ sed -i \
+ -e 's#$(man3dir)#$(DESTDIR)/$(man3dir)#' \
+ -e 's#$(docdir)#$(DESTDIR)/$(docdir)/html#' \
+ -e "s#^docdir =.*#docdir = /usr/share/doc/${PF}#" \
+ Makefile.in || die "sed failed"
+}
+
+src_compile() {
+ econf \
+ --without-omnithreads \
+ --without-idsa \
+ $(use_with threads pthreads) \
+ $(use_enable doc doxygen) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}