summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-01-18 16:20:46 +0000
committerJeroen Roovers <jer@gentoo.org>2013-01-18 16:20:46 +0000
commit486dc6049c7e910a26f81415f8b3bf8c7585442a (patch)
treef87c67e42713fae9295d277467d50fd37df263d8 /dev-libs/libvformat
parentFix build with latest ffmpeg: Sanitize include paths and port to the new API.... (diff)
downloadgentoo-2-486dc6049c7e910a26f81415f8b3bf8c7585442a.tar.gz
gentoo-2-486dc6049c7e910a26f81415f8b3bf8c7585442a.tar.bz2
gentoo-2-486dc6049c7e910a26f81415f8b3bf8c7585442a.zip
Use str* functions from libc by Raphaël Droz (bug #452756). Add USE=static-libs. Use newer Debian patchset. HAS_UNISTD_H -> HAVE_UNISTD_H.
(Portage version: 2.2.0_alpha154/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-libs/libvformat')
-rw-r--r--dev-libs/libvformat/ChangeLog11
-rw-r--r--dev-libs/libvformat/files/libvformat-1.13-has_unistd.patch13
-rw-r--r--dev-libs/libvformat/files/libvformat-1.13-str.patch22
-rw-r--r--dev-libs/libvformat/libvformat-1.13-r2.ebuild35
4 files changed, 79 insertions, 2 deletions
diff --git a/dev-libs/libvformat/ChangeLog b/dev-libs/libvformat/ChangeLog
index b7d8184c739f..4914e8a6bffe 100644
--- a/dev-libs/libvformat/ChangeLog
+++ b/dev-libs/libvformat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libvformat
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libvformat/ChangeLog,v 1.15 2012/04/06 21:46:13 pacho Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libvformat/ChangeLog,v 1.16 2013/01/18 16:20:46 jer Exp $
+
+*libvformat-1.13-r2 (18 Jan 2013)
+
+ 18 Jan 2013; Jeroen Roovers <jer@gentoo.org> +libvformat-1.13-r2.ebuild,
+ +files/libvformat-1.13-has_unistd.patch, +files/libvformat-1.13-str.patch:
+ Use str* functions from libc by Raphaël Droz (bug #452756). Add
+ USE=static-libs. Use newer Debian patchset. HAS_UNISTD_H -> HAVE_UNISTD_H.
06 Apr 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #63588
diff --git a/dev-libs/libvformat/files/libvformat-1.13-has_unistd.patch b/dev-libs/libvformat/files/libvformat-1.13-has_unistd.patch
new file mode 100644
index 000000000000..8788c966ffd0
--- /dev/null
+++ b/dev-libs/libvformat/files/libvformat-1.13-has_unistd.patch
@@ -0,0 +1,13 @@
+--- a/src/vf_reader.c
++++ b/src/vf_reader.c
+@@ -87,8 +87,9 @@
+
+ #include <stdio.h>
+ #include <sys/stat.h>
++#include "config.h"
+
+-#if defined(HAS_UNISTD_H)
++#if defined(HAVE_UNISTD_H)
+ #include <unistd.h>
+ #endif
+
diff --git a/dev-libs/libvformat/files/libvformat-1.13-str.patch b/dev-libs/libvformat/files/libvformat-1.13-str.patch
new file mode 100644
index 000000000000..8c47489842d8
--- /dev/null
+++ b/dev-libs/libvformat/files/libvformat-1.13-str.patch
@@ -0,0 +1,22 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -21,7 +21,7 @@
+ # Checks for library functions.
+ AC_FUNC_MKTIME
+ AC_FUNC_STAT
+-AC_CHECK_FUNCS([atexit memset strstr])
++AC_CHECK_FUNCS([atexit memset strstr strlen strcpy strcmp strcat memcpy])
+
+ AC_OUTPUT([Makefile src/Makefile vformat/Makefile test/Makefile doc/Makefile])
+ #AC_CONFIG_FILES([])
+--- a/src/vf_config.h
++++ b/src/vf_config.h
+@@ -31,6 +31,8 @@
+ *
+ *******************************************************************************/
+
++#include <config.h>
++
+ #ifndef _VF_CONFIG_H_
+ #define _VF_CONFIG_H_
+
diff --git a/dev-libs/libvformat/libvformat-1.13-r2.ebuild b/dev-libs/libvformat/libvformat-1.13-r2.ebuild
new file mode 100644
index 000000000000..1488ea7159ae
--- /dev/null
+++ b/dev-libs/libvformat/libvformat-1.13-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libvformat/libvformat-1.13-r2.ebuild,v 1.1 2013/01/18 16:20:46 jer Exp $
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="Library to read and write vcard files"
+HOMEPAGE="http://sourceforge.net/projects/vformat/"
+SRC_URI="
+ mirror://debian/pool/main/libv/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/libv/${PN}/${PN}_${PV}-10.debian.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="static-libs"
+
+S="${WORKDIR}/${P}.orig"
+
+src_prepare() {
+ epatch \
+ "${WORKDIR}"/debian/patches/*.patch \
+ "${FILESDIR}"/${PN}-nodoc.patch \
+ "${FILESDIR}"/${P}-has_unistd.patch \
+ "${FILESDIR}"/${P}-str.patch
+
+ eautoreconf
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}