summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-11-25 21:21:45 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-11-25 21:21:45 +0000
commit67979519187ff0f0e7d11c3439bd65fcafd1116b (patch)
treeee574b5ad2e12be8b5b9fc561cbfa1528b020721 /dev-libs/libpeas
parentVersion bump. (diff)
downloadgentoo-2-67979519187ff0f0e7d11c3439bd65fcafd1116b.tar.gz
gentoo-2-67979519187ff0f0e7d11c3439bd65fcafd1116b.tar.bz2
gentoo-2-67979519187ff0f0e7d11c3439bd65fcafd1116b.zip
Version bump.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'dev-libs/libpeas')
-rw-r--r--dev-libs/libpeas/ChangeLog7
-rw-r--r--dev-libs/libpeas/libpeas-1.6.2.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/dev-libs/libpeas/ChangeLog b/dev-libs/libpeas/ChangeLog
index dfe0c75e3aa3..758438c680e7 100644
--- a/dev-libs/libpeas/ChangeLog
+++ b/dev-libs/libpeas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libpeas
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpeas/ChangeLog,v 1.8 2012/10/20 06:46:36 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpeas/ChangeLog,v 1.9 2012/11/25 21:21:45 eva Exp $
+
+*libpeas-1.6.2 (25 Nov 2012)
+
+ 25 Nov 2012; Gilles Dartiguelongue <eva@gentoo.org> +libpeas-1.6.2.ebuild:
+ Version bump.
*libpeas-1.6.1 (20 Oct 2012)
diff --git a/dev-libs/libpeas/libpeas-1.6.2.ebuild b/dev-libs/libpeas/libpeas-1.6.2.ebuild
new file mode 100644
index 000000000000..e38b4aaf31cc
--- /dev/null
+++ b/dev-libs/libpeas/libpeas-1.6.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpeas/libpeas-1.6.2.ebuild,v 1.1 2012/11/25 21:21:45 eva Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_DEPEND="python? 2:2.5"
+
+inherit eutils gnome2 multilib python virtualx
+
+DESCRIPTION="A GObject plugins library"
+HOMEPAGE="http://developer.gnome.org/libpeas/stable/"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+IUSE="gjs +gtk glade +python seed"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+
+RDEPEND=">=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-0.10.1
+ gjs? ( >=dev-libs/gjs-1.31.11 )
+ glade? ( >=dev-util/glade-3.9.1:3.10 )
+ gtk? ( >=x11-libs/gtk+-3:3[introspection] )
+ python? ( >=dev-python/pygobject-3.0.0:3 )
+ seed? ( >=dev-libs/seed-2.91.91 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+
+ G2CONF="${G2CONF}
+ $(use_enable gjs)
+ $(use_enable glade glade-catalog)
+ $(use_enable gtk)
+ $(use_enable python)
+ $(use_enable seed)
+ --disable-deprecation
+ --disable-static"
+ # Wtf, --disable-gcov, --enable-gcov=no, --enable-gcov, all enable gcov
+ # What do we do about gdb, valgrind, gcov, etc?
+
+ use python && python_clean_py-compile_files
+ gnome2_src_prepare
+}
+
+src_test() {
+ # FIXME: Tests fail because of some bug involving Xvfb and Gtk.IconTheme
+ # DO NOT REPORT UPSTREAM, this is not a libpeas bug.
+ # To reproduce:
+ # >>> from gi.repository import Gtk
+ # >>> Gtk.IconTheme.get_default().has_icon("gtk-about")
+ # This should return True, it returns False for Xvfb
+ Xemake check
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ use python && python_mod_optimize /usr/$(get_libdir)/peas-demo
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ use python && python_mod_cleanup /usr/$(get_libdir)/peas-demo
+}