summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-05-17 18:38:25 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-05-17 18:38:25 +0000
commit0c265e0a57b5e18ad06c70babbf93ea0efa1e688 (patch)
tree678fcef771ff4aca167a5fd9a7bae0b7363c6e10 /dev-libs/libmcs
parentapplying updates from bug #211456 due to device breakage in 2.36 (diff)
downloadgentoo-2-0c265e0a57b5e18ad06c70babbf93ea0efa1e688.tar.gz
gentoo-2-0c265e0a57b5e18ad06c70babbf93ea0efa1e688.tar.bz2
gentoo-2-0c265e0a57b5e18ad06c70babbf93ea0efa1e688.zip
Drop KDE functionality as it stopped working. Simplify ebuild. Closes bug #222453.
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'dev-libs/libmcs')
-rw-r--r--dev-libs/libmcs/ChangeLog8
-rw-r--r--dev-libs/libmcs/libmcs-0.7.1-r1.ebuild29
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-libs/libmcs/ChangeLog b/dev-libs/libmcs/ChangeLog
index 7fd95ad83c80..f19b6c5c0bb9 100644
--- a/dev-libs/libmcs/ChangeLog
+++ b/dev-libs/libmcs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libmcs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcs/ChangeLog,v 1.37 2008/04/20 23:13:54 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcs/ChangeLog,v 1.38 2008/05/17 18:38:25 chainsaw Exp $
+
+*libmcs-0.7.1-r1 (17 May 2008)
+
+ 17 May 2008; <chainsaw@gentoo.org> +libmcs-0.7.1-r1.ebuild:
+ Drop KDE functionality as it stopped working. Simplify ebuild. Closes bug
+ #222453.
*libmcs-0.7.1 (20 Apr 2008)
diff --git a/dev-libs/libmcs/libmcs-0.7.1-r1.ebuild b/dev-libs/libmcs/libmcs-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..c4065bbcb466
--- /dev/null
+++ b/dev-libs/libmcs/libmcs-0.7.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcs/libmcs-0.7.1-r1.ebuild,v 1.1 2008/05/17 18:38:25 chainsaw Exp $
+
+DESCRIPTION="Abstracts the storage of configuration settings away from applications."
+HOMEPAGE="http://sacredspiral.co.uk/~nenolod/mcs/"
+SRC_URI="http://distfiles.atheme.org/${P}.tgz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gnome"
+
+DEPEND=">=dev-util/pkgconfig-0.9.0
+ ${RDEPEND}"
+RDEPEND=">=dev-libs/libmowgli-0.6.1
+ gnome? ( >=gnome-base/gconf-2.6.0 )"
+
+src_compile() {
+ econf \
+ $(use_enable gnome gconf) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS README TODO
+}