summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-01-16 10:14:16 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-01-16 10:14:16 +0000
commit9c7817c0476d69147fce41ce6b9b2a98e7f80829 (patch)
tree1ff1f7f741bd6262f614af349719c933c4d6a72c /dev-libs/libmcrypt
parentsuperceeded by r3 (diff)
downloadgentoo-2-9c7817c0476d69147fce41ce6b9b2a98e7f80829.tar.gz
gentoo-2-9c7817c0476d69147fce41ce6b9b2a98e7f80829.tar.bz2
gentoo-2-9c7817c0476d69147fce41ce6b9b2a98e7f80829.zip
initial version
Diffstat (limited to 'dev-libs/libmcrypt')
-rw-r--r--dev-libs/libmcrypt/files/digest-libmcrypt-2.4.191
-rw-r--r--dev-libs/libmcrypt/libmcrypt-2.4.19.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/libmcrypt/files/digest-libmcrypt-2.4.19 b/dev-libs/libmcrypt/files/digest-libmcrypt-2.4.19
new file mode 100644
index 000000000000..dc7ccc9a684f
--- /dev/null
+++ b/dev-libs/libmcrypt/files/digest-libmcrypt-2.4.19
@@ -0,0 +1 @@
+MD5 de7123b98801f755d6cd1bb53079aa28 libmcrypt-2.4.19.tar.gz 475136
diff --git a/dev-libs/libmcrypt/libmcrypt-2.4.19.ebuild b/dev-libs/libmcrypt/libmcrypt-2.4.19.ebuild
new file mode 100644
index 000000000000..1c5c3abe3860
--- /dev/null
+++ b/dev-libs/libmcrypt/libmcrypt-2.4.19.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Christian Rubbert <crubb@xrc.de>
+
+S=${WORKDIR}/${P}
+DESCRIPTION="libmcrypt is a library that provides uniform interface to access several encryption algorithms."
+SRC_URI="ftp://mcrypt.hellug.gr/pub/mcrypt/libmcrypt/${P}.tar.gz"
+HOMEPAGE="http://mcrypt.hellug.gr/"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ econf --host=${CHOST} \
+ --disable-posix-threads || die
+
+ # PHP manual states to disable posix threads, no further explanation given, but i'll
+ # stick with it :) (Source: http://www.php.net/manual/en/ref.mcrypt.php)
+
+ emake || die
+}
+
+src_install () {
+
+ dodir /usr/{bin,include,lib}
+
+ einstall || die
+
+ dodoc AUTHORS COPYING INSTALL KNOW-BUGS NEWS README THANKS TODO doc/README.* doc/example.c
+}