summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-02 17:27:28 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-02 17:27:28 +0000
commit10cc977f038de59628e2f24b722cdc2fd1c78a11 (patch)
tree4862728fdbff72d2cc824f230b4875a6daaf1f05 /dev-libs/libdnsres
parentminor fixes; fixed #339328 dont respect LDFLAGS (diff)
downloadgentoo-2-10cc977f038de59628e2f24b722cdc2fd1c78a11.tar.gz
gentoo-2-10cc977f038de59628e2f24b722cdc2fd1c78a11.tar.bz2
gentoo-2-10cc977f038de59628e2f24b722cdc2fd1c78a11.zip
QA: autotools cleanup via patch rather than sed; fix parallel build (and install) as it's needed to build with modern automake anyway; drop -O0 usage while at it.
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libdnsres')
-rw-r--r--dev-libs/libdnsres/ChangeLog10
-rw-r--r--dev-libs/libdnsres/files/libdnsres-0.1a-autotools.patch28
-rw-r--r--dev-libs/libdnsres/libdnsres-0.1a-r1.ebuild20
3 files changed, 43 insertions, 15 deletions
diff --git a/dev-libs/libdnsres/ChangeLog b/dev-libs/libdnsres/ChangeLog
index 3895c31e9a23..84d3266a8347 100644
--- a/dev-libs/libdnsres/ChangeLog
+++ b/dev-libs/libdnsres/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libdnsres
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnsres/ChangeLog,v 1.11 2007/11/16 15:30:03 beandog Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnsres/ChangeLog,v 1.12 2010/12/02 17:27:28 flameeyes Exp $
+
+ 02 Dec 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ libdnsres-0.1a-r1.ebuild, +files/libdnsres-0.1a-autotools.patch:
+ QA: autotools cleanup via patch rather than sed; fix parallel build (and
+ install) as it's needed to build with modern automake anyway; drop -O0 usage
+ while at it.
16 Nov 2007; Steve Dibb <beandog@gentoo.org> libdnsres-0.1a-r1.ebuild:
amd64 stable, bug 192446
diff --git a/dev-libs/libdnsres/files/libdnsres-0.1a-autotools.patch b/dev-libs/libdnsres/files/libdnsres-0.1a-autotools.patch
new file mode 100644
index 000000000000..3e2466af57f7
--- /dev/null
+++ b/dev-libs/libdnsres/files/libdnsres-0.1a-autotools.patch
@@ -0,0 +1,28 @@
+Index: libdnsres-0.1a/Makefile.am
+===================================================================
+--- libdnsres-0.1a.orig/Makefile.am
++++ libdnsres-0.1a/Makefile.am
+@@ -10,12 +10,12 @@ libdnsres_la_SOURCES = res_comp.c res_de
+ res_data.c res_init.c res_query.c res_send.c resolv.h dnsres.h \
+ gethostnamadr.c getaddrinfo.c getservbyname.c getservent.c base64.c \
+ dnsres-internal.h
+-libdnsres_la_LIBADD = @LIBOBJS@
++libdnsres_la_LIBADD = @LTLIBOBJS@
+ libdnsres_la_LDFLAGS = -version-info 0:1:0
+
+ include_HEADERS = dnsres.h
+
+-CFLAGS = -Wall -O0 -g -DRESOLVSORT
++AM_CFLAGS = -Wall -g -DRESOLVSORT
+ INCLUDES = -I$(top_srcdir)/compat @EVENTINC@
+
+ man_MANS = dnsres.3
+@@ -23,7 +23,7 @@ man_MANS = dnsres.3
+ noinst_PROGRAMS = simple_test
+ simple_test_SOURCES = test/simple_test.c
+ simple_test_INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/compat @EVENTINC@
+-simple_test_LDADD = -L$(top_buildir) -ldnsres @EVENTLIB@
++simple_test_LDADD = libdnsres.la @EVENTLIB@
+
+ verify: libdnsres.a
+ cd $(srcdir)/test && make verify
diff --git a/dev-libs/libdnsres/libdnsres-0.1a-r1.ebuild b/dev-libs/libdnsres/libdnsres-0.1a-r1.ebuild
index 31e81af9650f..c84559f8f08d 100644
--- a/dev-libs/libdnsres/libdnsres-0.1a-r1.ebuild
+++ b/dev-libs/libdnsres/libdnsres-0.1a-r1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnsres/libdnsres-0.1a-r1.ebuild,v 1.8 2007/11/16 15:30:03 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnsres/libdnsres-0.1a-r1.ebuild,v 1.9 2010/12/02 17:27:28 flameeyes Exp $
-WANT_AUTOMAKE=1.8
-inherit autotools
+inherit eutils autotools
DESCRIPTION="A non-blocking DNS resolver library"
HOMEPAGE="http://www.monkey.org/~provos/libdnsres/"
@@ -19,18 +18,13 @@ DEPEND="dev-libs/libevent"
src_unpack() {
unpack ${A}
cd "${S}"
- sed -i -e "s:LIBOBJS:LTLIBOBJS:" \
- -e "s:CFLAGS:AM_CFLAGS:" Makefile.am || die "sed of Makefile.am failed"
- # See Makefile.in for automake version upstream dev uses.
- eautomake || die "automake failed"
-}
-src_compile() {
- econf || die "econf failed"
- emake -j1 || die "make failed"
+ epatch "${FILESDIR}/${P}-autotools.patch"
+
+ eautoreconf
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "make install failed"
dodoc README
}