summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2011-07-29 15:45:27 +0000
committerJesus Rivero <neurogeek@gentoo.org>2011-07-29 15:45:27 +0000
commit6e15f382ea936b0c7f743a797bd34bbd361bf60a (patch)
tree0e8b7a773924a74675193172c57d6c4f5d25e167 /dev-libs/icu
parentFix linux-3 kernel compilation wrt #375353 (diff)
downloadgentoo-2-6e15f382ea936b0c7f743a797bd34bbd361bf60a.tar.gz
gentoo-2-6e15f382ea936b0c7f743a797bd34bbd361bf60a.tar.bz2
gentoo-2-6e15f382ea936b0c7f743a797bd34bbd361bf60a.zip
Version bump. Ebuild by Arfrever.
(Portage version: 2.2.0_alpha46/cvs/Linux i686)
Diffstat (limited to 'dev-libs/icu')
-rw-r--r--dev-libs/icu/ChangeLog7
-rw-r--r--dev-libs/icu/icu-4.8.1.ebuild88
2 files changed, 94 insertions, 1 deletions
diff --git a/dev-libs/icu/ChangeLog b/dev-libs/icu/ChangeLog
index 068ebef44220..59749e045db8 100644
--- a/dev-libs/icu/ChangeLog
+++ b/dev-libs/icu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/icu
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.154 2011/07/25 18:34:42 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.155 2011/07/29 15:45:27 neurogeek Exp $
+
+*icu-4.8.1 (29 Jul 2011)
+
+ 29 Jul 2011; Jesus Rivero <neurogeek@gentoo.org> +icu-4.8.1.ebuild:
+ Version bump. Ebuild by Arfrever.
25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> icu-4.8.ebuild:
ppc/ppc64 stable wrt #374589
diff --git a/dev-libs/icu/icu-4.8.1.ebuild b/dev-libs/icu/icu-4.8.1.ebuild
new file mode 100644
index 000000000000..be7d968d4821
--- /dev/null
+++ b/dev-libs/icu/icu-4.8.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-4.8.1.ebuild,v 1.1 2011/07/29 15:45:27 neurogeek Exp $
+
+EAPI="3"
+
+inherit versionator
+
+MAJOR_VERSION="$(get_version_component_range 1)"
+MINOR_VERSION="$(get_version_component_range 2)"
+if [[ "${PV}" =~ ^[[:digit:]]+\.[[:digit:]]+(_rc[[:digit:]]*)?$ ]]; then
+ MICRO_VERSION="0"
+else
+ MICRO_VERSION="$(get_version_component_range 3)"
+fi
+
+DESCRIPTION="International Components for Unicode"
+HOMEPAGE="http://www.icu-project.org/"
+
+BASE_URI="http://download.icu-project.org/files/icu4c/${PV/_/}"
+SRC_ARCHIVE="icu4c-${PV//./_}-src.tgz"
+DOCS_ARCHIVE="icu4c-${PV//./_}-docs.zip"
+
+SRC_URI="${BASE_URI}/${SRC_ARCHIVE}
+ doc? ( ${BASE_URI}/${DOCS_ARCHIVE} )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples static-libs"
+
+DEPEND="doc? ( app-arch/unzip )"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}/source"
+
+QA_DT_NEEDED="/usr/lib.*/libicudata\.so\.${MAJOR_VERSION}${MINOR_VERSION}\.${MICRO_VERSION}"
+
+src_unpack() {
+ unpack "${SRC_ARCHIVE}"
+ if use doc; then
+ mkdir docs
+ pushd docs > /dev/null
+ unpack "${DOCS_ARCHIVE}"
+ popd > /dev/null
+ fi
+}
+
+src_prepare() {
+ # Do not hardcode flags into icu-config.
+ # https://ssl.icu-project.org/trac/ticket/6102
+ local variable
+ for variable in CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
+ sed -i -e "/^${variable} =.*/s:@${variable}@::" config/Makefile.inc.in || die "sed failed"
+ done
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable examples samples) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ # INTLTEST_OPTS: intltest options
+ # -e: Exhaustive testing
+ # -l: Reporting of memory leaks
+ # -v: Increased verbosity
+ # IOTEST_OPTS: iotest options
+ # -e: Exhaustive testing
+ # -v: Increased verbosity
+ # CINTLTST_OPTS: cintltst options
+ # -e: Exhaustive testing
+ # -v: Increased verbosity
+ emake -j1 check || die "emake check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dohtml ../readme.html
+ dodoc ../unicode-license.txt
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html/api
+ doins -r "${WORKDIR}/docs/"* || die "doins failed"
+ fi
+}