summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-14 23:23:18 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-14 23:23:18 +0000
commita42cac8787b6c13d5586651e25f7367c3abff3cf (patch)
treefa2fd06689f4793af4f6e4886c0cb81cfeab6ad1 /dev-libs/glib
parentversion bump (diff)
downloadgentoo-2-a42cac8787b6c13d5586651e25f7367c3abff3cf.tar.gz
gentoo-2-a42cac8787b6c13d5586651e25f7367c3abff3cf.tar.bz2
gentoo-2-a42cac8787b6c13d5586651e25f7367c3abff3cf.zip
Add elfutils/libelf as a runtime dependency, and fix libelf detection. Fix datetime tests in non-English locales (bug #411967, thanks to Marien Zwart).
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/ChangeLog7
-rw-r--r--dev-libs/glib/files/glib-2.32.1-fix-libelf-check.patch11
-rw-r--r--dev-libs/glib/glib-2.32.0.ebuild6
-rw-r--r--dev-libs/glib/glib-2.32.1.ebuild10
4 files changed, 29 insertions, 5 deletions
diff --git a/dev-libs/glib/ChangeLog b/dev-libs/glib/ChangeLog
index 9eb7607974d8..532e852bbb77 100644
--- a/dev-libs/glib/ChangeLog
+++ b/dev-libs/glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/glib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.512 2012/04/14 16:12:55 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.513 2012/04/14 23:23:18 tetromino Exp $
+
+ 14 Apr 2012; Alexandre Rostovtsev <tetromino@gentoo.org> glib-2.32.0.ebuild,
+ glib-2.32.1.ebuild, +files/glib-2.32.1-fix-libelf-check.patch:
+ Add elfutils/libelf as a runtime dependency, and fix libelf detection. Fix
+ datetime tests in non-English locales (bug #411967, thanks to Marien Zwart).
14 Apr 2012; Alexis Ballier <aballier@gentoo.org> glib-2.32.1.ebuild:
allow to replace lelfutils by libelf. the former isnt keyworded and doesnt
diff --git a/dev-libs/glib/files/glib-2.32.1-fix-libelf-check.patch b/dev-libs/glib/files/glib-2.32.1-fix-libelf-check.patch
new file mode 100644
index 000000000000..936623474d33
--- /dev/null
+++ b/dev-libs/glib/files/glib-2.32.1-fix-libelf-check.patch
@@ -0,0 +1,11 @@
+--- configure.ac 2012-04-13 15:39:41.000000000 +0200
++++ configure.ac 2012-04-14 20:20:41.814099854 +0200
+@@ -1823,7 +1823,7 @@
+
+ if test $have_libelf != no; then
+ LIBELF_LIBS=-lelf
+- have_libelf = yes
++ have_libelf=yes
+ fi
+ fi
+
diff --git a/dev-libs/glib/glib-2.32.0.ebuild b/dev-libs/glib/glib-2.32.0.ebuild
index bfb6795f301f..682227583505 100644
--- a/dev-libs/glib/glib-2.32.0.ebuild
+++ b/dev-libs/glib/glib-2.32.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.32.0.ebuild,v 1.2 2012/03/27 03:16:18 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.32.0.ebuild,v 1.3 2012/04/14 23:23:18 tetromino Exp $
EAPI="4"
PYTHON_DEPEND="utils? 2"
@@ -21,11 +21,13 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~spar
RDEPEND="virtual/libiconv
virtual/libffi
sys-libs/zlib
+ || (
+ >=dev-libs/elfutils-0.142
+ >=dev-libs/libelf-0.8.11 )
xattr? ( sys-apps/attr )
fam? ( virtual/fam )
utils? ( >=dev-util/gdbus-codegen-${PV} )"
DEPEND="${RDEPEND}
- dev-libs/elfutils
>=sys-devel/gettext-0.11
>=dev-util/gtk-doc-am-1.15
doc? (
diff --git a/dev-libs/glib/glib-2.32.1.ebuild b/dev-libs/glib/glib-2.32.1.ebuild
index 2b364ca20267..992598e61a97 100644
--- a/dev-libs/glib/glib-2.32.1.ebuild
+++ b/dev-libs/glib/glib-2.32.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.32.1.ebuild,v 1.3 2012/04/14 16:12:55 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.32.1.ebuild,v 1.4 2012/04/14 23:23:18 tetromino Exp $
EAPI="4"
PYTHON_DEPEND="utils? 2"
@@ -21,11 +21,13 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~spar
RDEPEND="virtual/libiconv
virtual/libffi
sys-libs/zlib
+ || (
+ >=dev-libs/elfutils-0.142
+ >=dev-libs/libelf-0.8.11 )
xattr? ( sys-apps/attr )
fam? ( virtual/fam )
utils? ( >=dev-util/gdbus-codegen-${PV} )"
DEPEND="${RDEPEND}
- || ( dev-libs/elfutils dev-libs/libelf )
>=sys-devel/gettext-0.11
>=dev-util/gtk-doc-am-1.15
doc? (
@@ -110,6 +112,9 @@ src_prepare() {
# gdbus-codegen is a separate package
epatch "${FILESDIR}/${PN}-2.31.x-external-gdbus-codegen.patch"
+ # https://bugzilla.gnome.org/show_bug.cgi?id=673132
+ epatch "${FILESDIR}/${PN}-2.32.1-fix-libelf-check.patch"
+
# disable pyc compiling
use test && python_clean_py-compile_files
@@ -193,6 +198,7 @@ src_test() {
export XDG_DATA_DIRS=/usr/local/share:/usr/share
export G_DBUS_COOKIE_SHA1_KEYRING_DIR="${T}/temp"
unset GSETTINGS_BACKEND # bug 352451
+ export LC_TIME=C # bug #411967
# Related test is a bit nitpicking
mkdir "$G_DBUS_COOKIE_SHA1_KEYRING_DIR"