summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-03-14 01:40:28 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-03-14 01:40:28 +0000
commit2b8613e7741fe768bfb0aebdcc689c82021cb78f (patch)
tree89803f53f69b814f61c7ec2c3e25e0f7b86519eb /dev-libs/glib
parentVersion bump. (diff)
downloadgentoo-2-2b8613e7741fe768bfb0aebdcc689c82021cb78f.tar.gz
gentoo-2-2b8613e7741fe768bfb0aebdcc689c82021cb78f.tar.bz2
gentoo-2-2b8613e7741fe768bfb0aebdcc689c82021cb78f.zip
Version bump, fixes several memory leaks and other bugs.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/ChangeLog8
-rw-r--r--dev-libs/glib/files/glib-2.30.3-assert-test-failure.patch19
-rw-r--r--dev-libs/glib/files/glib-2.30.3-closure-64bit-be.patch220
-rw-r--r--dev-libs/glib/glib-2.30.3.ebuild249
4 files changed, 495 insertions, 1 deletions
diff --git a/dev-libs/glib/ChangeLog b/dev-libs/glib/ChangeLog
index 850abfec968c..71731d399b06 100644
--- a/dev-libs/glib/ChangeLog
+++ b/dev-libs/glib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/glib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.503 2012/03/05 21:57:27 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.504 2012/03/14 01:40:28 tetromino Exp $
+
+*glib-2.30.3 (14 Mar 2012)
+
+ 14 Mar 2012; Alexandre Rostovtsev <tetromino@gentoo.org> +glib-2.30.3.ebuild,
+ +files/glib-2.30.3-closure-64bit-be.patch:
+ Version bump, fixes several memory leaks and other bugs.
05 Mar 2012; Brent Baude <ranger@gentoo.org> glib-2.30.2.ebuild:
Marking glib-2.30.2 ppc stable for bug 393007
diff --git a/dev-libs/glib/files/glib-2.30.3-assert-test-failure.patch b/dev-libs/glib/files/glib-2.30.3-assert-test-failure.patch
new file mode 100644
index 000000000000..20a12c43ff9c
--- /dev/null
+++ b/dev-libs/glib/files/glib-2.30.3-assert-test-failure.patch
@@ -0,0 +1,19 @@
+Tests fail when upgrading glib from 2.22 to 2.24 if sys-devel/gdb is installed
+because gdb is run on .libs/assert-msg-test before LD_LIBRARY_PATH is set. This
+causes gdb to use the system-wide glib instead, and fail on the test.
+
+This patch exports LD_LIBRARY_PATH before running gdb
+
+https://bugzilla.gnome.org/621368
+
+---
+--- tests/run-assert-msg-test.sh
++++ tests/run-assert-msg-test.sh
+@@ -34,6 +34,7 @@ if [ -e ".libs/lt-$msg_test" ]; then
+ msg_test="lt-$msg_test"
+ fi
+ echo_v "Running gdb on assert-msg-test"
++export LD_LIBRARY_PATH="`dirname $PWD`/glib/.libs:$LD_LIBRARY_PATH"
+ OUT=$(gdb --batch --ex run --ex "set print elements 0" --ex "print (char*) __glib_assert_msg" .libs/$msg_test 2> $error_out) || \
+ fail "failed to run gdb"
+
diff --git a/dev-libs/glib/files/glib-2.30.3-closure-64bit-be.patch b/dev-libs/glib/files/glib-2.30.3-closure-64bit-be.patch
new file mode 100644
index 000000000000..9ec9f1aa1775
--- /dev/null
+++ b/dev-libs/glib/files/glib-2.30.3-closure-64bit-be.patch
@@ -0,0 +1,220 @@
+From 0782edcb44110c8a3ba921258eb8d4e452f2470e Mon Sep 17 00:00:00 2001
+From: Dan Williams <dcbw@redhat.com>
+Date: Fri, 23 Sep 2011 12:32:23 -0500
+Subject: [PATCH] closure: fix handling of ENUMs and integral return types on
+ 64-bit BE platforms
+
+enums are stored in v_long but need to be marshalled as signed
+integers. On platforms where int is 32 bits, taking the
+address of v_long resulted in the wrong 32 bits being marshalled.
+So we need to stuff the enum's int-sized value to a temporary
+int-sized variable and marshall that instead.
+
+Second, on return, libffi actually returns a pointer to a value
+that's sized according to platform conventions, not according to
+what the caller requested. ie if ffi_type_sint was requested, the
+value can still be a 64-bit sign-extended long on a 64-bit
+architecture like PPC64, thus the caller cannot simply cast
+the return value as a pointer to the desired type, but must cast
+as a pointer to an integral type and then cast to the desired
+type to remove any sign extension complications.
+
+For more information on how to correctly handle libffi return
+values, see the following bug, specifically comment 35:
+
+https://bugzilla.redhat.com/show_bug.cgi?id=736489
+
+"For 64-bit ABIs that extend integral returns types to 64-bits, libffi always
+returns full 64-bit values that you can truncate in the calling code. It's
+just the way it is has always been. Please don't change libffi. I'll document
+this clearly for the next version (perhaps there is a mention of this, I
+haven't looked yet).
+
+The same is true for returning 8-bit values, for instance, on 32-bit systems.
+All ABIs extend those results to the full 32-bits so you need to provide a
+properly aligned buffer that's big enough to hold the result."
+
+https://bugzilla.gnome.org/show_bug.cgi?id=659881
+
+[Alexandre Rostovtsev <tetromino@gentoo.org>: backport to glib-2.30.x]
+---
+ gobject/gclosure.c | 76 ++++++++++++++++++++++++++++++++++++++++-----------
+ 1 files changed, 59 insertions(+), 17 deletions(-)
+
+diff --git a/gobject/gclosure.c b/gobject/gclosure.c
+index 5fd928b..fc4f99a 100644
+--- a/gobject/gclosure.c
++++ b/gobject/gclosure.c
+@@ -944,21 +944,42 @@ g_signal_type_cclosure_new (GType itype,
+
+ #include <ffi.h>
+ static ffi_type *
+-value_to_ffi_type (const GValue *gvalue, gpointer *value)
++value_to_ffi_type (const GValue *gvalue,
++ gpointer *value,
++ gint *enum_tmpval,
++ gboolean *tmpval_used)
+ {
+ ffi_type *rettype = NULL;
+ GType type = g_type_fundamental (G_VALUE_TYPE (gvalue));
+ g_assert (type != G_TYPE_INVALID);
+
++ if (enum_tmpval)
++ {
++ g_assert (tmpval_used != NULL);
++ *tmpval_used = FALSE;
++ }
++
+ switch (type)
+ {
+ case G_TYPE_BOOLEAN:
+ case G_TYPE_CHAR:
+ case G_TYPE_INT:
+- case G_TYPE_ENUM:
+ rettype = &ffi_type_sint;
+ *value = (gpointer)&(gvalue->data[0].v_int);
+ break;
++ case G_TYPE_ENUM:
++ /* enums are stored in v_long even though they are integers, which makes
++ * marshalling through libffi somewhat complicated. They need to be
++ * marshalled as signed ints, but we need to use a temporary int sized
++ * value to pass to libffi otherwise it'll pull the wrong value on
++ * BE machines with 32-bit integers when treating v_long as 32-bit int.
++ */
++ g_assert (enum_tmpval != NULL);
++ rettype = &ffi_type_sint;
++ *enum_tmpval = g_value_get_enum (gvalue);
++ *value = enum_tmpval;
++ *tmpval_used = TRUE;
++ break;
+ case G_TYPE_UCHAR:
+ case G_TYPE_UINT:
+ case G_TYPE_FLAGS:
+@@ -1011,10 +1032,12 @@ value_to_ffi_type (const GValue *gvalue, gpointer *value)
+ static void
+ value_from_ffi_type (GValue *gvalue, gpointer *value)
+ {
++ ffi_arg *int_val = value;
++
+ switch (g_type_fundamental (G_VALUE_TYPE (gvalue)))
+ {
+ case G_TYPE_INT:
+- g_value_set_int (gvalue, *(gint*)value);
++ g_value_set_int (gvalue, (gint) *int_val);
+ break;
+ case G_TYPE_FLOAT:
+ g_value_set_float (gvalue, *(gfloat*)value);
+@@ -1023,43 +1046,43 @@ value_from_ffi_type (GValue *gvalue, gpointer *value)
+ g_value_set_double (gvalue, *(gdouble*)value);
+ break;
+ case G_TYPE_BOOLEAN:
+- g_value_set_boolean (gvalue, *(gboolean*)value);
++ g_value_set_boolean (gvalue, (gboolean) *int_val);
+ break;
+ case G_TYPE_STRING:
+ g_value_set_string (gvalue, *(gchar**)value);
+ break;
+ case G_TYPE_CHAR:
+- g_value_set_char (gvalue, *(gchar*)value);
++ g_value_set_char (gvalue, (gchar) *int_val);
+ break;
+ case G_TYPE_UCHAR:
+- g_value_set_uchar (gvalue, *(guchar*)value);
++ g_value_set_uchar (gvalue, (guchar) *int_val);
+ break;
+ case G_TYPE_UINT:
+- g_value_set_uint (gvalue, *(guint*)value);
++ g_value_set_uint (gvalue, (guint) *int_val);
+ break;
+ case G_TYPE_POINTER:
+ g_value_set_pointer (gvalue, *(gpointer*)value);
+ break;
+ case G_TYPE_LONG:
+- g_value_set_long (gvalue, *(glong*)value);
++ g_value_set_long (gvalue, (glong) *int_val);
+ break;
+ case G_TYPE_ULONG:
+- g_value_set_ulong (gvalue, *(gulong*)value);
++ g_value_set_ulong (gvalue, (gulong) *int_val);
+ break;
+ case G_TYPE_INT64:
+- g_value_set_int64 (gvalue, *(gint64*)value);
++ g_value_set_int64 (gvalue, (gint64) *int_val);
+ break;
+ case G_TYPE_UINT64:
+- g_value_set_uint64 (gvalue, *(guint64*)value);
++ g_value_set_uint64 (gvalue, (guint64) *int_val);
+ break;
+ case G_TYPE_BOXED:
+ g_value_set_boxed (gvalue, *(gpointer*)value);
+ break;
+ case G_TYPE_ENUM:
+- g_value_set_enum (gvalue, *(gint*)value);
++ g_value_set_enum (gvalue, (gint) *int_val);
+ break;
+ case G_TYPE_FLAGS:
+- g_value_set_flags (gvalue, *(guint*)value);
++ g_value_set_flags (gvalue, (guint) *int_val);
+ break;
+ case G_TYPE_PARAM:
+ g_value_set_param (gvalue, *(gpointer*)value);
+@@ -1108,10 +1131,13 @@ g_cclosure_marshal_generic (GClosure *closure,
+ int i;
+ ffi_cif cif;
+ GCClosure *cc = (GCClosure*) closure;
++ gint *enum_tmpval;
++ gboolean tmpval_used = FALSE;
+
++ enum_tmpval = g_alloca (sizeof (gint));
+ if (return_gvalue && G_VALUE_TYPE (return_gvalue))
+ {
+- rtype = value_to_ffi_type (return_gvalue, &rvalue);
++ rtype = value_to_ffi_type (return_gvalue, &rvalue, enum_tmpval, &tmpval_used);
+ }
+ else
+ {
+@@ -1124,22 +1150,38 @@ g_cclosure_marshal_generic (GClosure *closure,
+ atypes = g_alloca (sizeof (ffi_type *) * n_args);
+ args = g_alloca (sizeof (gpointer) * n_args);
+
++ if (tmpval_used)
++ enum_tmpval = g_alloca (sizeof (gint));
++
+ if (G_CCLOSURE_SWAP_DATA (closure))
+ {
+ atypes[n_args-1] = value_to_ffi_type (param_values + 0,
+- &args[n_args-1]);
++ &args[n_args-1],
++ enum_tmpval,
++ &tmpval_used);
+ atypes[0] = &ffi_type_pointer;
+ args[0] = &closure->data;
+ }
+ else
+ {
+- atypes[0] = value_to_ffi_type (param_values + 0, &args[0]);
++ atypes[0] = value_to_ffi_type (param_values + 0,
++ &args[0],
++ enum_tmpval,
++ &tmpval_used);
+ atypes[n_args-1] = &ffi_type_pointer;
+ args[n_args-1] = &closure->data;
+ }
+
+ for (i = 1; i < n_args - 1; i++)
+- atypes[i] = value_to_ffi_type (param_values + i, &args[i]);
++ {
++ if (tmpval_used)
++ enum_tmpval = g_alloca (sizeof (gint));
++
++ atypes[i] = value_to_ffi_type (param_values + i,
++ &args[i],
++ enum_tmpval,
++ &tmpval_used);
++ }
+
+ if (ffi_prep_cif (&cif, FFI_DEFAULT_ABI, n_args, rtype, atypes) != FFI_OK)
+ return;
+--
+1.7.8.5
+
diff --git a/dev-libs/glib/glib-2.30.3.ebuild b/dev-libs/glib/glib-2.30.3.ebuild
new file mode 100644
index 000000000000..c0655eef0d4e
--- /dev/null
+++ b/dev-libs/glib/glib-2.30.3.ebuild
@@ -0,0 +1,249 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.30.3.ebuild,v 1.1 2012/03/14 01:40:28 tetromino Exp $
+
+EAPI="4"
+PYTHON_DEPEND="utils? 2"
+# Avoid runtime dependency on python when USE=test
+
+inherit autotools gnome.org libtool eutils flag-o-matic multilib pax-utils python toolchain-funcs virtualx
+
+DESCRIPTION="The GLib library of C routines"
+HOMEPAGE="http://www.gtk.org/"
+SRC_URI="${SRC_URI}
+ http://pkgconfig.freedesktop.org/releases/pkg-config-0.26.tar.gz" # pkg.m4 for eautoreconf
+
+LICENSE="LGPL-2"
+SLOT="2"
+IUSE="debug doc fam selinux +static-libs systemtap test utils xattr"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-linux"
+
+RDEPEND="virtual/libiconv
+ virtual/libffi
+ sys-libs/zlib
+ xattr? ( sys-apps/attr )
+ fam? ( virtual/fam )
+ utils? ( >=dev-util/gdbus-codegen-${PV} )"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11
+ >=dev-util/gtk-doc-am-1.15
+ doc? (
+ >=dev-libs/libxslt-1.0
+ >=dev-util/gdbus-codegen-${PV}
+ >=dev-util/gtk-doc-1.15
+ ~app-text/docbook-xml-dtd-4.1.2 )
+ systemtap? ( >=dev-util/systemtap-1.3 )
+ test? (
+ sys-devel/gdb
+ =dev-lang/python-2*
+ >=dev-util/gdbus-codegen-${PV}
+ >=sys-apps/dbus-1.2.14 )
+ !<dev-util/gtk-doc-1.15-r2"
+PDEPEND="!<gnome-base/gvfs-1.6.4-r990" # Earlier versions do not work with glib
+
+pkg_setup() {
+ # Needed for gio/tests/gdbus-testserver.py
+ if use test ; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ mv -vf "${WORKDIR}"/pkg-config-*/pkg.m4 "${WORKDIR}"/ || die
+
+ if use ia64 ; then
+ # Only apply for < 4.1
+ local major=$(gcc-major-version)
+ local minor=$(gcc-minor-version)
+ if (( major < 4 || ( major == 4 && minor == 0 ) )); then
+ epatch "${FILESDIR}/glib-2.10.3-ia64-atomic-ops.patch"
+ fi
+ fi
+
+ # Fix from upstream for building with C++ compilers.
+ epatch "${FILESDIR}/${PN}-2.30.2-missing-decls.patch"
+
+ # Don't fail gio tests when ran without userpriv, upstream bug 552912
+ # This is only a temporary workaround, remove as soon as possible
+# epatch "${FILESDIR}/${PN}-2.18.1-workaround-gio-test-failure-without-userpriv.patch"
+
+ # Fix gmodule issues on fbsd; bug #184301
+ epatch "${FILESDIR}"/${PN}-2.12.12-fbsd.patch
+
+ # Fix test failure when upgrading from 2.22 to 2.24, upstream bug 621368
+ epatch "${FILESDIR}/${PN}-2.30.3-assert-test-failure.patch"
+
+ # Do not try to remove files on live filesystem, upstream bug #619274
+ sed 's:^\(.*"/desktop-app-info/delete".*\):/*\1*/:' \
+ -i "${S}"/gio/tests/desktop-app-info.c || die "sed failed"
+
+ # need to build tests if USE=doc for bug #387385
+ if ! use test && ! use doc; then
+ # don't waste time building tests
+ sed 's/^\(.*\SUBDIRS .*\=.*\)tests\(.*\)$/\1\2/' -i $(find . -name Makefile.am -o -name Makefile.in) || die
+ else
+ # Disable tests requiring dev-util/desktop-file-utils when not installed, bug #286629
+ if ! has_version dev-util/desktop-file-utils ; then
+ ewarn "Some tests will be skipped due dev-util/desktop-file-utils not being present on your system,"
+ ewarn "think on installing it to get these tests run."
+ sed -i -e "/appinfo\/associations/d" gio/tests/appinfo.c || die
+ sed -i -e "/desktop-app-info\/default/d" gio/tests/desktop-app-info.c || die
+ sed -i -e "/desktop-app-info\/fallback/d" gio/tests/desktop-app-info.c || die
+ sed -i -e "/desktop-app-info\/lastused/d" gio/tests/desktop-app-info.c || die
+ fi
+
+ # Disable tests requiring dbus-python and pygobject; bugs #349236, #377549, #384853
+ if ! has_version dev-python/dbus-python || ! has_version 'dev-python/pygobject:2' ; then
+ ewarn "Some tests will be skipped due to dev-python/dbus-python or dev-python/pygobject:2"
+ ewarn "not being present on your system, think on installing them to get these tests run."
+ sed -i -e "/connection\/filter/d" gio/tests/gdbus-connection.c || die
+ sed -i -e "/connection\/large_message/d" gio/tests/gdbus-connection-slow.c || die
+ sed -i -e "/gdbus\/proxy/d" gio/tests/gdbus-proxy.c || die
+ sed -i -e "/gdbus\/proxy-well-known-name/d" gio/tests/gdbus-proxy-well-known-name.c || die
+ sed -i -e "/gdbus\/introspection-parser/d" gio/tests/gdbus-introspection.c || die
+ sed -i -e "/g_test_add_func/d" gio/tests/gdbus-threading.c || die
+ sed -i -e "/gdbus\/method-calls-in-thread/d" gio/tests/gdbus-threading.c || die
+ # needed to prevent gdbus-threading from asserting
+ ln -sfn $(type -P true) gio/tests/gdbus-testserver.py
+ fi
+ fi
+
+ # gdbus-codegen is a separate package
+ epatch "${FILESDIR}/${PN}-2.30.1-external-gdbus-codegen.patch"
+
+ # Handle the G_HOME environment variable to override the passwd entry, upstream bug #142568
+ epatch "${FILESDIR}/${PN}-2.30.1-homedir-env.patch"
+
+ # Fix hardcoded path to machine-id wrt #390143
+ epatch "${FILESDIR}/${PN}-2.30.2-machine-id.patch"
+
+ # Fix from glib-2.31 for ppc64
+ epatch "${FILESDIR}/${PN}-2.30.3-closure-64bit-be.patch"
+
+ # disable pyc compiling
+ use test && python_clean_py-compile_files
+
+ # Needed for the punt-python-check patch, disabling timeout test
+ # Also needed to prevent croscompile failures, see bug #267603
+ # Also needed for the no-gdbus-codegen patch
+ AT_M4DIR="${WORKDIR}" eautoreconf
+
+ [[ ${CHOST} == *-freebsd* ]] && elibtoolize
+
+ epunt_cxx
+}
+
+src_configure() {
+ # Avoid circular depend with dev-util/pkgconfig and
+ # native builds (cross-compiles won't need pkg-config
+ # in the target ROOT to work here)
+ if ! tc-is-cross-compiler && ! has_version dev-util/pkgconfig; then
+ if has_version sys-apps/dbus; then
+ export DBUS1_CFLAGS="-I/usr/include/dbus-1.0 -I/usr/$(get_libdir)/dbus-1.0/include"
+ export DBUS1_LIBS="-ldbus-1"
+ fi
+ export LIBFFI_CFLAGS="-I$(echo /usr/$(get_libdir)/libffi-*/include)"
+ export LIBFFI_LIBS="-lffi"
+ fi
+
+ local myconf
+
+ # Building with --disable-debug highly unrecommended. It will build glib in
+ # an unusable form as it disables some commonly used API. Please do not
+ # convert this to the use_enable form, as it results in a broken build.
+ # -- compnerd (3/27/06)
+ use debug && myconf="--enable-debug"
+
+ # Always use internal libpcre, bug #254659
+ econf ${myconf} \
+ $(use_enable xattr) \
+ $(use_enable doc man) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable fam) \
+ $(use_enable selinux) \
+ $(use_enable static-libs static) \
+ $(use_enable systemtap dtrace) \
+ $(use_enable systemtap systemtap) \
+ --enable-regex \
+ --with-pcre=internal \
+ --with-threads=posix
+}
+
+src_install() {
+ local f
+
+ # install-exec-hook substitutes ${PYTHON} in glib/gtester-report
+ emake DESTDIR="${D}" PYTHON="${EPREFIX}/usr/bin/python2" install
+
+ if ! use utils; then
+ rm "${ED}usr/bin/gtester-report"
+ fi
+
+ # Do not install charset.alias even if generated, leave it to libiconv
+ rm -f "${ED}/usr/lib/charset.alias"
+
+ # Don't install gdb python macros, bug 291328
+ rm -rf "${ED}/usr/share/gdb/" "${ED}/usr/share/glib-2.0/gdb/"
+
+ dodoc AUTHORS ChangeLog* NEWS* README
+
+ insinto /usr/share/bash-completion
+ for f in gdbus gsettings; do
+ newins "${ED}/etc/bash_completion.d/${f}-bash-completion.sh" ${f}
+ done
+ rm -rf "${ED}/etc"
+
+ # Completely useless with or without USE static-libs, people need to use
+ # pkg-config
+ find "${D}" -name '*.la' -exec rm -f {} +
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ export XDG_CONFIG_DIRS=/etc/xdg
+ export XDG_DATA_DIRS=/usr/local/share:/usr/share
+ export G_DBUS_COOKIE_SHA1_KEYRING_DIR="${T}/temp"
+ export XDG_DATA_HOME="${T}"
+ unset GSETTINGS_BACKEND # bug 352451
+
+ # Related test is a bit nitpicking
+ mkdir "$G_DBUS_COOKIE_SHA1_KEYRING_DIR"
+ chmod 0700 "$G_DBUS_COOKIE_SHA1_KEYRING_DIR"
+
+ # Hardened: gdb needs this, bug #338891
+ if host-is-pax ; then
+ pax-mark -mr "${S}"/tests/.libs/assert-msg-test \
+ || die "Hardened adjustment failed"
+ fi
+
+ # Need X for dbus-launch session X11 initialization
+ Xemake check
+}
+
+pkg_preinst() {
+ # Only give the introspection message if:
+ # * The user has gobject-introspection
+ # * Has glib already installed
+ # * Previous version was different from new version
+ if has_version "dev-libs/gobject-introspection" && ! has_version "=${CATEGORY}/${PF}"; then
+ ewarn "You must rebuild gobject-introspection so that the installed"
+ ewarn "typelibs and girs are regenerated for the new APIs in glib"
+ fi
+}
+
+pkg_postinst() {
+ # Inform users about possible breakage when updating glib and not dbus-glib, bug #297483
+ if has_version dev-libs/dbus-glib; then
+ ewarn "If you experience a breakage after updating dev-libs/glib try"
+ ewarn "rebuilding dev-libs/dbus-glib"
+ fi
+
+ if has_version '<x11-libs/gtk+-3.0.12:3'; then
+ # To have a clear upgrade path for gtk+-3.0.x users, have to resort to
+ # a warning instead of a blocker
+ ewarn
+ ewarn "Using <gtk+-3.0.12:3 with ${P} results in frequent crashes."
+ ewarn "You should upgrade to a newer version of gtk+:3 immediately."
+ fi
+}