summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2006-09-13 17:52:15 +0000
committerAron Griffis <agriffis@gentoo.org>2006-09-13 17:52:15 +0000
commit122a5d19ee438d29035c3dfed08d2f2727a511b2 (patch)
tree5ca556b7a7d28eeda6ebb0518a988147918ee5c2 /dev-libs/glib
parentRemoved old ebuild (diff)
downloadgentoo-2-122a5d19ee438d29035c3dfed08d2f2727a511b2.tar.gz
gentoo-2-122a5d19ee438d29035c3dfed08d2f2727a511b2.tar.bz2
gentoo-2-122a5d19ee438d29035c3dfed08d2f2727a511b2.zip
Propogate ia64-atomic-ops.patch to more ebuilds
(Portage version: 2.1-r1)
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/ChangeLog7
-rw-r--r--dev-libs/glib/glib-2.10.3.ebuild9
-rw-r--r--dev-libs/glib/glib-2.12.0.ebuild11
-rw-r--r--dev-libs/glib/glib-2.12.1.ebuild12
-rw-r--r--dev-libs/glib/glib-2.12.2.ebuild11
-rw-r--r--dev-libs/glib/glib-2.12.3.ebuild11
6 files changed, 50 insertions, 11 deletions
diff --git a/dev-libs/glib/ChangeLog b/dev-libs/glib/ChangeLog
index 262b7d02843f..4ab76cb227b8 100644
--- a/dev-libs/glib/ChangeLog
+++ b/dev-libs/glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/glib
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.213 2006/09/04 06:02:53 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.214 2006/09/13 17:52:15 agriffis Exp $
+
+ 13 Sep 2006; Aron Griffis <agriffis@gentoo.org> glib-2.10.3.ebuild,
+ glib-2.12.0.ebuild, glib-2.12.1.ebuild, glib-2.12.2.ebuild,
+ glib-2.12.3.ebuild:
+ Propogate ia64-atomic-ops.patch to more ebuilds
*glib-2.12.3 (04 Sep 2006)
diff --git a/dev-libs/glib/glib-2.10.3.ebuild b/dev-libs/glib/glib-2.10.3.ebuild
index 19f5924382b9..a59ba91b2713 100644
--- a/dev-libs/glib/glib-2.10.3.ebuild
+++ b/dev-libs/glib/glib-2.10.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.10.3.ebuild,v 1.11 2006/08/18 22:18:31 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.10.3.ebuild,v 1.12 2006/09/13 17:52:15 agriffis Exp $
inherit gnome.org libtool eutils flag-o-matic debug
@@ -36,10 +36,9 @@ src_unpack() {
if use ia64; then
# Only apply for < 4.1
- local ma="$(gcc-major-version)"
- local mi="$(gcc-minor-version)"
- if [[ "${ma}" -lt 4 ]] || [[ "${ma}" -eq 4 && "${mi}" -eq 0 ]]
- then
+ local major=$(gcc-major-version)
+ local minor=$(gcc-minor-version)
+ if (( major < 4 || ( major == 4 && minor == 0 ) )); then
epatch "${FILESDIR}/glib-2.10.3-ia64-atomic-ops.patch"
fi
fi
diff --git a/dev-libs/glib/glib-2.12.0.ebuild b/dev-libs/glib/glib-2.12.0.ebuild
index dbeda07081eb..8d6fdc6f65fd 100644
--- a/dev-libs/glib/glib-2.12.0.ebuild
+++ b/dev-libs/glib/glib-2.12.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.12.0.ebuild,v 1.1 2006/07/05 15:01:07 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.12.0.ebuild,v 1.2 2006/09/13 17:52:15 agriffis Exp $
inherit gnome.org libtool eutils flag-o-matic debug
@@ -34,6 +34,15 @@ src_unpack() {
epatch "${FILESDIR}"/glib-2.6.3-testglib-ssp.patch
fi
+ if use ia64; then
+ # Only apply for < 4.1
+ local major=$(gcc-major-version)
+ local minor=$(gcc-minor-version)
+ if (( major < 4 || ( major == 4 && minor == 0 ) )); then
+ epatch "${FILESDIR}/glib-2.10.3-ia64-atomic-ops.patch"
+ fi
+ fi
+
epatch ${FILESDIR}/${PN}-2.8.3-macos.patch
}
diff --git a/dev-libs/glib/glib-2.12.1.ebuild b/dev-libs/glib/glib-2.12.1.ebuild
index 92449c93905f..3b3fdc30bb22 100644
--- a/dev-libs/glib/glib-2.12.1.ebuild
+++ b/dev-libs/glib/glib-2.12.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.12.1.ebuild,v 1.1 2006/07/24 21:10:00 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.12.1.ebuild,v 1.2 2006/09/13 17:52:15 agriffis Exp $
inherit gnome.org libtool eutils flag-o-matic debug
@@ -34,8 +34,16 @@ src_unpack() {
epatch "${FILESDIR}"/glib-2.6.3-testglib-ssp.patch
fi
- epatch ${FILESDIR}/${PN}-2.8.3-macos.patch
+ if use ia64; then
+ # Only apply for < 4.1
+ local major=$(gcc-major-version)
+ local minor=$(gcc-minor-version)
+ if (( major < 4 || ( major == 4 && minor == 0 ) )); then
+ epatch "${FILESDIR}/glib-2.10.3-ia64-atomic-ops.patch"
+ fi
+ fi
+ epatch ${FILESDIR}/${PN}-2.8.3-macos.patch
}
src_compile() {
diff --git a/dev-libs/glib/glib-2.12.2.ebuild b/dev-libs/glib/glib-2.12.2.ebuild
index 580438e5b116..9a7cdfd6d5bc 100644
--- a/dev-libs/glib/glib-2.12.2.ebuild
+++ b/dev-libs/glib/glib-2.12.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.12.2.ebuild,v 1.1 2006/09/07 03:38:40 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.12.2.ebuild,v 1.2 2006/09/13 17:52:15 agriffis Exp $
inherit gnome.org libtool eutils flag-o-matic debug
@@ -34,6 +34,15 @@ src_unpack() {
epatch "${FILESDIR}"/glib-2.6.3-testglib-ssp.patch
fi
+ if use ia64; then
+ # Only apply for < 4.1
+ local major=$(gcc-major-version)
+ local minor=$(gcc-minor-version)
+ if (( major < 4 || ( major == 4 && minor == 0 ) )); then
+ epatch "${FILESDIR}/glib-2.10.3-ia64-atomic-ops.patch"
+ fi
+ fi
+
epatch ${FILESDIR}/${PN}-2.8.3-macos.patch
}
diff --git a/dev-libs/glib/glib-2.12.3.ebuild b/dev-libs/glib/glib-2.12.3.ebuild
index 7e78a267fded..f7b25ae08b3a 100644
--- a/dev-libs/glib/glib-2.12.3.ebuild
+++ b/dev-libs/glib/glib-2.12.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.12.3.ebuild,v 1.1 2006/09/04 06:02:53 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.12.3.ebuild,v 1.2 2006/09/13 17:52:15 agriffis Exp $
inherit gnome.org libtool eutils flag-o-matic debug
@@ -33,6 +33,15 @@ src_unpack() {
epatch "${FILESDIR}"/glib-2.6.3-testglib-ssp.patch
fi
+ if use ia64; then
+ # Only apply for < 4.1
+ local major=$(gcc-major-version)
+ local minor=$(gcc-minor-version)
+ if (( major < 4 || ( major == 4 && minor == 0 ) )); then
+ epatch "${FILESDIR}/glib-2.10.3-ia64-atomic-ops.patch"
+ fi
+ fi
+
epatch ${FILESDIR}/${PN}-2.8.3-macos.patch
}