summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Shepherd <masterdriverz@gentoo.org>2006-12-08 18:46:52 +0000
committerCharlie Shepherd <masterdriverz@gentoo.org>2006-12-08 18:46:52 +0000
commitcc451e016f12df480ea8337977ff50d0f233f49f (patch)
treebdf551b94148f552fb5c1f14d967127dd2470bc2 /dev-libs/gdome2/gdome2-0.8.1-r2.ebuild
parentMarked stable on amd64 for bug #155901 (diff)
downloadgentoo-2-cc451e016f12df480ea8337977ff50d0f233f49f.tar.gz
gentoo-2-cc451e016f12df480ea8337977ff50d0f233f49f.tar.bz2
gentoo-2-cc451e016f12df480ea8337977ff50d0f233f49f.zip
Fix configure.in so that gdome2-conf --version works correctly, thanks to Daniel Westermann-Clark; bug 114542
(Portage version: 2.1.2_rc2-r2)
Diffstat (limited to 'dev-libs/gdome2/gdome2-0.8.1-r2.ebuild')
-rw-r--r--dev-libs/gdome2/gdome2-0.8.1-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/gdome2/gdome2-0.8.1-r2.ebuild b/dev-libs/gdome2/gdome2-0.8.1-r2.ebuild
new file mode 100644
index 000000000000..ec1db23e52ae
--- /dev/null
+++ b/dev-libs/gdome2/gdome2-0.8.1-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gdome2/gdome2-0.8.1-r2.ebuild,v 1.1 2006/12/08 18:46:52 masterdriverz Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="The DOM C library for the GNOME project"
+HOMEPAGE="http://gdome2.cs.unibo.it/"
+SRC_URI="http://gdome2.cs.unibo.it/tarball/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="alpha ~amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.2.0
+ >=dev-libs/libxml2-2.4.26"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1 )
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog INSTALL MAINTAINERS NEWS README*"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix broken GLIB_CONFIG in configure.in, see #114542
+ epatch ${FILESDIR}/gdome2-0.8.1-gdome2-config.patch
+ eautoconf || die
+
+ # make docs honor DESTDIR
+ epatch "${FILESDIR}/${P}-docs-destdir.patch"
+
+ # prevent gtk-fixxref from running (will cause sandbox violation)
+ cd ${S}/gtk-doc
+ sed -e 's:gtkdoc-fixxref:#gtkdoc-fixxref:' -i Makefile.in
+}