summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-01-04 08:37:13 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-01-04 08:37:13 +0000
commit19370c02e666a0c5f42560826c1a2d861563a91e (patch)
treef885ba9faa949efa9dd9aca6b83e6ac14b78cc77 /dev-libs/dvxml
parentVersion bump (bug #203806). (diff)
downloadgentoo-2-19370c02e666a0c5f42560826c1a2d861563a91e.tar.gz
gentoo-2-19370c02e666a0c5f42560826c1a2d861563a91e.tar.bz2
gentoo-2-19370c02e666a0c5f42560826c1a2d861563a91e.zip
Version bump (bug #203806). Dropped old version.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-libs/dvxml')
-rw-r--r--dev-libs/dvxml/ChangeLog12
-rw-r--r--dev-libs/dvxml/dvxml-0.1.4-r2.ebuild32
-rw-r--r--dev-libs/dvxml/dvxml-0.1.5.ebuild37
-rw-r--r--dev-libs/dvxml/files/digest-dvxml-0.1.4-r23
-rw-r--r--dev-libs/dvxml/files/digest-dvxml-0.1.53
-rw-r--r--dev-libs/dvxml/files/dvxml-0.1.4-fix-underquoted-m4.diff20
-rw-r--r--dev-libs/dvxml/files/dvxml-0.1.5-namespace_usage.patch215
7 files changed, 265 insertions, 57 deletions
diff --git a/dev-libs/dvxml/ChangeLog b/dev-libs/dvxml/ChangeLog
index 8efb892a318c..8d42df606cd1 100644
--- a/dev-libs/dvxml/ChangeLog
+++ b/dev-libs/dvxml/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/dvxml
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dvxml/ChangeLog,v 1.11 2006/11/29 21:42:28 dev-zero Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dvxml/ChangeLog,v 1.12 2008/01/04 08:37:13 dev-zero Exp $
+
+*dvxml-0.1.5 (04 Jan 2008)
+
+ 04 Jan 2008; Tiziano Müller <dev-zero@gentoo.org>
+ -files/dvxml-0.1.4-fix-underquoted-m4.diff,
+ +files/dvxml-0.1.5-namespace_usage.patch, -dvxml-0.1.4-r2.ebuild,
+ +dvxml-0.1.5.ebuild:
+ Version bump (bug #203806). Dropped old version.
29 Nov 2006; Tiziano Müller <dev-zero@gentoo.org> metadata.xml:
Set herd as maintainer
diff --git a/dev-libs/dvxml/dvxml-0.1.4-r2.ebuild b/dev-libs/dvxml/dvxml-0.1.4-r2.ebuild
deleted file mode 100644
index 88e02a56916d..000000000000
--- a/dev-libs/dvxml/dvxml-0.1.4-r2.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dvxml/dvxml-0.1.4-r2.ebuild,v 1.1 2005/05/20 12:58:41 ka0ttic Exp $
-
-inherit eutils
-
-DESCRIPTION="dvxml provides some convenient stuff on top of the xmlwrapp package"
-SRC_URI="http://tinf2.vub.ac.be/~dvermeir/software/dv/dvxml/download/dvxml-${PV}.tar.gz"
-HOMEPAGE="http://tinf2.vub.ac.be/~dvermeir/software/dv/dvxml/html/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc"
-IUSE="doc"
-
-DEPEND="dev-libs/dvutil
- dev-libs/xmlwrapp"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-fix-underquoted-m4.diff
-
- sed -i 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' Makefile.in || \
- die "sed Makefile.in failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- dodoc ChangeLog README AUTHORS
- use doc && dohtml -r doc/html/*
-}
diff --git a/dev-libs/dvxml/dvxml-0.1.5.ebuild b/dev-libs/dvxml/dvxml-0.1.5.ebuild
new file mode 100644
index 000000000000..e040b77892ac
--- /dev/null
+++ b/dev-libs/dvxml/dvxml-0.1.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dvxml/dvxml-0.1.5.ebuild,v 1.1 2008/01/04 08:37:13 dev-zero Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="dvxml provides some convenient stuff on top of the xmlwrapp package"
+SRC_URI="http://tinf2.vub.ac.be/~dvermeir/software/dv/${PN}/download/${P}.tar.gz"
+HOMEPAGE="http://tinf2.vub.ac.be/~dvermeir/software/dv/dvxml/html/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="dev-libs/dvutil
+ >=dev-libs/xmlwrapp-0.5.0
+ dev-libs/libxslt
+ dev-libs/libxml2"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-namespace_usage.patch"
+
+ sed -i 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' Makefile.in || \
+ die "sed Makefile.in failed"
+
+ filter-ldflags -Wl,--as-needed
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog README AUTHORS
+ use doc && dohtml -r doc/html/*
+}
diff --git a/dev-libs/dvxml/files/digest-dvxml-0.1.4-r2 b/dev-libs/dvxml/files/digest-dvxml-0.1.4-r2
deleted file mode 100644
index 3bda5588f782..000000000000
--- a/dev-libs/dvxml/files/digest-dvxml-0.1.4-r2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 91b17474673d24bae194188e53303a65 dvxml-0.1.4.tar.gz 419031
-RMD160 ced368271ad6da894718323c0d11ffad84429e2d dvxml-0.1.4.tar.gz 419031
-SHA256 73865d84ebcc60e075c3a1f35751a2d25116c4e4b3c8ab12573394b2d838fb90 dvxml-0.1.4.tar.gz 419031
diff --git a/dev-libs/dvxml/files/digest-dvxml-0.1.5 b/dev-libs/dvxml/files/digest-dvxml-0.1.5
new file mode 100644
index 000000000000..ab4fd53a9340
--- /dev/null
+++ b/dev-libs/dvxml/files/digest-dvxml-0.1.5
@@ -0,0 +1,3 @@
+MD5 74fb2d53728ceb14234c44ae9539d052 dvxml-0.1.5.tar.gz 488546
+RMD160 249017846ef0450f11a33cd5ce805034d860ee60 dvxml-0.1.5.tar.gz 488546
+SHA256 1d3333f9a35909e3a6c17ee2fa99ad6e02d77dcd81194aa934a0d4fe7bbe73c0 dvxml-0.1.5.tar.gz 488546
diff --git a/dev-libs/dvxml/files/dvxml-0.1.4-fix-underquoted-m4.diff b/dev-libs/dvxml/files/dvxml-0.1.4-fix-underquoted-m4.diff
deleted file mode 100644
index 74a7e2216025..000000000000
--- a/dev-libs/dvxml/files/dvxml-0.1.4-fix-underquoted-m4.diff
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --exclude='*~' --exclude='.*' -I '$Id:' -urN dvxml-0.1.4.orig/m4/dvxml.m4.in dvxml-0.1.4/m4/dvxml.m4.in
---- dvxml-0.1.4.orig/m4/dvxml.m4.in 2005-05-20 04:26:03.000000000 -0400
-+++ dvxml-0.1.4/m4/dvxml.m4.in 2005-05-20 04:26:24.000000000 -0400
-@@ -1,6 +1,6 @@
- dnl @PACKAGE@-@VERSION@ autoconf macros
-
--AC_DEFUN(DV_REQUIRE_XMLWRAPP,
-+AC_DEFUN([DV_REQUIRE_XMLWRAPP],
- [
- DV_REQUIRE_CFUNC(xmlBufferCat,xml2)
- DV_APPEND_UNIQ("-lxml2", CXXLTLIBS)
-@@ -13,7 +13,7 @@
- DV_APPEND_UNIQ("-lxsltwrapp", CXXLTLIBS)
- ])
-
--AC_DEFUN(DV_REQUIRE_DVXML,
-+AC_DEFUN([DV_REQUIRE_DVXML],
- [
- DV_REQUIRE_XMLWRAPP
- DV_REQUIRE_LTLIB([dvxml/xml.h],[Dv::Xml::Document doc;],dvxml,
diff --git a/dev-libs/dvxml/files/dvxml-0.1.5-namespace_usage.patch b/dev-libs/dvxml/files/dvxml-0.1.5-namespace_usage.patch
new file mode 100644
index 000000000000..4f34a8b78e3e
--- /dev/null
+++ b/dev-libs/dvxml/files/dvxml-0.1.5-namespace_usage.patch
@@ -0,0 +1,215 @@
+diff -Naur dvxml-0.1.5.orig/dvxml/node.C dvxml-0.1.5/dvxml/node.C
+--- dvxml-0.1.5.orig/dvxml/node.C 2008-01-04 09:22:42.000000000 +0100
++++ dvxml-0.1.5/dvxml/node.C 2008-01-04 09:24:21.000000000 +0100
+@@ -3,9 +3,12 @@
+ #include <iostream>
+ #include <dvutil/ntostr.h>
+
++namespace Dv {
++namespace Xml {
++
+ //////// Auxiliary assertion function.
+ void
+-Dv::Xml::Node::Ref::assert_valid(const std::string& operation) const
++Node::Ref::assert_valid(const std::string& operation) const
+ throw (Dv::Xml::Exception) {
+ if (nil())
+ throw Dv::Xml::Exception(operation + ": nil node");
+@@ -13,19 +16,19 @@
+
+ //////// Auxiliary Dv::Xml::Node::AttributeReference class.
+
+-Dv::Xml::Node::AttributeReference::AttributeReference(const xml::node::iterator n,
++Node::AttributeReference::AttributeReference(const xml::node::iterator n,
+ const std::string& nm): name(nm), node(n) {
+ }
+
+ const std::string&
+-Dv::Xml::Node::AttributeReference::operator=(const std::string& value) {
++Node::AttributeReference::operator=(const std::string& value) {
+ // node->get_attributes().insert(name.c_str(), Dv::Xml::to_html(value).c_str());
+ node->get_attributes().insert(name.c_str(), value.c_str());
+ return value;
+ }
+
+ std::string
+-Dv::Xml::Node::AttributeReference::str() const {
++Node::AttributeReference::str() const {
+ xml::attributes::iterator it(node->get_attributes().find(name.c_str()));
+ if ( it == node->get_attributes().end() )
+ return "";
+@@ -35,28 +38,28 @@
+
+ //////// Constructors.
+
+-Dv::Xml::Node::Ref::Ref(xml::node& node): it_(node.self()), nil_(false) {
++Node::Ref::Ref(xml::node& node): it_(node.self()), nil_(false) {
+ }
+
+-Dv::Xml::Node::Ref::Ref(xml::node::iterator it, bool nil): it_(it), nil_(nil) {
++Node::Ref::Ref(xml::node::iterator it, bool nil): it_(it), nil_(nil) {
+ }
+
+ //////// Retrieve info on Node
+ std::string
+-Dv::Xml::Node::Ref::name() const throw (Exception) {
++Node::Ref::name() const throw (Exception) {
+ assert_valid("name()");
+ return it_->get_name();
+ }
+
+-Dv::Xml::Node::Ref::operator const xml::node*() const {
++Node::Ref::operator const xml::node*() const {
+ if (nil())
+ return 0;
+ return &*it_;
+ }
+
+ //////// Setting Node properties
+-Dv::Xml::Node::Ref&
+-Dv::Xml::Node::Ref::name(const std::string& nm) throw (Exception) {
++Node::Ref&
++Node::Ref::name(const std::string& nm) throw (Exception) {
+ assert_valid("name(name)");
+ it_->set_name(nm.c_str());
+ return *this;
+@@ -64,16 +67,16 @@
+
+ //////// Finding and creating children.
+
+-Dv::Xml::Node::Ref
+-Dv::Xml::operator/(const Dv::Xml::Node::Ref& ref, const std::string& nm)
++Node::Ref
++operator/(const Dv::Xml::Node::Ref& ref, const std::string& nm)
+ throw (Dv::Xml::Exception) {
+ ref.assert_valid(nm + "/");
+ xml::node::iterator itc(ref.it_->find(nm.c_str()));
+ return Dv::Xml::Node::Ref(itc, itc == ref.it_->end() );
+ }
+
+-Dv::Xml::Node::Ref
+-Dv::Xml::operator>>(const Dv::Xml::Node::Ref& ref, const std::string& name)
++Node::Ref
++operator>>(const Dv::Xml::Node::Ref& ref, const std::string& name)
+ throw (Dv::Xml::Exception) {
+ static const std::string op(">>");
+ ref.assert_valid(op + name);
+@@ -81,8 +84,8 @@
+ return Dv::Xml::Node::Ref(ref.it_->insert(n));
+ }
+
+-Dv::Xml::Node::Ref
+-Dv::Xml::operator>>(const Dv::Xml::Node::Ref& ref, const Dv::Xml::Node::Ref& nref)
++Node::Ref
++operator>>(const Dv::Xml::Node::Ref& ref, const Dv::Xml::Node::Ref& nref)
+ throw (Dv::Xml::Exception) {
+ ref.assert_valid("BadRef::operator>>(const Ref&)");
+ nref.assert_valid("operator>>(const BadRef&)");
+@@ -91,8 +94,8 @@
+
+ //////// Iterator operations
+
+-Dv::Xml::Node::Ref
+-Dv::Xml::Node::Ref::operator++() throw (Exception) {
++Node::Ref
++Node::Ref::operator++() throw (Exception) {
+ assert_valid("operator++");
+ xml::node::iterator parent(it_->parent());
+ xml::node::iterator next(it_);
+@@ -101,14 +104,14 @@
+ return *this;
+ }
+
+-Dv::Xml::Node::Ref
+-Dv::Xml::Node::Ref::end() const throw (Exception) {
++Node::Ref
++Node::Ref::end() const throw (Exception) {
+ assert_valid("end()");
+ return Ref(it_->end(), true);
+ }
+
+ bool
+-Dv::Xml::operator==(const Dv::Xml::Node::Ref& n, const Dv::Xml::Node::Ref& m) {
++operator==(const Dv::Xml::Node::Ref& n, const Dv::Xml::Node::Ref& m) {
+ if ( n.nil() )
+ return m.nil();
+ else
+@@ -118,14 +121,14 @@
+ //////// Setting and retrieving attributes.
+
+ bool
+-Dv::Xml::Node::Ref::defined(const std::string& name) const throw (Exception) {
++Node::Ref::defined(const std::string& name) const throw (Exception) {
+ assert_valid(name + "(defined)");
+ xml::attributes::iterator it(it_->get_attributes().find(name.c_str()));
+ return ( it != it_->get_attributes().end() );
+ }
+
+ const std::string
+-Dv::Xml::Node::Ref::operator()(const std::string& nm) const throw (Exception) {
++Node::Ref::operator()(const std::string& nm) const throw (Exception) {
+ assert_valid(nm + "(get_attr)");
+ xml::attributes::iterator it(it_->get_attributes().find(nm.c_str()));
+ if ( it == it_->get_attributes().end() )
+@@ -133,20 +136,20 @@
+ return it->get_value();
+ }
+
+-Dv::Xml::Node::AttributeReference
+-Dv::Xml::Node::Ref::operator[](const std::string& name) throw (Exception) {
++Node::AttributeReference
++Node::Ref::operator[](const std::string& name) throw (Exception) {
+ assert_valid(name + "[]");
+ return AttributeReference(it_, name);
+ }
+
+ //////// Setting and retrieving text content.
+
+-Dv::Xml::Node::Ref::operator std::string() const throw (Exception) {
++Node::Ref::operator std::string() const throw (Exception) {
+ return str(true);
+ }
+
+ std::string
+-Dv::Xml::Node::Ref::str(bool trim) const throw (Exception) {
++Node::Ref::str(bool trim) const throw (Exception) {
+ assert_valid("get_content");
+ if (trim) {
+ std::string result(it_->get_content());
+@@ -157,8 +160,8 @@
+ return it_->get_content();
+ }
+
+-Dv::Xml::Node::Ref&
+-Dv::Xml::Node::Ref::operator=(const std::string& text) throw (Exception) {
++Node::Ref&
++Node::Ref::operator=(const std::string& text) throw (Exception) {
+ assert_valid(text + ": set_content");
+ // it_->set_content(Dv::Xml::to_html(text).c_str());
+ it_->set_content(text.c_str());
+@@ -168,8 +171,8 @@
+ //////// Replacing a node.
+
+
+-Dv::Xml::Node::Ref&
+-Dv::Xml::Node::Ref::replace(const Ref& ref) {
++Node::Ref&
++Node::Ref::replace(const Ref& ref) {
+ assert_valid("replace");
+ if (this == &ref)
+ return *this;
+@@ -184,10 +187,13 @@
+ }
+
+ std::ostream&
+-Dv::Xml::operator<<(std::ostream& os, const Dv::Xml::Node::Ref& ref) {
++operator<<(std::ostream& os, const Dv::Xml::Node::Ref& ref) {
+ const xml::node* p(static_cast<const xml::node*>(ref));
+ if (p)
+ return os << *p;
+ else
+ return os << "NIL";
+ }
++
++} // namespace Xml
++} // namespace Dv