summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-10-09 07:34:18 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-10-09 07:34:18 +0000
commit9ccc8f9181adb26a4ee2aded0f20860d42b43192 (patch)
tree7867baf2c88f39daa46eb296fda036ab859d6389 /dev-libs/cryptlib
parentgoing stable (diff)
downloadgentoo-2-9ccc8f9181adb26a4ee2aded0f20860d42b43192.tar.gz
gentoo-2-9ccc8f9181adb26a4ee2aded0f20860d42b43192.tar.bz2
gentoo-2-9ccc8f9181adb26a4ee2aded0f20860d42b43192.zip
tidy; more error messages; actually install the manual if USE=doc
Diffstat (limited to 'dev-libs/cryptlib')
-rw-r--r--dev-libs/cryptlib/ChangeLog6
-rw-r--r--dev-libs/cryptlib/Manifest4
-rw-r--r--dev-libs/cryptlib/cryptlib-3.1_beta04.ebuild31
3 files changed, 27 insertions, 14 deletions
diff --git a/dev-libs/cryptlib/ChangeLog b/dev-libs/cryptlib/ChangeLog
index eb8b09e48173..9daf1f342b75 100644
--- a/dev-libs/cryptlib/ChangeLog
+++ b/dev-libs/cryptlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/cryptlib
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/ChangeLog,v 1.1 2003/06/13 17:54:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/ChangeLog,v 1.2 2003/10/09 07:34:15 mr_bones_ Exp $
+
+ 09 Oct 2003; Michael Sterrett <mr_bones_@gentoo.org>
+ cryptlib-3.1_beta04.ebuild:
+ tidy; more error messages; actually install the manual if USE=doc
*cryptlib-3.1_beta04 (13 Jun 2003)
diff --git a/dev-libs/cryptlib/Manifest b/dev-libs/cryptlib/Manifest
index 7eed9da96ae5..7dfa8b1bdf5c 100644
--- a/dev-libs/cryptlib/Manifest
+++ b/dev-libs/cryptlib/Manifest
@@ -1,5 +1,5 @@
+MD5 6083cd40e7aa06c4479a3089fb23cc8e ChangeLog 629
MD5 0fc6db7b40264047cb491190ab09a0ee cryptlib-3.0.ebuild 1122
+MD5 cc6c51a5d18862002e1d00d9cede390b cryptlib-3.1_beta04.ebuild 1452
MD5 bb69781cd7a49bb58937abeba1ea18dd files/digest-cryptlib-3.0 108
MD5 743e6e019948102d51993bc1e2745d0c files/digest-cryptlib-3.1_beta04 114
-MD5 dd4efb0ec611545265f2ef94e38e0052 ChangeLog 472
-MD5 3ea12f4cd169bbeb4cf8d7c0a9c64392 cryptlib-3.1_beta04.ebuild 1164
diff --git a/dev-libs/cryptlib/cryptlib-3.1_beta04.ebuild b/dev-libs/cryptlib/cryptlib-3.1_beta04.ebuild
index 68edb038ea0d..55008208a20d 100644
--- a/dev-libs/cryptlib/cryptlib-3.1_beta04.ebuild
+++ b/dev-libs/cryptlib/cryptlib-3.1_beta04.ebuild
@@ -1,37 +1,46 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/cryptlib-3.1_beta04.ebuild,v 1.1 2003/06/13 17:54:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/cryptlib-3.1_beta04.ebuild,v 1.2 2003/10/09 07:34:15 mr_bones_ Exp $
MY_PV=${PV/./}; MY_PV=${MY_PV/_/}
-DESCRIPTION="powerful security toolkit for adding encryption to software"
+DESCRIPTION="Powerful security toolkit for adding encryption to software"
HOMEPAGE="http://www.cs.auckland.ac.nz/~pgut001/cryptlib/"
SRC_URI="ftp://ftp.franken.de/pub/crypt/cryptlib/beta/cl${MY_PV}.zip
doc? ( ftp://ftp.franken.de/pub/crypt/cryptlib/beta/manual.pdf )"
LICENSE="Sleepycat"
-SLOT="0"
KEYWORDS="x86"
+SLOT="0"
+
IUSE="static doc"
S=${WORKDIR}
src_unpack() {
- # cant use unpack cause we need the '-a' option
- unzip -qoa ${DISTDIR}/${A}
+ # Can't use unpack because we need the '-a' option
+ unzip -qoa ${DISTDIR}/cl${MY_PV}.zip
}
src_compile() {
export SCFLAGS="-fpic -c -D__UNIX__ -DNDEBUG -I. ${CFLAGS}"
export CFLAGS="-c -D__UNIX__ -DNDEBUG -I. ${CFLAGS}"
if [ `use static` ] ; then
- make CFLAGS="${CFLAGS}" SCFLAGS="${SCFLAGS}" || die "could not make static"
+ emake CFLAGS="${CFLAGS}" SCFLAGS="${SCFLAGS}" || \
+ die "emake static failed"
fi
- make shared CFLAGS="${CFLAGS}" SCFLAGS="${SCFLAGS}" || die "could not make shared"
+ emake shared CFLAGS="${CFLAGS}" SCFLAGS="${SCFLAGS}" || \
+ die "emake shared failed"
}
src_install() {
- dolib.so libcl.so*
- use static && dolib.a libcl.a
- insinto /usr/include ; doins cryptlib.h
- dodoc README
+ dolib.so libcl.so* || die "dolib.so failed"
+ if [ `use static` ] ; then
+ dolib.a libcl.a || die "dolib.a failed"
+ fi
+ insinto /usr/include
+ doins cryptlib.h || die "doins failed"
+ dodoc README || die "dodoc failed"
+ if [ `use doc` ] ; then
+ dodoc ${DISTDIR}/manual.pdf || die "dodoc failed (manual.pdf)"
+ fi
}