summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-02-07 09:51:52 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-02-07 09:51:52 +0000
commit6bafaf8aafff12fb41da803733bc3c037e95a1c5 (patch)
tree15931adbbe729cbf0d3fa39f52087860d87ec464 /dev-libs/beecrypt
parentRespect CFLAGS wrt bug #455840, fix conditions on nonexistent 'svn' USE flag ... (diff)
downloadgentoo-2-6bafaf8aafff12fb41da803733bc3c037e95a1c5.tar.gz
gentoo-2-6bafaf8aafff12fb41da803733bc3c037e95a1c5.tar.bz2
gentoo-2-6bafaf8aafff12fb41da803733bc3c037e95a1c5.zip
Revision bump: EAPI 5, add sub-slot operator for dependency on dev-libs/icu, wrt bug #455900
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/beecrypt')
-rw-r--r--dev-libs/beecrypt/ChangeLog10
-rw-r--r--dev-libs/beecrypt/beecrypt-4.2.1-r1.ebuild87
2 files changed, 95 insertions, 2 deletions
diff --git a/dev-libs/beecrypt/ChangeLog b/dev-libs/beecrypt/ChangeLog
index 1c662c691925..e089fbf69ed3 100644
--- a/dev-libs/beecrypt/ChangeLog
+++ b/dev-libs/beecrypt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/beecrypt
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/ChangeLog,v 1.83 2012/09/06 05:41:11 vapier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/ChangeLog,v 1.84 2013/02/07 09:51:52 pinkbyte Exp $
+
+*beecrypt-4.2.1-r1 (07 Feb 2013)
+
+ 07 Feb 2013; Sergey Popov <pinkbyte@gentoo.org> +beecrypt-4.2.1-r1.ebuild:
+ Revision bump: EAPI 5, add sub-slot operator for dependency on dev-libs/icu,
+ wrt bug #455900
06 Sep 2012; Mike Frysinger <vapier@gentoo.org>
files/beecrypt-4.2.1-build-system.patch:
diff --git a/dev-libs/beecrypt/beecrypt-4.2.1-r1.ebuild b/dev-libs/beecrypt/beecrypt-4.2.1-r1.ebuild
new file mode 100644
index 000000000000..7a3fe0b829b0
--- /dev/null
+++ b/dev-libs/beecrypt/beecrypt-4.2.1-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/beecrypt-4.2.1-r1.ebuild,v 1.1 2013/02/07 09:51:52 pinkbyte Exp $
+
+EAPI=5
+PYTHON_DEPEND="python? 2"
+
+inherit eutils multilib autotools java-pkg-opt-2 python
+
+DESCRIPTION="general-purpose cryptography library"
+HOMEPAGE="http://sourceforge.net/projects/beecrypt/"
+SRC_URI="mirror://sourceforge/beecrypt/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="java cxx python static-libs threads doc"
+
+COMMONDEPEND="!<app-arch/rpm-4.2.1
+ cxx? ( >=dev-libs/icu-2.8:= )"
+
+DEPEND="${COMMONDEPEND}
+ java? ( >=virtual/jdk-1.4 )
+ doc? ( app-doc/doxygen
+ virtual/latex-base
+ dev-texlive/texlive-fontsextra
+ )"
+RDEPEND="${COMMONDEPEND}
+ java? ( >=virtual/jre-1.4 )"
+
+DOCS="BUGS README BENCHMARKS NEWS"
+
+REQUIRED_USE="cxx? ( threads )"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ java-pkg-opt-2_pkg_setup
+ fi
+}
+
+src_prepare() {
+ java-pkg-opt-2_src_prepare
+
+ use python && python_convert_shebangs -r 2 .
+
+ epatch "${FILESDIR}"/${P}-build-system.patch
+ epatch "${FILESDIR}"/${P}-gcc-4.7.patch
+ eautoreconf
+}
+
+src_configure() {
+ # cpluscplus needs threads support
+ econf \
+ --disable-expert-mode \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(use_with python python "${EPREFIX}"/usr/bin/python2) \
+ $(use_with cxx cplusplus) \
+ $(use_with java)
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ cd include/beecrypt
+ doxygen || die "doxygen failed"
+ fi
+}
+
+src_test() {
+ export BEECRYPT_CONF_FILE="${T}/beecrypt-test.conf"
+ echo "provider.1=${S}/c++/provider/.libs/base.so" > "${BEECRYPT_CONF_FILE}"
+ emake check
+ emake bench
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/$(get_libdir)/python*/site-packages/_bc.*a
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+
+ use doc && dohtml -r docs/html/.
+}