summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stewart <vericgar@gentoo.org>2006-07-07 05:05:50 +0000
committerMichael Stewart <vericgar@gentoo.org>2006-07-07 05:05:50 +0000
commitd592145acfc4aa49cfac4b341b4e6b1f0e74e0a0 (patch)
tree7a2e08646635b5f7c41c7066444d0d6dc74a8be9 /dev-libs/apr
parentStable x86; Its nut-astic! (diff)
downloadgentoo-2-d592145acfc4aa49cfac4b341b4e6b1f0e74e0a0.tar.gz
gentoo-2-d592145acfc4aa49cfac4b341b4e6b1f0e74e0a0.tar.bz2
gentoo-2-d592145acfc4aa49cfac4b341b4e6b1f0e74e0a0.zip
Use a config.layout instead of command line options to work around bug 139033.
(Portage version: 2.1.1_pre2-r2)
Diffstat (limited to 'dev-libs/apr')
-rw-r--r--dev-libs/apr/ChangeLog8
-rw-r--r--dev-libs/apr/apr-1.2.7-r3.ebuild88
-rw-r--r--dev-libs/apr/files/config.layout.patch25
-rw-r--r--dev-libs/apr/files/digest-apr-1.2.7-r33
4 files changed, 123 insertions, 1 deletions
diff --git a/dev-libs/apr/ChangeLog b/dev-libs/apr/ChangeLog
index af827a601918..a8c27577dca5 100644
--- a/dev-libs/apr/ChangeLog
+++ b/dev-libs/apr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/apr
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.66 2006/06/28 18:54:56 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.67 2006/07/07 05:05:50 vericgar Exp $
+
+*apr-1.2.7-r3 (07 Jul 2006)
+
+ 07 Jul 2006; Michael Stewart <vericgar@gentoo.org>
+ +files/config.layout.patch, +apr-1.2.7-r3.ebuild:
+ Use a config.layout instead of command line options to work around bug 139033.
28 Jun 2006; Tobias Scherbaum <dertobi123@gentoo.org> apr-0.9.12.ebuild:
ppc stable, #138011
diff --git a/dev-libs/apr/apr-1.2.7-r3.ebuild b/dev-libs/apr/apr-1.2.7-r3.ebuild
new file mode 100644
index 000000000000..86c1328b1818
--- /dev/null
+++ b/dev-libs/apr/apr-1.2.7-r3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-1.2.7-r3.ebuild,v 1.1 2006/07/07 05:05:50 vericgar Exp $
+
+inherit autotools
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6 urandom debug"
+RESTRICT="test"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # for some reason not all the .m4 files that are referenced in
+ # configure.in exist, so we remove all references and include every
+ # .m4 file in build using aclocal via eautoreconf
+ # See bug 135463
+ sed -i -e '/sinclude/d' configure.in
+ AT_M4DIR="build" eautoreconf
+
+ epatch ${FILESDIR}/config.layout.patch
+
+}
+
+src_compile() {
+
+
+ myconf="--enable-layout=gentoo"
+
+ # For now we always enable ipv6. Testing has shown that is still works
+ # correctly in ipv4 systems, and currently, the ipv4-only support
+ # is broken in apr. (ipv6 is enabled by default)
+ #myconf="${myconf} $(use_enable ipv6)"
+
+ myconf="${myconf} --enable-threads"
+ myconf="${myconf} --enable-nonportable-atomics"
+ if use urandom; then
+ einfo "Using /dev/urandom as random device"
+ myconf="${myconf} --with-devrandom=/dev/urandom"
+ else
+ einfo "Using /dev/random as random device"
+ myconf="${myconf} --with-devrandom=/dev/random"
+ fi
+
+ useq debug && myconf="${myconf} --enable-maintainer-mode"
+
+ # We pre-load the cache with the correct answer! This avoids
+ # it violating the sandbox. This may have to be changed for
+ # non-Linux systems or if sem_open changes on Linux. This
+ # hack is built around documentation in /usr/include/semaphore.h
+ # and the glibc (pthread) source
+ # See bugs 24215 and 133573
+ echo 'ac_cv_func_sem_open=${ac_cv_func_sem_open=no}' >> ${S}/config.cache
+
+ econf ${myconf} || die "Configure failed"
+
+ # Make sure we use the system libtool
+ sed -i 's,$(apr_builddir)/libtool,/usr/bin/libtool,' build/apr_rules.mk
+ sed -i 's,${installbuilddir}/libtool,/usr/bin/libtool,' apr-1-config
+ rm libtool
+
+ emake || die "Make failed"
+}
+
+src_install() {
+
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc CHANGES NOTICE LICENSE
+}
+
+pkg_postinst() {
+ ewarn "We are now using the system's libtool rather then bundling"
+ ewarn "our own. You will need to rebuild Apache and possibly other"
+ ewarn "software if you get a message similiar to the following:"
+ ewarn
+ ewarn " /usr/share/apr-1/build-1/libtool: No such file or directory"
+ ewarn
+}
diff --git a/dev-libs/apr/files/config.layout.patch b/dev-libs/apr/files/config.layout.patch
new file mode 100644
index 000000000000..66fa868c0bbe
--- /dev/null
+++ b/dev-libs/apr/files/config.layout.patch
@@ -0,0 +1,25 @@
+--- config.layout.orig 2006-07-06 21:44:41.000000000 -0700
++++ config.layout 2006-07-06 21:46:26.000000000 -0700
+@@ -229,3 +229,22 @@
+ infodir: ${exec_prefix}/share/info
+ libsuffix: -${APR_MAJOR_VERSION}
+ </Layout>
++
++# Gentoo layout
++<Layout gentoo>
++ prefix: /usr
++ exec_prefix: ${prefix}
++ bindir: ${exec_prefix}/bin
++ sbindir: ${exec_prefix}/bin
++ libdir: ${exec_prefix}/lib
++ libexecdir: ${exec_prefix}/modules
++ mandir: ${prefix}/man
++ sysconfdir: ${prefix}/conf
++ datadir: /usr/share/apr-${APR_MAJOR_VERSION}
++ installbuilddir: ${datadir}/build-${APR_MAJOR_VERSION}
++ includedir: ${prefix}/include/apr-${APR_MAJOR_VERSION}
++ localstatedir: ${prefix}
++ libsuffix: -${APR_MAJOR_VERSION}
++</Layout>
++
++
diff --git a/dev-libs/apr/files/digest-apr-1.2.7-r3 b/dev-libs/apr/files/digest-apr-1.2.7-r3
new file mode 100644
index 000000000000..13dfeb0ca3cd
--- /dev/null
+++ b/dev-libs/apr/files/digest-apr-1.2.7-r3
@@ -0,0 +1,3 @@
+MD5 aea926cbe588f844ad9e317157d60175 apr-1.2.7.tar.gz 1102370
+RMD160 9dfeb562b376c32261b8a263887a05515c4afbe2 apr-1.2.7.tar.gz 1102370
+SHA256 4bde26d8168216f00e0f652e34e20e527dab38edca6a7c0d85aea542bf0fc5fa apr-1.2.7.tar.gz 1102370