summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2006-06-04 13:23:34 +0000
committerLuca Longinotti <chtekk@gentoo.org>2006-06-04 13:23:34 +0000
commit6dba41358cec32dace46b7e470f66326eeded237 (patch)
tree76dede5ff7c76b2417a7831f63094ea6798298cf /dev-libs/apr-util
parentupdate l7-filter patch version - bug #133017 (diff)
downloadgentoo-2-6dba41358cec32dace46b7e470f66326eeded237.tar.gz
gentoo-2-6dba41358cec32dace46b7e470f66326eeded237.tar.bz2
gentoo-2-6dba41358cec32dace46b7e470f66326eeded237.zip
Fix bug #133871.
(Portage version: 2.1_rc1-r3)
Diffstat (limited to 'dev-libs/apr-util')
-rw-r--r--dev-libs/apr-util/ChangeLog6
-rw-r--r--dev-libs/apr-util/apr-util-0.9.12.ebuild19
-rw-r--r--dev-libs/apr-util/apr-util-0.9.7.ebuild19
-rw-r--r--dev-libs/apr-util/apr-util-1.2.2.ebuild19
-rw-r--r--dev-libs/apr-util/apr-util-1.2.7.ebuild22
5 files changed, 33 insertions, 52 deletions
diff --git a/dev-libs/apr-util/ChangeLog b/dev-libs/apr-util/ChangeLog
index d252684c30e1..84d1b4ba9f27 100644
--- a/dev-libs/apr-util/ChangeLog
+++ b/dev-libs/apr-util/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/apr-util
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.50 2006/04/27 16:05:46 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.51 2006/06/04 13:23:34 chtekk Exp $
+
+ 04 Jun 2006; Luca Longinotti <chtekk@gentoo.org> apr-util-0.9.7.ebuild,
+ apr-util-0.9.12.ebuild, apr-util-1.2.2.ebuild, apr-util-1.2.7.ebuild:
+ Fix bug #133871 for all apr-util versions save the all-stable one.
27 Apr 2006; Marien Zwart <marienz@gentoo.org> Manifest:
Fixing SHA256 digest, pass four
diff --git a/dev-libs/apr-util/apr-util-0.9.12.ebuild b/dev-libs/apr-util/apr-util-0.9.12.ebuild
index 6387dd0a9169..dc1e09984c8c 100644
--- a/dev-libs/apr-util/apr-util-0.9.12.ebuild
+++ b/dev-libs/apr-util/apr-util-0.9.12.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-0.9.12.ebuild,v 1.4 2006/05/18 18:19:19 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-0.9.12.ebuild,v 1.5 2006/06/04 13:23:34 chtekk Exp $
-inherit eutils flag-o-matic libtool
+inherit eutils flag-o-matic libtool db-use
DESCRIPTION="Apache Portable Runtime Library"
HOMEPAGE="http://apr.apache.org/"
@@ -31,16 +31,11 @@ src_compile() {
myconf="${myconf} $(use_with gdbm)"
if use berkdb; then
- if has_version '=sys-libs/db-4.3*'; then
- myconf="${myconf} --with-dbm=db43
- --with-berkeley-db=/usr/include/db4.3:/usr/$(get_libdir)"
- elif has_version '=sys-libs/db-4.2*'; then
- myconf="${myconf} --with-dbm=db42
- --with-berkeley-db=/usr/include/db4.2:/usr/$(get_libdir)"
- elif has_version '=sys-libs/db-4*'; then
- myconf="${myconf} --with-dbm=db4
- --with-berkeley-db=/usr/include/db4:/usr/$(get_libdir)"
- fi
+ dbver="$(db_findver sys-libs/db)" || die "Unable to find db version"
+ dbver="$(db_ver_to_slot "$dbver")"
+ dbver="${dbver/\./}"
+ myconf="${myconf} --with-dbm=db${dbver}
+ --with-berkeley-db=$(db_includedir):/usr/$(get_libdir)"
else
myconf="${myconf} --without-berkeley-db"
fi
diff --git a/dev-libs/apr-util/apr-util-0.9.7.ebuild b/dev-libs/apr-util/apr-util-0.9.7.ebuild
index cde278836acb..cbc7f601b393 100644
--- a/dev-libs/apr-util/apr-util-0.9.7.ebuild
+++ b/dev-libs/apr-util/apr-util-0.9.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-0.9.7.ebuild,v 1.11 2006/04/19 01:00:25 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-0.9.7.ebuild,v 1.12 2006/06/04 13:23:34 chtekk Exp $
-inherit eutils libtool
+inherit eutils libtool db-use
DESCRIPTION="Apache Portable Runtime Library"
HOMEPAGE="http://apr.apache.org/"
@@ -29,16 +29,11 @@ src_compile() {
myconf="${myconf} $(use_with gdbm)"
if use berkdb; then
- if has_version '=sys-libs/db-4.3*'; then
- myconf="${myconf} --with-dbm=db43
- --with-berkeley-db=/usr/include/db4.3:/usr/$(get_libdir)"
- elif has_version '=sys-libs/db-4.2*'; then
- myconf="${myconf} --with-dbm=db42
- --with-berkeley-db=/usr/include/db4.2:/usr/$(get_libdir)"
- elif has_version '=sys-libs/db-4*'; then
- myconf="${myconf} --with-dbm=db4
- --with-berkeley-db=/usr/include/db4:/usr/$(get_libdir)"
- fi
+ dbver="$(db_findver sys-libs/db)" || die "Unable to find db version"
+ dbver="$(db_ver_to_slot "$dbver")"
+ dbver="${dbver/\./}"
+ myconf="${myconf} --with-dbm=db${dbver}
+ --with-berkeley-db=$(db_includedir):/usr/$(get_libdir)"
else
myconf="${myconf} --without-berkeley-db"
fi
diff --git a/dev-libs/apr-util/apr-util-1.2.2.ebuild b/dev-libs/apr-util/apr-util-1.2.2.ebuild
index 0993009efef3..af03584c5f11 100644
--- a/dev-libs/apr-util/apr-util-1.2.2.ebuild
+++ b/dev-libs/apr-util/apr-util-1.2.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.2.2.ebuild,v 1.5 2006/04/19 01:00:25 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.2.2.ebuild,v 1.6 2006/06/04 13:23:34 chtekk Exp $
-inherit eutils libtool
+inherit eutils libtool db-use
DESCRIPTION="Apache Portable Runtime Library"
HOMEPAGE="http://apr.apache.org/"
@@ -38,16 +38,11 @@ src_compile() {
myconf="${myconf} $(use_with sqlite3)"
if use berkdb; then
- if has_version '=sys-libs/db-4.3*'; then
- myconf="${myconf} --with-dbm=db43
- --with-berkeley-db=/usr/include/db4.3:/usr/$(get_libdir)"
- elif has_version '=sys-libs/db-4.2*'; then
- myconf="${myconf} --with-dbm=db42
- --with-berkeley-db=/usr/include/db4.2:/usr/$(get_libdir)"
- elif has_version '=sys-libs/db-4*'; then
- myconf="${myconf} --with-dbm=db4
- --with-berkeley-db=/usr/include/db4:/usr/$(get_libdir)"
- fi
+ dbver="$(db_findver sys-libs/db)" || die "Unable to find db version"
+ dbver="$(db_ver_to_slot "$dbver")"
+ dbver="${dbver/\./}"
+ myconf="${myconf} --with-dbm=db${dbver}
+ --with-berkeley-db=$(db_includedir):/usr/$(get_libdir)"
else
myconf="${myconf} --without-berkeley-db"
fi
diff --git a/dev-libs/apr-util/apr-util-1.2.7.ebuild b/dev-libs/apr-util/apr-util-1.2.7.ebuild
index 6755e926dd29..a5179ff50dac 100644
--- a/dev-libs/apr-util/apr-util-1.2.7.ebuild
+++ b/dev-libs/apr-util/apr-util-1.2.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.2.7.ebuild,v 1.3 2006/05/18 18:19:19 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.2.7.ebuild,v 1.4 2006/06/04 13:23:34 chtekk Exp $
-inherit eutils flag-o-matic libtool
+inherit eutils flag-o-matic libtool db-use
DESCRIPTION="Apache Portable Runtime Library"
HOMEPAGE="http://apr.apache.org/"
@@ -40,19 +40,11 @@ src_compile() {
myconf="${myconf} $(use_with sqlite3)"
if use berkdb; then
- if has_version '=sys-libs/db-4.4*'; then
- myconf="${myconf} --with-dbm=db44
- --with-berkeley-db=/usr/include/db4.4:/usr/$(get_libdir)"
- elif has_version '=sys-libs/db-4.3*'; then
- myconf="${myconf} --with-dbm=db43
- --with-berkeley-db=/usr/include/db4.3:/usr/$(get_libdir)"
- elif has_version '=sys-libs/db-4.2*'; then
- myconf="${myconf} --with-dbm=db42
- --with-berkeley-db=/usr/include/db4.2:/usr/$(get_libdir)"
- elif has_version '=sys-libs/db-4*'; then
- myconf="${myconf} --with-dbm=db4
- --with-berkeley-db=/usr/include/db4:/usr/$(get_libdir)"
- fi
+ dbver="$(db_findver sys-libs/db)" || die "Unable to find db version"
+ dbver="$(db_ver_to_slot "$dbver")"
+ dbver="${dbver/\./}"
+ myconf="${myconf} --with-dbm=db${dbver}
+ --with-berkeley-db=$(db_includedir):/usr/$(get_libdir)"
else
myconf="${myconf} --without-berkeley-db"
fi