summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-02-26 17:32:40 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-02-26 17:32:40 +0000
commitd98e76a38388f76a36ff15ac3ace39e1344ab937 (patch)
tree4fb1bd8bce058c8d62218eefd949661e99318102 /dev-lang
parentppc stable, bug #211240 (diff)
downloadgentoo-2-d98e76a38388f76a36ff15ac3ace39e1344ab937.tar.gz
gentoo-2-d98e76a38388f76a36ff15ac3ace39e1344ab937.tar.bz2
gentoo-2-d98e76a38388f76a36ff15ac3ace39e1344ab937.zip
Removed older versions, and duplicate license files (see bug #211534)
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/R/ChangeLog6
-rw-r--r--dev-lang/R/R-2.2.1-r1.ebuild114
-rw-r--r--dev-lang/R/R-2.6.1-r1.ebuild9
-rw-r--r--dev-lang/R/R-2.6.1.ebuild113
-rw-r--r--dev-lang/R/R-2.6.2.ebuild9
5 files changed, 7 insertions, 244 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 1037b08f0dd0..c8ddd2e8a899 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.116 2008/02/19 14:20:01 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.117 2008/02/26 17:32:40 bicatali Exp $
+
+ 26 Feb 2008; Sébastien Fabbro <bicatali@gentoo.org> -R-2.2.1-r1.ebuild,
+ -R-2.6.1.ebuild, R-2.6.1-r1.ebuild, R-2.6.2.ebuild:
+ Removed older versions, and duplicate license files (see bug #211534)
19 Feb 2008; Brent Baude <ranger@gentoo.org> R-2.6.1-r1.ebuild:
stable ppc64, bug 210229
diff --git a/dev-lang/R/R-2.2.1-r1.ebuild b/dev-lang/R/R-2.2.1-r1.ebuild
deleted file mode 100644
index 578e44bd4308..000000000000
--- a/dev-lang/R/R-2.2.1-r1.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.2.1-r1.ebuild,v 1.8 2007/11/20 21:56:47 wolf31o2 Exp $
-
-inherit fortran toolchain-funcs flag-o-matic
-
-DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
-HOMEPAGE="http://www.r-project.org/"
-SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ia64 ppc ppc64 sparc x86"
-IUSE="blas jpeg nls png readline tk X lapack"
-
-RDEPEND=">=dev-lang/perl-5.6.1-r3
- >=dev-libs/libpcre-7.3
- app-arch/bzip2
- readline? ( >=sys-libs/readline-4.1-r3 )
- jpeg? ( >=media-libs/jpeg-6b-r2 )
- png? ( >=media-libs/libpng-1.2.1 )
- blas? ( virtual/blas )
- lapack? ( virtual/lapack )
- tk? ( dev-lang/tk
- dev-lang/tcl )
- X? ( x11-libs/libX11 )"
-DEPEND="${RDEPEND}
- X? ( x11-proto/xproto
- x11-libs/libXt
- x11-libs/libX11 )"
-
-AT_M4DIR="${S}/m4"
-
-pkg_setup() {
- # Test for a 64 bit architecture - f2c won't work on 64 bit archs with R.
- # Thanks to vapier for providing the test.
- cd "${T}"
- echo 'int main(){}' > test.c
- $(tc-getCC) -c test.c -o test.o
- if file test.o | grep -qs 64-bit ; then
- einfo "64 bit architecture detected, using g77 or gfortran."
- FORTRAN="gfortran g77 ifc"
- else
- FORTRAN="gfortran g77 f2c"
- fi
- rm -f test.{c,o}
- fortran_pkg_setup
-
- filter-ldflags -Wl,-Bdirect -Bdirect
-}
-
-src_compile() {
- local myconf="--enable-R-profiling --enable-R-shlib --enable-linux-lfs"
-
- if use tk; then
- #configure needs to find the files tclConfig.sh and tkConfig.sh
- myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib/tclConfig.sh
- --with-tk-config=/usr/lib/tkConfig.sh"
- else
- myconf="${myconf} --without-tcltk"
- fi
-
- econf \
- --with-system-zlib \
- --with-system-bzlib \
- --with-system-pcre \
- $(use_enable nls) \
- $(use_with blas) \
- $(use_with lapack) \
- $(use_with jpeg jpeglib) \
- $(use_with png libpng) \
- $(use_with readline) \
- $(use_with X x) \
- ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- make \
- prefix="${D}"/usr \
- mandir="${D}"/usr/share/man \
- infodir="${D}"/usr/share/info \
- rhome="${D}"/usr/$(get_libdir)/R \
- install || die "Installation Failed"
-
- # fix the R wrapper script to have the correct R_HOME_DIR
- # sed regexp borrowed from included debian rules
- sed \
- -e "/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/$(get_libdir)/R:" \
- -i "${D}"/usr/$(get_libdir)/R/bin/R \
- || die "sed failed."
-
- # The same kinds of seds are needed for these variables too, see bug 115140
- sed \
- -e "/^R_SHARE_DIR=.*/s::R_SHARE_DIR=/usr/$(get_libdir)/R/share:" \
- -e "/^R_INCLUDE_DIR=.*/s::R_INCLUDE_DIR=/usr/$(get_libdir)/R/include:" \
- -e "/^R_DOC_DIR=.*/s::R_DOC_DIR=/usr/$(get_libdir)/R/doc:" \
- -i "${D}"/usr/$(get_libdir)/R/bin/R \
- || die "sed failed."
-
- # R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
- # the 2nd one is corrected by above sed, the first is replaced by a symlink
- cd "${D}"/usr/bin/
- rm R
- dosym ../$(get_libdir)/R/bin/R /usr/bin/R
- dodir /etc/env.d
- echo -n \
- "LDPATH=\"/usr/$(get_libdir)/R/lib\"" \
- > "${D}"/etc/env.d/99R
- cd "${S}"
-
- dodoc AUTHORS BUGS COPYING* ChangeLog FAQ *NEWS README \
- RESOURCES THANKS VERSION Y2K
-}
diff --git a/dev-lang/R/R-2.6.1-r1.ebuild b/dev-lang/R/R-2.6.1-r1.ebuild
index 5afce64b2e1c..2bb10b600906 100644
--- a/dev-lang/R/R-2.6.1-r1.ebuild
+++ b/dev-lang/R/R-2.6.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.6.1-r1.ebuild,v 1.10 2008/02/19 14:20:01 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.6.1-r1.ebuild,v 1.11 2008/02/26 17:32:40 bicatali Exp $
inherit fortran flag-o-matic bash-completion
@@ -123,13 +123,6 @@ src_install() {
EOF
doenvd 99R || die "doenvd failed"
- # avoid copying licenses but link then because of html docs
- rm -f "${D}"usr/share/doc/${PF}/{COPYING,COPYING.LIB} \
- "${D}"${R_HOME}/COPYING
- dosym "${PORTDIR}"/licenses/GPL-2 /usr/share/doc/${PF}/COPYING
- dosym "${PORTDIR}"/licenses/LGPL-2.1 /usr/share/doc/${PF}/COPYING.LIB
- dosym "${PORTDIR}"/licenses/GPL-2 ${R_HOME}/COPYING
-
dobashcompletion "${WORKDIR}"/R.bash_completion
}
diff --git a/dev-lang/R/R-2.6.1.ebuild b/dev-lang/R/R-2.6.1.ebuild
deleted file mode 100644
index 37e7d7e74168..000000000000
--- a/dev-lang/R/R-2.6.1.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.6.1.ebuild,v 1.2 2008/01/16 16:26:19 bicatali Exp $
-
-inherit fortran flag-o-matic
-
-DESCRIPTION="Language and environment for statistical computing and graphics"
-HOMEPAGE="http://www.r-project.org/"
-SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-
-IUSE="doc java jpeg lapack minimal nls png readline tk X"
-
-# common depends
-CDEPEND="dev-lang/perl
- >=dev-libs/libpcre-7.3
- app-arch/bzip2
- virtual/blas
- virtual/ghostscript
- readline? ( sys-libs/readline )
- jpeg? ( media-libs/jpeg )
- png? ( media-libs/libpng )
- lapack? ( virtual/lapack )
- tk? ( dev-lang/tk )
- X? ( x11-libs/libXmu x11-misc/xdg-utils )"
-
-DEPEND="${CDEPEND}
- dev-util/pkgconfig
- doc? ( virtual/latex-base
- || ( dev-texlive/texlive-fontsrecommended virtual/tetex ) )"
-
-RDEPEND="${CDEPEND}
- java? ( >=virtual/jre-1.5 )"
-
-pkg_setup() {
- FORTRAN="gfortran ifc g77"
- fortran_pkg_setup
- export FFLAGS="${FFLAGS:--O2}"
- [[ ${FORTRANC} = gfortran || ${FORTRANC} = if* ]] && \
- export FCFLAGS="${FCFLAGS:-${FFLAGS}}"
-
- filter-ldflags -Wl,-Bdirect -Bdirect
-
- # this is needed to properly compile additional R packages
- # (see bug #152379)
- append-flags -std=gnu99
-}
-
-src_compile() {
- use lapack && \
- export LAPACK_LIBS="$(pkg-config --libs lapack)"
-
- if use X; then
- export R_BROWSER="$(type -p xdg-open)"
- export R_PDFVIEWER="$(type -p xdg-open)"
- fi
-
- econf \
- --enable-R-profiling \
- --enable-memory-profiling \
- --enable-R-shlib \
- --enable-linux-lfs \
- --with-system-zlib \
- --with-system-bzlib \
- --with-system-pcre \
- --with-blas="$(pkg-config --libs blas)" \
- --docdir=/usr/share/doc/${PF} \
- rdocdir=/usr/share/doc/${PF} \
- $(use_enable nls) \
- $(use_with lapack) \
- $(use_with tk tcltk) \
- $(use_with jpeg jpeglib) \
- $(use_with !minimal recommended-packages) \
- $(use_with png libpng) \
- $(use_with readline) \
- $(use_with X x) \
- || die "econf failed"
- emake || die "emake failed"
-
- if use doc; then
- export VARTEXFONTS="${T}/fonts"
- emake info pdf || die "emake docs failed"
- fi
-}
-
-src_install() {
- # -j1 because creates various dirs sequentially (hit should be small)
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
-
- if use doc; then
- emake DESTDIR="${D}" \
- install-info install-pdf || die "emake install docs failed"
- fi
-
- # env files
- echo "LDPATH=\"/usr/$(get_libdir)/R/lib\"" > 99R
- doenvd 99R || die "doenvd failed"
-
- # dealing with licenses
- rm -f "${D}"usr/share/doc/${PF}/{COPYING,COPYING.LIB}
- dosym "${PORTDIR}"/licenses/GPL-2 /usr/share/doc/${PF}/COPYING
- dosym "${PORTDIR}"/licenses/LGPL-2.1 /usr/share/doc/${PF}/COPYING.LIB
-}
-
-pkg_config() {
- if use java; then
- einfo "Re-initializing java paths for ${P}"
- R CMD javareconf
- fi
-}
diff --git a/dev-lang/R/R-2.6.2.ebuild b/dev-lang/R/R-2.6.2.ebuild
index c388663695a0..4ccaefc8cf00 100644
--- a/dev-lang/R/R-2.6.2.ebuild
+++ b/dev-lang/R/R-2.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.6.2.ebuild,v 1.1 2008/02/14 14:00:54 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.6.2.ebuild,v 1.2 2008/02/26 17:32:40 bicatali Exp $
inherit fortran flag-o-matic bash-completion
@@ -120,13 +120,6 @@ src_install() {
EOF
doenvd 99R || die "doenvd failed"
- # avoid copying licenses but link then because of html docs
- rm -f "${D}"usr/share/doc/${PF}/{COPYING,COPYING.LIB} \
- "${D}"${R_HOME}/COPYING
- dosym "${PORTDIR}"/licenses/GPL-2 /usr/share/doc/${PF}/COPYING
- dosym "${PORTDIR}"/licenses/LGPL-2.1 /usr/share/doc/${PF}/COPYING.LIB
- dosym "${PORTDIR}"/licenses/GPL-2 ${R_HOME}/COPYING
-
dobashcompletion "${WORKDIR}"/R.bash_completion
}