summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-04-03 23:13:35 +0000
committerMike Frysinger <vapier@gentoo.org>2015-04-03 23:13:35 +0000
commitd13e67427a336bd628cc112e602c9c87e22ef2de (patch)
tree9b22771c8dc2583460581d8841294ceb3b510a84 /dev-lang
parentMark arm/arm64/ia64/s390/sh stable. (diff)
downloadgentoo-2-d13e67427a336bd628cc112e602c9c87e22ef2de.tar.gz
gentoo-2-d13e67427a336bd628cc112e602c9c87e22ef2de.tar.bz2
gentoo-2-d13e67427a336bd628cc112e602c9c87e22ef2de.zip
Version bump #532702 by Longtime Gentoo User.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/yasm/ChangeLog7
-rw-r--r--dev-lang/yasm/yasm-1.3.0.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-lang/yasm/ChangeLog b/dev-lang/yasm/ChangeLog
index b8e3e7d18528..c33cb25a5322 100644
--- a/dev-lang/yasm/ChangeLog
+++ b/dev-lang/yasm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/yasm
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.66 2015/03/03 06:13:53 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.67 2015/04/03 23:13:35 vapier Exp $
+
+*yasm-1.3.0 (03 Apr 2015)
+
+ 03 Apr 2015; Mike Frysinger <vapier@gentoo.org> +yasm-1.3.0.ebuild:
+ Version bump #532702 by Longtime Gentoo User.
02 Mar 2015; Yixun Lan <dlan@gentoo.org> yasm-1.2.0-r1.ebuild:
add arm64 support, tested on A53 board
diff --git a/dev-lang/yasm/yasm-1.3.0.ebuild b/dev-lang/yasm/yasm-1.3.0.ebuild
new file mode 100644
index 000000000000..02548020116b
--- /dev/null
+++ b/dev-lang/yasm/yasm-1.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-1.3.0.ebuild,v 1.1 2015/04/03 23:13:35 vapier Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit python-r1
+
+DESCRIPTION="An assembler for x86 and x86_64 instruction sets"
+HOMEPAGE="http://yasm.tortall.net/"
+SRC_URI="http://www.tortall.net/projects/yasm/releases/${P}.tar.gz"
+
+LICENSE="BSD-2 BSD || ( Artistic GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm64 ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="nls python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/cython-0.14[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( AUTHORS )
+
+src_configure() {
+ use python && python_export_best
+
+ XMLTO=: \
+ econf \
+ $(use_enable python) \
+ $(use_enable python python-bindings) \
+ $(use_enable nls)
+}
+
+src_test() {
+ emake check
+}