summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2010-05-06 19:41:01 +0000
committerAlex Legler <a3li@gentoo.org>2010-05-06 19:41:01 +0000
commitb3e8783aa49f2c74217e215613ede70018d62665 (patch)
tree6786543d02b24179fb7e4f5678677f54e834402b /dev-lang
parentFix atom syntax (diff)
downloadgentoo-2-b3e8783aa49f2c74217e215613ede70018d62665.tar.gz
gentoo-2-b3e8783aa49f2c74217e215613ede70018d62665.tar.bz2
gentoo-2-b3e8783aa49f2c74217e215613ede70018d62665.zip
Remove old version. Cleanup in files/
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ruby/ChangeLog9
-rw-r--r--dev-lang/ruby/files/auto_gem.rb10
-rw-r--r--dev-lang/ruby/files/ruby-1.8.6-memory-leak.diff60
-rw-r--r--dev-lang/ruby/files/ruby-1.8.6-uclibc-udp.patch21
-rw-r--r--dev-lang/ruby/files/ruby-mkconfig.patch14
-rw-r--r--dev-lang/ruby/files/ruby18-mkmf-parallel-install.patch14
-rw-r--r--dev-lang/ruby/ruby-1.9.1_p243.ebuild195
7 files changed, 8 insertions, 315 deletions
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index c2f2381f2f9c..c3467aa7189d 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/ruby
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.445 2010/05/01 10:25:23 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.446 2010/05/06 19:41:00 a3li Exp $
+
+ 06 May 2010; Alex Legler <a3li@gentoo.org>
+ -files/ruby-1.8.6-memory-leak.diff,
+ -files/ruby18-mkmf-parallel-install.patch,
+ -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
+ -files/auto_gem.rb, -files/ruby-mkconfig.patch:
+ Remove old version. Cleanup in files/
*ruby-1.9.1_p376 (01 May 2010)
diff --git a/dev-lang/ruby/files/auto_gem.rb b/dev-lang/ruby/files/auto_gem.rb
deleted file mode 100644
index e7d564264d68..000000000000
--- a/dev-lang/ruby/files/auto_gem.rb
+++ /dev/null
@@ -1,10 +0,0 @@
-# DO NOT USE THIS FILE!
-# ---------------------
-# This file is a placebo for Ruby 1.9 to work with a legacy feature, Gentoo
-# added to Ruby 1.8 and earlier, loading rubygems automatically (auto_gem).
-# It is no longer needed, but ruby19 needs this file to operate properly on
-# a system containing older versions of Ruby and thus the legacy feature.
-#
-# REMOVAL NOTE:
-# You may remove this file if you are running a Ruby >=1.9.1 *only* system
-# or have disabled the Gentoo auto_gem.rb/RUBYOPT=auto_gem magic.
diff --git a/dev-lang/ruby/files/ruby-1.8.6-memory-leak.diff b/dev-lang/ruby/files/ruby-1.8.6-memory-leak.diff
deleted file mode 100644
index b71f4088f570..000000000000
--- a/dev-lang/ruby/files/ruby-1.8.6-memory-leak.diff
+++ /dev/null
@@ -1,60 +0,0 @@
-Index: ptr.c
-===================================================================
---- ptr.c (revision 12047)
-+++ ptr.c (working copy)
-@@ -53,6 +53,8 @@
- void
- dlptr_free(struct ptr_data *data)
- {
-+ if (!data)
-+ return;
- if (data->ptr) {
- DEBUG_CODE({
- printf("dlptr_free(): removing the pointer `0x%x' from the MemorySpace\n",
-@@ -69,4 +71,5 @@
- if (data->stype) dlfree(data->stype);
- if (data->ssize) dlfree(data->ssize);
- if (data->ids) dlfree(data->ids);
-+ dlfree(data);
- }
-
- void
-Index: sym.c
-===================================================================
---- sym.c (revision 12047)
-+++ sym.c (working copy)
-@@ -57,6 +57,8 @@
- void
- dlsym_free(struct sym_data *data)
- {
-+ if(!data)
-+ return;
- if( data->name ){
- DEBUG_CODE({
- printf("dlsym_free(): free(data->name:%s)\n",data->name);
-@@ -69,4 +71,5 @@
- });
- free(data->type);
- }
-+ dlfree(data);
- }
-
- VALUE
-Index: handle.c
-===================================================================
---- handle.c (revision 12047)
-+++ handle.c (working copy)
-@@ -10,7 +10,10 @@
- void
- dlhandle_free(struct dl_handle *dlhandle)
- {
-+ if (!dlhandle)
-+ return;
- if (dlhandle->ptr && dlhandle->open && dlhandle->enable_close) {
-- dlclose(dlhandle->ptr);
-+ dlclose(dlhandle->ptr);
- }
-+ dlfree(dlhandle);
- }
-
- VALUE
diff --git a/dev-lang/ruby/files/ruby-1.8.6-uclibc-udp.patch b/dev-lang/ruby/files/ruby-1.8.6-uclibc-udp.patch
deleted file mode 100644
index 07919d273d9d..000000000000
--- a/dev-lang/ruby/files/ruby-1.8.6-uclibc-udp.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Patch for bug 260760. Fixes UDP sockets on uClibc systems.
-
-diff --exclude '*~' -uNr ruby-1.8.6-p36.orig/configure.in ruby-1.8.6-p36/configure.in
---- configure.in.orig 2007-05-22 19:19:07.000000000 +0100
-+++ configure.in 2007-08-29 09:42:47.000000000 +0100
-@@ -707,6 +707,7 @@
- __ptr dnl
- bufpos dnl
- _p dnl
-+ __bufpos dnl
- ; do
- AC_TRY_COMPILE([#include <stdio.h>
- ],
-@@ -726,6 +727,7 @@
- [for frend in dnl
- _IO_read_end dnl
- bufread dnl
-+ __bufread dnl
- ; do
- AC_TRY_COMPILE([#include <stdio.h>
- ],
diff --git a/dev-lang/ruby/files/ruby-mkconfig.patch b/dev-lang/ruby/files/ruby-mkconfig.patch
deleted file mode 100644
index 4426ef90d7ed..000000000000
--- a/dev-lang/ruby/files/ruby-mkconfig.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Fix for mkconfig to be able to handle empty continued lines.
-Patch from [ruby-core:20420] via bug 234877.
-
---- mkconfig.rb.orig 2008-06-08 01:37:10.000000000 +0900
-+++ mkconfig.rb 2009-02-12 13:39:02.000000000 +0900
-@@ -54,7 +54,7 @@
- continued_name = name
- next
- end
-- when /^"(.+)"\s*(\\)?$/
-+ when /^"(.*)"\s*(\\)?$/
- if continued_line
- continued_line << $1
- unless $2
diff --git a/dev-lang/ruby/files/ruby18-mkmf-parallel-install.patch b/dev-lang/ruby/files/ruby18-mkmf-parallel-install.patch
deleted file mode 100644
index 26c05bbde378..000000000000
--- a/dev-lang/ruby/files/ruby18-mkmf-parallel-install.patch
+++ /dev/null
@@ -1,14 +0,0 @@
- Patch for bug 239101 by Matsuu Takuto, via Redmine issue 1337 (yes, really).
- Backported for 1.8.* by Alex Legler.
-
---- lib/mkmf.orig 2009-04-03 13:04:17.000000000 +0200
-+++ lib/mkmf.rb 2009-04-03 13:04:30.000000000 +0200
-@@ -1500,7 +1500,7 @@
- dest = "#{dir}/#{f}"
- mfile.puts dir, "install-so: #{dest}"
- unless $extout
-- mfile.print "#{dest}: #{f}\n"
-+ mfile.print "#{dest}: #{dir} #{f}\n"
- if (sep = config_string('BUILD_FILE_SEPARATOR'))
- f.gsub!("/", sep)
- dir.gsub!("/", sep)
diff --git a/dev-lang/ruby/ruby-1.9.1_p243.ebuild b/dev-lang/ruby/ruby-1.9.1_p243.ebuild
deleted file mode 100644
index b09d4703dcfb..000000000000
--- a/dev-lang/ruby/ruby-1.9.1_p243.ebuild
+++ /dev/null
@@ -1,195 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.9.1_p243.ebuild,v 1.2 2009/10/12 23:07:03 jer Exp $
-
-EAPI=2
-
-inherit autotools eutils flag-o-matic multilib versionator
-
-# Add patchlevel
-MY_P="${P/_/-}"
-
-# 1.9.1.0 -> 1.9
-SLOT=$(get_version_component_range 1-2)
-
-# 1.9.1.0 -> 1.9.1 (used in libdirs)
-RUBYVERSION=$(get_version_component_range 1-3)
-
-# 1.9 -> 19
-MY_SUFFIX=$(delete_version_separator 1 ${SLOT})
-
-DESCRIPTION="An object-oriented scripting language"
-HOMEPAGE="http://www.ruby-lang.org/"
-SRC_URI="mirror://ruby/${MY_P}.tar.bz2
- http://dev.a3li.info/gentoo/distfiles/${PN}-patches-${PVR}.tar.bz2"
-
-LICENSE="|| ( Ruby GPL-2 )"
-KEYWORDS="~amd64 ~hppa ~x86 ~x86-fbsd"
-IUSE="berkdb debug doc emacs examples gdbm ipv6 rubytests socks5 ssl tk xemacs"
-
-RDEPEND="
- berkdb? ( sys-libs/db )
- gdbm? ( sys-libs/gdbm )
- ssl? ( dev-libs/openssl )
- socks5? ( >=net-proxy/dante-1.1.13 )
- tk? ( dev-lang/tk[threads] )
- >=app-admin/eselect-ruby-20090909
- !=dev-lang/ruby-cvs-${SLOT}*
- !<dev-ruby/rdoc-2
- !dev-ruby/rexml"
-DEPEND="${RDEPEND}"
-PDEPEND="
- emacs? ( app-emacs/ruby-mode )
- xemacs? ( app-xemacs/ruby-modes )"
-
-PROVIDE="virtual/ruby"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- ewarn
- ewarn "It is highly recommended to install >=dev-ruby/rubygems-1.3.1-r30"
- ewarn "if you have Ruby 1.8 on this system installed, too."
- ewarn
- epause 5
-}
-
-src_prepare() {
- cd "${S}"
-
- EPATCH_FORCE="yes" EPATCH_SUFFIX="patch" \
- epatch "${WORKDIR}/patches-${PVR}"
-
- # Strip rake
- rm "bin/rake"
- rm "lib/rake.rb"
- rm -rf "lib/rake"
-
- # Fix a hardcoded lib path in configure script
- sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
- configure.in || die "sed failed"
-
- eautoreconf
-}
-
-src_configure() {
- # -fomit-frame-pointer makes ruby segfault, see bug #150413.
- filter-flags -fomit-frame-pointer
- # In many places aliasing rules are broken; play it safe
- # as it's risky with newer compilers to leave it as it is.
- append-flags -fno-strict-aliasing
-
- # Socks support via dante
- if use socks5 ; then
- # Socks support can't be disabled as long as SOCKS_SERVER is
- # set and socks library is present, so need to unset
- # SOCKS_SERVER in that case.
- unset SOCKS_SERVER
- fi
-
- # Increase GC_MALLOC_LIMIT if set (default is 8000000)
- if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
- append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
- fi
-
- # ipv6 hack, bug 168939. Needs --enable-ipv6.
- use ipv6 || myconf="--with-lookup-order-hack=INET"
-
- econf --program-suffix=${MY_SUFFIX} --enable-shared --enable-pthread \
- $(use_enable socks5 socks) \
- $(use_enable doc install-doc) \
- --enable-ipv6 \
- $(use_enable debug) \
- $(use_with berkdb dbm) \
- $(use_with gdbm) \
- $(use_with ssl openssl) \
- $(use_with tk) \
- ${myconf} \
- --enable-option-checking=no \
- || die "econf failed"
-}
-
-src_compile() {
- emake EXTLDFLAGS="${LDFLAGS}" || die "emake failed"
-}
-
-src_test() {
- emake test || die "make test failed"
-
- elog "Ruby's make test has been run. Ruby also ships with a make check"
- elog "that cannot be run until after ruby has been installed."
- elog
- if use rubytests; then
- elog "You have enabled rubytests, so they will be installed to"
- elog "/usr/share/${PN}-${RUBYVERSION}/test. To run them you must be a user other"
- elog "than root, and you must place them into a writeable directory."
- elog "Then call: "
- elog
- elog "ruby19 -C /location/of/tests runner.rb"
- else
- elog "Enable the rubytests USE flag to install the make check tests"
- fi
-}
-
-src_install() {
- # Ruby is involved in the install process, we don't want interference here.
- unset RUBYOPT
-
- # Creating the rubygems directories, bug #230163 once more.
- local MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
- keepdir /usr/$(get_libdir)/ruby${MY_SUFFIX}/gems/${RUBYVERSION}/{doc,gems,cache,specifications}
-
- export GEM_HOME="${D}/usr/$(get_libdir)/ruby${MY_SUFFIX}/gems/${RUBYVERSION}"
- export GEM_PATH="${GEM_HOME}/"
-
- LD_LIBRARY_PATH="${D}/usr/$(get_libdir)${LD_LIBRARY_PATH+:}${LD_LIBRARY_PATH}"
- RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${RUBYVERSION}"
- for d in $(find "${S}/ext" -type d) ; do
- RUBYLIB="${RUBYLIB}:$d"
- done
- export LD_LIBRARY_PATH RUBYLIB
-
- emake DESTDIR="${D}" install || die "make install failed"
-
- keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitelibdir']")
- keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitearchdir']")
-
- if use doc; then
- make DESTDIR="${D}" install-doc || die "make install-doc failed"
- fi
-
- if use examples; then
- dodir /usr/share/doc/${PF}
- cp -pPR sample "${D}/usr/share/doc/${PF}"
- fi
-
- dosym "libruby${MY_SUFFIX}$(get_libname ${PV%_*})" \
- "/usr/$(get_libdir)/libruby$(get_libname ${PV%.*})"
- dosym "libruby${MY_SUFFIX}$(get_libname ${PV%_*})" \
- "/usr/$(get_libdir)/libruby$(get_libname ${PV%_*})"
-
- dodoc ChangeLog NEWS doc/NEWS-1.8.7 README* ToDo
-
- if use rubytests; then
- dodir /usr/share/${PN}-${RUBYVERSION}
- cp -pPR test "${D}/usr/share/${PN}-${RUBYVERSION}"
- fi
-
- insinto /usr/$(get_libdir)/ruby${MY_SUFFIX}/vendor_ruby/${RUBYVERSION}/
- newins "${FILESDIR}/auto_gem.rb" auto_gem.rb
-}
-
-pkg_postinst() {
- if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
- eselect ruby set ruby${MY_SUFFIX}
- fi
-
- elog
- elog "To switch between available Ruby profiles, execute as root:"
- elog "\teselect ruby set ruby(18|19|...)"
- elog
-}
-
-pkg_postrm() {
- eselect ruby cleanup
-}