summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-06 16:15:24 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-06 16:15:24 +0000
commit066add0b813bbc61ea071f49ed90ef05c9b7a091 (patch)
tree53167a46011cc883ebcf2e835c7486d5b9f2012b /dev-lang
parenthttp://my.opera.com/desktopteam/blog/2010/12/06/extension-improvements-update... (diff)
downloadgentoo-2-066add0b813bbc61ea071f49ed90ef05c9b7a091.tar.gz
gentoo-2-066add0b813bbc61ea071f49ed90ef05c9b7a091.tar.bz2
gentoo-2-066add0b813bbc61ea071f49ed90ef05c9b7a091.zip
Version Bump, #347561
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/tcl/ChangeLog9
-rw-r--r--dev-lang/tcl/tcl-8.4.15.ebuild119
-rw-r--r--dev-lang/tcl/tcl-8.4.18.ebuild10
-rw-r--r--dev-lang/tcl/tcl-8.4.19.ebuild10
-rw-r--r--dev-lang/tcl/tcl-8.5.7.ebuild8
-rw-r--r--dev-lang/tcl/tcl-8.5.8-r1.ebuild4
-rw-r--r--dev-lang/tcl/tcl-8.5.8-r2.ebuild4
-rw-r--r--dev-lang/tcl/tcl-8.5.9.ebuild (renamed from dev-lang/tcl/tcl-8.5.8.ebuild)52
8 files changed, 51 insertions, 165 deletions
diff --git a/dev-lang/tcl/ChangeLog b/dev-lang/tcl/ChangeLog
index 9cbfe7c3f8a1..7acda33ab0d0 100644
--- a/dev-lang/tcl/ChangeLog
+++ b/dev-lang/tcl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/tcl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.127 2010/11/08 13:16:52 mduft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.128 2010/12/06 16:15:24 jlec Exp $
+
+*tcl-8.5.9 (06 Dec 2010)
+
+ 06 Dec 2010; Justin Lecher <jlec@gentoo.org> -tcl-8.4.15.ebuild,
+ tcl-8.4.18.ebuild, tcl-8.4.19.ebuild, tcl-8.5.7.ebuild, -tcl-8.5.8.ebuild,
+ tcl-8.5.8-r1.ebuild, tcl-8.5.8-r2.ebuild, +tcl-8.5.9.ebuild:
+ Version Bump, #347561
08 Nov 2010; Markus Duft <mduft@gentoo.org> tcl-8.5.8-r2.ebuild:
added ~x86-interix keyword
diff --git a/dev-lang/tcl/tcl-8.4.15.ebuild b/dev-lang/tcl/tcl-8.4.15.ebuild
deleted file mode 100644
index d0e613893af4..000000000000
--- a/dev-lang/tcl/tcl-8.4.15.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.15.ebuild,v 1.10 2010/06/15 23:46:51 mr_bones_ Exp $
-
-inherit autotools eutils multilib toolchain-funcs
-
-DESCRIPTION="Tool Command Language"
-HOMEPAGE="http://www.tcl.tk/"
-SRC_URI="mirror://sourceforge/tcl/${PN}${PV}-src.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="debug threads"
-
-DEPEND=""
-
-S=${WORKDIR}/${PN}${PV}
-
-pkg_setup() {
- if use threads ; then
- ewarn ""
- ewarn "PLEASE NOTE: You are compiling ${P} with"
- ewarn "threading enabled."
- ewarn "Threading is not supported by all applications"
- ewarn "that compile against tcl. You use threading at"
- ewarn "your own discretion."
- ewarn ""
- epause 5
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-8.4.11-multilib.patch
-
- # Bug 125971
- epatch "${FILESDIR}"/${P}-tclm4-soname.patch
-
- local d
- for d in */configure ; do
- cd "${S}"/${d%%/*}
- EPATCH_SINGLE_MSG="Patching nls cruft in ${d}" \
- epatch "${FILESDIR}"/tcl-configure-LANG.patch
- done
-
- cd "${S}"/unix
- eautoreconf
-}
-
-src_compile() {
- tc-export CC
- local local_config_use=""
-
- if use threads ; then
- local_config_use="--enable-threads"
- fi
-
- cd "${S}"/unix
- econf \
- $(use_enable threads) \
- $(use_enable debug symbols) || die
- emake || die
-}
-
-src_install() {
- #short version number
- local v1
- v1=${PV%.*}
-
- cd "${S}"/unix
- S= emake DESTDIR="${D}" install || die
-
- # fix the tclConfig.sh to eliminate refs to the build directory
- local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
- sed -i \
- -e "s,^TCL_BUILD_LIB_SPEC='-L.*/unix,TCL_BUILD_LIB_SPEC='-L$/usr/${mylibdir}," \
- -e "s,^TCL_SRC_DIR='.*',TCL_SRC_DIR='/usr/${mylibdir}/tcl${v1}/include'," \
- -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L.*/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/${mylibdir}," \
- -e "s,^TCL_BUILD_STUB_LIB_PATH='.*/unix,TCL_BUILD_STUB_LIB_PATH='/usr/${mylibdir}," \
- -e "s,^TCL_LIB_FILE='libtcl${v1}..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl${v1}\$\{TCL_DBGX\}.so\"," \
- -e "s,^TCL_CC_SEARCH_FLAGS='\(.*\)',TCL_CC_SEARCH_FLAGS='\1:/usr/${mylibdir}'," \
- -e "s,^TCL_LD_SEARCH_FLAGS='\(.*\)',TCL_LD_SEARCH_FLAGS='\1:/usr/${mylibdir}'," \
- "${D}"/usr/${mylibdir}/tclConfig.sh || die
-
- # install private headers
- insinto /usr/${mylibdir}/tcl${v1}/include/unix
- doins "${S}"/unix/*.h || die
- insinto /usr/${mylibdir}/tcl${v1}/include/generic
- doins "${S}"/generic/*.h || die
- rm -f "${D}"/usr/${mylibdir}/tcl${v1}/include/generic/tcl.h
- rm -f "${D}"/usr/${mylibdir}/tcl${v1}/include/generic/tclDecls.h
- rm -f "${D}"/usr/${mylibdir}/tcl${v1}/include/generic/tclPlatDecls.h
-
- # install symlink for libraries
- if use debug ; then
- dosym libtcl${v1}g.so /usr/${mylibdir}/libtcl${v1}.so
- dosym libtclstub${v1}g.a /usr/${mylibdir}/libtclstub${v1}.a
- fi
- dosym libtcl${v1}.so /usr/${mylibdir}/libtcl.so
- dosym libtclstub${v1}.a /usr/${mylibdir}/libtclstub.a
-
- dosym tclsh${v1} /usr/bin/tclsh
-
- cd "${S}"
- dodoc ChangeLog* README changes
-}
-
-pkg_postinst() {
- ewarn
- ewarn "If you're upgrading from tcl-8.3, you must recompile the other"
- ewarn "packages on your system that link with tcl after the upgrade"
- ewarn "completes. To perform this action, please run revdep-rebuild"
- ewarn "in package app-portage/gentoolkit."
- ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
- ewarn "upgrade them before this recompilation, too,"
- ewarn
-}
diff --git a/dev-lang/tcl/tcl-8.4.18.ebuild b/dev-lang/tcl/tcl-8.4.18.ebuild
index 23a8ed5d9713..b8977f194621 100644
--- a/dev-lang/tcl/tcl-8.4.18.ebuild
+++ b/dev-lang/tcl/tcl-8.4.18.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.18.ebuild,v 1.11 2010/06/15 23:46:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.18.ebuild,v 1.12 2010/12/06 16:15:24 jlec Exp $
inherit autotools eutils multilib toolchain-funcs
@@ -13,14 +13,12 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
IUSE="debug threads"
-DEPEND=""
-
S="${WORKDIR}/${PN}${PV}"
pkg_setup() {
if use threads ; then
ewarn ""
- ewarn "PLEASE NOTE: You are compiling ${PF} with"
+ ewarn "PLEASE NOTE: You are compiling ${P} with"
ewarn "threading enabled."
ewarn "Threading is not supported by all applications"
ewarn "that compile against tcl. You use threading at"
@@ -62,7 +60,7 @@ src_compile() {
cd "${S}"/unix
econf \
$(use_enable threads) \
- $(use_enable debug symbols) || die
+ $(use_enable debug symbols)
emake || die
}
diff --git a/dev-lang/tcl/tcl-8.4.19.ebuild b/dev-lang/tcl/tcl-8.4.19.ebuild
index 0bee571e5297..81ab667916ac 100644
--- a/dev-lang/tcl/tcl-8.4.19.ebuild
+++ b/dev-lang/tcl/tcl-8.4.19.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.19.ebuild,v 1.3 2010/06/15 23:46:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.19.ebuild,v 1.4 2010/12/06 16:15:24 jlec Exp $
inherit autotools eutils multilib toolchain-funcs
@@ -13,14 +13,12 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
IUSE="debug threads"
-DEPEND=""
-
S="${WORKDIR}/${PN}${PV}"
pkg_setup() {
if use threads ; then
ewarn ""
- ewarn "PLEASE NOTE: You are compiling ${PF} with"
+ ewarn "PLEASE NOTE: You are compiling ${P} with"
ewarn "threading enabled."
ewarn "Threading is not supported by all applications"
ewarn "that compile against tcl. You use threading at"
@@ -62,7 +60,7 @@ src_compile() {
cd "${S}"/unix
econf \
$(use_enable threads) \
- $(use_enable debug symbols) || die
+ $(use_enable debug symbols)
emake || die
}
diff --git a/dev-lang/tcl/tcl-8.5.7.ebuild b/dev-lang/tcl/tcl-8.5.7.ebuild
index 96ee13e6e4ae..2907f6a82f9b 100644
--- a/dev-lang/tcl/tcl-8.5.7.ebuild
+++ b/dev-lang/tcl/tcl-8.5.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.7.ebuild,v 1.13 2010/06/15 23:46:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.7.ebuild,v 1.14 2010/12/06 16:15:24 jlec Exp $
inherit autotools eutils flag-o-matic multilib toolchain-funcs
@@ -14,8 +14,6 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE="debug threads"
-DEPEND=""
-
S="${WORKDIR}/${MY_P}"
pkg_setup() {
@@ -54,7 +52,7 @@ src_compile() {
cd "${S}"/unix
econf \
$(use_enable threads) \
- $(use_enable debug symbols) || die
+ $(use_enable debug symbols)
emake || die
}
diff --git a/dev-lang/tcl/tcl-8.5.8-r1.ebuild b/dev-lang/tcl/tcl-8.5.8-r1.ebuild
index b992842b4f20..33ac2f50a1a3 100644
--- a/dev-lang/tcl/tcl-8.5.8-r1.ebuild
+++ b/dev-lang/tcl/tcl-8.5.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.8-r1.ebuild,v 1.9 2010/10/24 15:30:23 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.8-r1.ebuild,v 1.10 2010/12/06 16:15:24 jlec Exp $
EAPI="3"
@@ -51,7 +51,7 @@ src_configure() {
cd "${S}"/unix
econf \
$(use_enable threads) \
- $(use_enable debug symbols) || die
+ $(use_enable debug symbols)
}
src_compile() {
diff --git a/dev-lang/tcl/tcl-8.5.8-r2.ebuild b/dev-lang/tcl/tcl-8.5.8-r2.ebuild
index 9bfa4de07b45..141f093c9b53 100644
--- a/dev-lang/tcl/tcl-8.5.8-r2.ebuild
+++ b/dev-lang/tcl/tcl-8.5.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.8-r2.ebuild,v 1.2 2010/11/08 13:16:52 mduft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.8-r2.ebuild,v 1.3 2010/12/06 16:15:24 jlec Exp $
EAPI="3"
@@ -52,7 +52,7 @@ src_configure() {
cd "${S}"/unix
econf \
$(use_enable threads) \
- $(use_enable debug symbols) || die
+ $(use_enable debug symbols)
}
src_compile() {
diff --git a/dev-lang/tcl/tcl-8.5.8.ebuild b/dev-lang/tcl/tcl-8.5.9.ebuild
index 32a74355ede0..80fd21d5bd44 100644
--- a/dev-lang/tcl/tcl-8.5.8.ebuild
+++ b/dev-lang/tcl/tcl-8.5.9.ebuild
@@ -1,21 +1,22 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.8.ebuild,v 1.3 2010/06/15 23:46:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.9.ebuild,v 1.1 2010/12/06 16:15:24 jlec Exp $
+
+EAPI="3"
inherit autotools eutils flag-o-matic multilib toolchain-funcs
MY_P="${PN}${PV/_beta/b}"
+
DESCRIPTION="Tool Command Language"
HOMEPAGE="http://www.tcl.tk/"
SRC_URI="mirror://sourceforge/tcl/${MY_P}-src.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x86-solaris"
IUSE="debug threads"
-DEPEND=""
-
S="${WORKDIR}/${MY_P}"
pkg_setup() {
@@ -27,13 +28,10 @@ pkg_setup() {
ewarn "that compile against tcl. You use threading at"
ewarn "your own discretion."
ewarn ""
- epause 5
fi
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${PN}-8.5_alpha6-multilib.patch
# Bug 125971
@@ -43,7 +41,7 @@ src_unpack() {
eautoreconf
}
-src_compile() {
+src_configure() {
# workaround stack check issues, bug #280934
if use hppa; then
append-cflags "-DTCL_NO_STACK_CHECK=1"
@@ -54,7 +52,11 @@ src_compile() {
cd "${S}"/unix
econf \
$(use_enable threads) \
- $(use_enable debug symbols) || die
+ $(use_enable debug symbols)
+}
+
+src_compile() {
+ cd "${S}"/unix
emake || die
}
@@ -69,32 +71,34 @@ src_install() {
# fix the tclConfig.sh to eliminate refs to the build directory
local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
sed -i \
- -e "s,^TCL_BUILD_LIB_SPEC='-L.*/unix,TCL_BUILD_LIB_SPEC='-L$/usr/${mylibdir}," \
- -e "s,^TCL_SRC_DIR='.*',TCL_SRC_DIR='/usr/${mylibdir}/tcl${v1}/include'," \
- -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L.*/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/${mylibdir}," \
- -e "s,^TCL_BUILD_STUB_LIB_PATH='.*/unix,TCL_BUILD_STUB_LIB_PATH='/usr/${mylibdir}," \
+ -e "s,^TCL_BUILD_LIB_SPEC='-L.*/unix,TCL_BUILD_LIB_SPEC='-L${EPREFIX}/usr/${mylibdir}," \
+ -e "s,^TCL_SRC_DIR='.*',TCL_SRC_DIR='${EPREFIX}/usr/${mylibdir}/tcl${v1}/include'," \
+ -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L.*/unix,TCL_BUILD_STUB_LIB_SPEC='-L${EPREFIX}/usr/${mylibdir}," \
+ -e "s,^TCL_BUILD_STUB_LIB_PATH='.*/unix,TCL_BUILD_STUB_LIB_PATH='${EPREFIX}/usr/${mylibdir}," \
-e "s,^TCL_LIB_FILE='libtcl${v1}..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl${v1}\$\{TCL_DBGX\}.so\"," \
- -e "s,^TCL_CC_SEARCH_FLAGS='\(.*\)',TCL_CC_SEARCH_FLAGS='\1:/usr/${mylibdir}'," \
- -e "s,^TCL_LD_SEARCH_FLAGS='\(.*\)',TCL_LD_SEARCH_FLAGS='\1:/usr/${mylibdir}'," \
- "${D}"/usr/${mylibdir}/tclConfig.sh || die
+ "${ED}"/usr/${mylibdir}/tclConfig.sh || die
+ [[ ${CHOST} != *-darwin* ]] && sed -i \
+ -e "s,^TCL_CC_SEARCH_FLAGS='\(.*\)',TCL_CC_SEARCH_FLAGS='\1:${EPREFIX}/usr/${mylibdir}'," \
+ -e "s,^TCL_LD_SEARCH_FLAGS='\(.*\)',TCL_LD_SEARCH_FLAGS='\1:${EPREFIX}/usr/${mylibdir}'," \
+ "${ED}"/usr/${mylibdir}/tclConfig.sh
# install private headers
insinto /usr/${mylibdir}/tcl${v1}/include/unix
doins "${S}"/unix/*.h || die
insinto /usr/${mylibdir}/tcl${v1}/include/generic
doins "${S}"/generic/*.h || die
- rm -f "${D}"/usr/${mylibdir}/tcl${v1}/include/generic/tcl.h
- rm -f "${D}"/usr/${mylibdir}/tcl${v1}/include/generic/tclDecls.h
- rm -f "${D}"/usr/${mylibdir}/tcl${v1}/include/generic/tclPlatDecls.h
+ rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tcl.h
+ rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tclDecls.h
+ rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tclPlatDecls.h
# install symlink for libraries
- dosym libtcl${v1}.so /usr/${mylibdir}/libtcl.so
- dosym libtclstub${v1}.a /usr/${mylibdir}/libtclstub.a
+ dosym libtcl${v1}.so /usr/${mylibdir}/libtcl.so || die
+ dosym libtclstub${v1}.a /usr/${mylibdir}/libtclstub.a || die
- dosym tclsh${v1} /usr/bin/tclsh
+ dosym tclsh${v1} /usr/bin/tclsh || die
cd "${S}"
- dodoc ChangeLog* README changes
+ dodoc ChangeLog* README changes || die
}
pkg_postinst() {